Playbar + turntable using AD converter and switch


Hi all,

Since I've switched to the PLAYBAR as my primary speaker I wasn't able to play my vinyl records anymore. After researching for a solution without having to spent over 350 euros for the a CONNECT unit I stumbled on the topic below:

https://en.community.sonos.com/components-228996/playbar-and-turntable-with-pre-amp-6735603/index1.html

Today I received the AD converter and Toslink switch and connected them to my PLAYBAR, tv and turntable. The sound coming out of tv is as good and crisp as ever. The problem is when I switch to the signal from the turntable. When I play the record the sound keeps falling away. You can also hear it when you turn off the record and turn the volume of the PLAYBAR up, you hear intervals where the the signal falls away. It is like the signal isn't strong enough.

I tried several things:

- Tested the cables and switched them between the PLAYBAR, converter and switch. Same noise.
- Connected the turntable directly to the PLAYBAR, without the switch in between. No result.
- Tested it with a pre-amp (with my turntable on 'phono') and with the built-in pre-amp (on 'line').

All with the same result, I can hear one second of the track playing, then it falls away for a second and then it returns again.

I hope you guys can help me, thanks in advance!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.