Playbar and turntable (with pre-amp)?

  • 26 February 2016
  • 41 replies
  • 16709 views

I have a question for which I have found half the answer, but not all of it so far... Situation is as follows:
- My only speaker at home at the moment is a Playbar, it might get extended with another Play (1/3/5) at some point. I have no passive speakers to use.
- I would like to use the playbar with a turntable, which I would operate as a stand-alone device, i.e. not connected to any further system / receiver. The turntable has a built-in pre-amp.
- I gather I can hook up the turntable with the sonos system using a connect device.

--> Question: does this setup require a connect:amp, or would a connect be enough? Again, no additional passive speakers to use, all I want to achieve is linking the turntable with the playbar.

Thanks for any insights 🙂

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

41 replies

Sorry about that, didn't realize.
Hi everyone, this seems to be mostly about connecting to a play bar, but thought I'd ask this anyway. . I have an Audio Technica AT-LP120-USB, it has a Pre-amp "LINE" with a 150 mV output. I have it connected directly to my Sonos Connect Amp. I also have the line output set to 10. However, I would guess that even at max volume, I'm only getting about 30% out of my speakers. I have 4 Play 1's. Any advice? Do I need an external pre-amp?Double posting isn't helpful. Please see response on the other thread.
Hi everyone, this seems to be mostly about connecting to a play bar, but thought I'd ask this anyway. . I have an Audio Technica AT-LP120-USB, it has a Pre-amp "LINE" with a 150 mV output. I have it connected directly to my Sonos Connect Amp. I also have the line output set to 10. However, I would guess that even at max volume, I'm only getting about 30% out of my speakers. I have 4 Play 1's. Any advice? Do I need an external pre-amp?
Just now reading the responses, i will try the direct turntable to playbar optical tonight and see if that works (and the headphone jack test).
Well, you're most welcome, but I'll be honest, I don't even have a turntable set up in my system, so I'm working completely theoretically here. Hope you can figure out where it's failing.
Hi Bruce,

Thanks for the feedback. it's such a finicky system. I would just get the CONNECT but it's hard to justify as the turntable is actually cheaper than the sonos device. I'll try your idea. This turntable has a built in preamp but i bought another preamp just to test out if it works or not. I guess I have to keep getting the toys for sonos for this to work. It's crazy that the CONNECT AMP is $350
thanks again.
Yea, the problem is that this is really an unsupported method of getting turntable data in to the Sonos ecosystem. The usual way to connect a turntable is to use a CONNECT, rather than trying to input through the optical input on the PLAYBAR, so there's just not a lot of experience out there on which to build a base of knowledge on how to troubleshoot this, especially remotely across the internet. Might be different if I was sitting in front of everything.

I've heard of pre-amp switches that are a bit "finicky" in as much as they look like they're on, but actually haven't made full contact. No idea if this is the issue here. Is there any way to connect a set of headphones to the output of the turntable, to see if it's putting out a line level signal?

My thought is, with all of the variables that are in the equation, you need to test each device to make sure that it is working properly before moving down the line to the next device.
hi
i used two different toslink dacs and tried two different optical cables (through the playbar and they both worked) and still i get no sound. my record player has a preamp built in and it’s brwnd new out of the box and still low volume sound only through the turntable .
targo98, I'd be suspect on the toslink switch. What happens when you remove it and connect the optical directly to the PLAYBAR? I think I'd work on that setup, getting it working 100% before I added back in the switch. Of course, it could also be the RCA to digital converter that's the issue. Obviously, the TV part of it works, but I'm wondering if maybe the switch is broken, possibly. Remove as many as the variables, get it working "normally" with the data going straight through to the PLAYBAR first, then re-introduce the switch.

Umm, one more question, though. Do you have a pre-amp on the signal coming out of the turntable, before it goes in to the digital converter? I *think* that the digital converter would be expecting a line level input, not a phono level input.

But no, there shouldn't be any special settings. You'd set the controller app on "TV" as normal, and it should play. The PLAYBAR would not have the ability to tell the difference between the turntable and the TV, since the light path only travels one way.
i have the same problem. worked for a day or two and then stopped all together. changed adc and changed optical cable and still nothing!
I’ve tried connecting my Audio Technica LP120 to an RCA to digital converter and then connected the optical cord to a toslink switch but getting no sound out of the playbar. Are there any settings or anything i need to setup on the playbar to get it to work? Playbar works great with the tv but nothing with the turntable. I hear a faint sound directly out of the turntable but nothing through the speaker. I’ve tried it with the switch on line in and phono.
Gemma, did you manage to get sound playing through your surrounds form vinyl?
I just took the great advice here and purchased the Audio Technica LP120 along with an ADC and Toslink Switch.... Hopefully I will be in vinyl heaven by Wednesday. A big thanks to all of the great advice I have read here. Much appreciated.

Result. All set up and sounds great
I just took the great advice here and purchased the Audio Technica LP120 along with an ADC and Toslink Switch.... Hopefully I will be in vinyl heaven by Wednesday. A big thanks to all of the great advice I have read here. Much appreciated.
I think the problem is that you're expecting stuff to come out of surrounds, but you're only feeding the PLAYBAR a stereo signal. Go in to the app, under room settings, advanced room settings, and change the surround speaker to play "FULL" rather than "AMBIENT", and you should get what you're looking for.i am not so sure, as it is coming through the optical
I think the problem is that you're expecting stuff to come out of surrounds, but you're only feeding the PLAYBAR a stereo signal. Go in to the app, under room settings, advanced room settings, and change the surround speaker to play "FULL" rather than "AMBIENT", and you should get what you're looking for.
Hi all, turntable newbie here with a pro ject carbon debut phono usb TT in the line in on my tv, playing through the playbar just as the tv does. However TT is not playing through 2 x play1s as surrounds, which makes the TT sound rubbish compared to a streamed tune. Would Ratty's suggestions above about coverting to optical and bypassing the tv mean that the surrounds would work again? Really cant work out why they are not playing...
Any advice is gratefully recieved!
Thx jgatie but I am not connecting the turntable to the play5 but to the playbar directly as is states at the beginning of this threat.
Having the play5s linked to the playbar allows me to play music form the play5s (sonos app, spotify) but not when the signal is from the playbar (with the turntable connected to it)
I have a playbar and two Play5 linked to the playbar. I used the solution to plug the turntable via the playbar but the sound is as "TV", so no stereo in the play5s 😞 . I assume this only works if the playbase is the only speaker. Correct?

The line-in on the Play:5 is deactivated when used as surround speakers.
I have a playbar and two Play5 linked to the playbar. I used the solution to plug the turntable via the playbar but the sound is as "TV", so no stereo in the play5s 😞 . I assume this only works if the playbase is the only speaker. Correct?
Userlevel 2
Badge +1
Hi esusanto. All the info you need is contained in this thread.
I have playbar as well and just bought LP60. Can you fully describe in details how you connect LP60 to tv and to Playbar? Thanks
Userlevel 2
Badge +1
I purchased the items suggested by Ratty...ref links....worked a treat.
hmmm well i gave it a shot and it didnt do the trick...
There's no such thing as an rca to hdmi cable. At least, not one that isn't a complete con at any rate.