Question

Onkyo receiver can't find Sonos

  • 29 December 2020
  • 15 replies
  • 242 views

Apologize if this has been asked. Searched the forum and couldn’t find an answer.

I have 2 Onkyo receivers in my setup and am having the same issue with both. Currently have a TX NR686 and TX NR585. The 686 is connected to a 3rd Gen Sonos connect and the 585 is connected to a brand new Sonos port. Neither the connect nor the port can be found via the onkyo setup/works with Sonos search. I get the same time out on both and a resulting connect cannot be found message.

I have tried rebooting the router, updating firmware, rebooting receivers and removing and reinstalling both Sonos components in the system. Nothing has made a difference.

My assumption is that the problem is in my network setup. I have not been able to get to a solution using onkyo tech support. So I’m trying here. My wifi is a eero mesh system. I’m far from a network expert so looking for advice on things to try. 
 

any help is appreciated.


15 replies

Is the Sonos system wired, and if so where? And how do the Onkyo units connect to the network?

The sonos system and the onkyo receivers are hooked up via wifi. They are all on the same network,

So, they’re all on the eero WiFi? And is the WiFi of the original router (assuming there is one) turned off?

Yes all are on the eero network. The cable modem connects straight to the eero unit.

According to this older setup video it looks like the receiver should just see the Sonos boxes on the local network. 

Assuming you have everything on the same IP subnet (same ‘network’) I can’t immediately see why it wouldn’t work. Sorry. Maybe Sonos tech staff can shed some light.

Just checking - you mention updating the firmware - was that on the receivers as well?

Zdoor,


The eero WiFi system is a dual band system and broadcasts a signal using the same SSID for both 2.4Ghz and 5ghz bands, I have two ‘quick’ suggestions that might be worth a try…

 

Perhaps try the ‘works with Sonos’ search for devices after ‘pausing’ the 5Ghz band as mentioned in this link below … just to see if the dual band is causing an issue with the search.

https://www.podfeet.com/blog/2020/09/eero-pause-5ghz/

 

The other option (which can perhaps be seen as an alternative) is to wire one Sonos device to the primary eero router hub and switch the Sonos products to run on SonosNet and then try the ‘works with’ search again.

 

I would guess if the above options fail, then it might be the Onkyo Receivers are perhaps waiting for a firmware update to catchup with recent Sonos updates, which has occasionally been the case in the past.

 

Thanks for the replies. The receivers are running the latest firmware available. I just tried the SonosNet setup. Hadn’t tried that before but still got nothing. I’m going to try switching the sonosNet channel and turning off the 5g band and see what happens...

Thanks for the replies. The receivers are running the latest firmware available. I just tried the SonosNet setup. Hadn’t tried that before but still got nothing. I’m going to try switching the sonosNet channel and turning off the 5g band and see what happens...

I wouldn’t have thought that Sonosnet would make a difference, as your Onkyo doesn’t understand it - the Onkyo ‘just’ uses normal wifi. I also have a 686, but all I can remember is that I needed to install the latest update on the Onkyo to get it working, but it sounds like you’ve already done that. My 686 is wired in, though, via a switch and an EoP plug - maybe that makes a difference.

However, having got it working when I first bought the 686, I ended up simply turning it off - it just doesn’t do anything that wonderful. I still use the Onkyo remote for other sources, as I can’t see the point of using an app. It is irritating when something should work, but doesn’t, though - so I have sympathy.

Same issue here. Tx-rz3100. Wasn’t working so updated firmware and now no sonos devices show. On a Unifi network, trued sonos system off of sonosnet, reviver wired and wireless. Best i can get is some devices to show right after sonos reboot but does not last. Smells like a bad update. Very unreliable feature

I’m having the same issue with a TX NR686 and my Port. I’m assuming it’s related to a recent firmware update.

I’m having same/similar issues with my new NR696.  Onkyo told me that their engineering dept is looking into it….for over a week.  Have you contacted Onkyo?  The more of us the better….very frustrating.  I bought all this stuff specifically for it all to integrate!

Same issue

Possible expensive solution.

Sonos connect or port into Sonos AMP into Receiver HDMI ARC port.

Connect triggers amp which triggers receiver input

 

Be better if Sonos would hold Onlyo accountable and Onkyo would maintain their ***. If any of you have spare time, best to call them and open tickets to present some pressure to resolve. A bit of a niche feature so we have to work together on this.

 

*Moderator Note: Modified in accordance with the community guidelines.*

I’ve been working with Onkyo support for several months on this.  I have a TX-RZ630 and 2 x Sonos Connect that were working before their 1081 firmware update.  I was told they are still “gathering specifics” and I have provided an obnoxious amount of detailed troubleshooting network specifics to them.  Originally they stated it was my network, but being a network admin for datacenter sized environments I quickly proved that wrong and provided evidence of the issue.  I believe it to be shotty firmware on the Onkyo unit.  Their engineering department has stated they have no spare RZ level units in inventory.  It’s a really frustrating problem because it worked fine before I updated to firmware 1081 and now 1091 on the Onkyo device.  It works fine when I manually select the input which leads me to believe it’s a network level (layer 2 or 3) issue with a UDP broadcast request sent FROM the Sonos Connect device to signal the Onkyo unit out of network standby mode.

Reply