Multiple CONNECT units (wired); Trouble with playlists

  • 2 March 2020
  • 4 replies
  • 158 views

Badge +1

I have had a single CONNECT for a long time and mostly really like it. I have a pretty large .flac library and things have been reasonably good and reliable.

I recently connected a 2nd CONNECT via CAT6e (the other is also wired) and it worked almost perfectly except that it could not load certain playlists that I had created within the Controller app, originally for the first (and for a long time the only) CONNECT on my network.

The newly-added CONNECT would play files, albums, webstreams etc but would NOT play my large hodge-podge playlist (it’s around 1,000 songs) but it WOULD play other smaller playlists lists. In fact, not only would it not play the 1,000-cong list it simply would not load.

I went around and around with tech support and even had them remote-in to my machine looking for oddities. They suggested the usual (reboot router, switches etc) but none of it worked.

I tried setting very specific folder permissions and that would not fix it either. Then it dawned on me:

What if I load the lengthy playlist in the CONNECT that IS working and then save the playlist with a new name?, so I did just that.

I then cleared the queue on the original CONNECT (TV Room) and invoked the 2nd CONNECT (Media Room) and dragged and dropped the newly-named playlist (remember...I simply saved the existing 1,000-song list it with a new name while it was open in the CONNECT that COULD read it) into the Media Room unit.

It worked.

So, I then cleared the queue from the newly-installed Media Room unit and went back to my original unit and dragged the “save(d) as” playlist into the TV Room unit. The playlist immediately loaded.

I then deleted the original playlist that would load on the TV Room Connect but not the Media Room Connect and then RENAMED the list that I had just done via “save as”, and I renamed it back to the playlist’s original name.

This too worked, and on each of the two Connect units. I did not try to play the same list on both simultaneously as this really isn’t a scenario that I can envision ever doing.

WONDERING…

Would simply changing the name of the existing playlist (the one that would not load on the 2nd unit) have done the trick? Maybe...but I am not going to deal with that. I would suggest that if you run into this issue though you give it a try before you do the ‘save as’ approach as it will save you a bit of time. On the other hand...working on a copy is sometimes a nice insurance policy because of possible corruption of the original.

One LAST thing...I have no idea if this is part of the issue or not: The CONNECT that I recently added was not purchased from Sonos, but from a friend. I had been using it in another residence so it was never on my network to begin with (though when I DID power it up the desktop ad found it and did a system update). Anyway, the newly-added unit was actually considerably older than the CONNECT that I bought direct from Sonos.

So far everything is running smoothly...my guess is that there are some bugs in the code that are ‘outsmarted’ by renaming the playlist. Luckily I had two bits or hardware to help diagnose the issue (which would have been tougher to figure out had I only the one CONNECT and had it failed to load there).

I don’t know if you have run into this issue but (knock on wood) the fix appears to be working.

Mark


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Hi Mark, Thank you for bringing your concern(s) to us here and welcome to the Sonos Community. We are not aware of any bugs that you have mentioned but perhaps you can submit us a diagnostic report and reply back here with the report number when you are experiencing the issue.

We can also see if other Community members can chime in who may be running into this as well.

Badge +1

John: Thanks. However, during my phone call with tech support (and they really tried a lot of stuff) I generated a ton of diagnostics after we tried each step. I think I submitted four different diagnostics; they even took remote control of my machine using Team Viewer but could find nothing.

I looked at the error logs and saw nothing. I did however forget a few details:

  1. AFTER I had almost given up I removed the pointer to the library and then re-added it.
  2. When I did this the playlist DID load into the Media Room device. I was amazed.
  3. When I tried to play the long playlist it looked like it was going to but then it started flying through the list, stopping on one song in the list which it played. I looked at the ERROR LOG and saw that the message was that the Media Room unit “could not access [share]”.
  4. I tried modifying folder permissions etc and once again flushing the library and having it re-learned. The same error resulted.
  5. ONLY when I did what I outlined (the save as, delete original long playlist, rename copy of playlist to original name) did the system start to work as advertised.

I have to say that the cat from tech support tried many different things, even when remotely connected but none of them worked. What I did as outlined above DID work and STILL works (fingers crossed).

So in a nutshell the older CONNECT (Media Room) plays everything, including long playlists.

Oh, one last morsel…

BEFORE I renamed the playlist and went that route...when the playlist did load in the Media Room CONNECT the first time every entry showed up as the file name (i.e. 01-Black Dog.flac”) and none of the cover art was visible.

Then after the first ‘forget and relearn’ the library the playlist showed up with Titles rather than file names AND the cover art was also shown, but none would play.

ONLY after the rename exercise (of the lengthy playlist) could I get BOTH units to successfully load and play the playlists.

Hey Mark, Thank you for the additional information, as you have things up and working now, I would suggest that you track the issue and let us know if/when it may happen again. You can then follow up with our phone agents or on here with a new diagnostic report and report number. We will also need your full network topology with the model names and numbers of the products that are wired or wirelessly connected on your network for any modem, router(s), extenders, access points or switches (managed or unmanaged).

As you describe the issue corrects when you re-establish the playlist. This points to something breaking in that connection/pathway and you are just re-establishing that token to find the music/playlist each time.

Badge +1

Hey Mark, ...

As you describe the issue corrects when you re-establish the playlist. This points to something breaking in that connection/pathway and you are just re-establishing that token to find the music/playlist each time.

Yeah, that makes sense - the whole ‘refresh’ thing (even if a sort of brute-force method) does indeed work.

Again, the system remains stable thus far...so I’m happy.