Question

How does Autoplay on new Sonos Amp work?


Badge
Just got a new Sonos Amp, and I have my TV connected via ARC HDMI and a turntable connected via the line in. It strikes me that the new Amp is unique in that it's the only Sonos product that has TV mode as well as a line input, which leads me to my question: When I turn off my TV, the Amp's zone stays in TV mode until I select a new source (pretty much the same behavior as a PlayBar, Beam, etc.), but if I start playing a record, Autoplay on the Line In doesn't seem to function, and I have to manually select the Line In as the source through the app. Is this the expected behavior, or do I need to tweak my settings?

I know that for my PlayBar, if I'm watching TV, AutoPlay won't override the TV audio when a Line In source kicks in
for another zone that's set to AutPlay for a group that includes the PlayBar. But for the new Amp, it seems like a no-brainer that the Line In should play automatically if there is currently no signal through ARC.

7 replies

Userlevel 7
Badge +22
I'm wondering if TV autoplay and Line In Autoplay can't both be turned on.
Badge
Just set it up last night so haven't had a lot of time to fiddle, but my recollection is that I could only set up Autoplay settings for the Line In.
Userlevel 7
Badge +22
Line In Autoplay definitely seems pretty broken. I could only get it randomly to kick in when on regular music not TV sound. Couldn't get it to autoplay off TV sound at all.

They need to build some better logic into that.
Userlevel 7
Badge +25
Hi guys, the Amp can have Autoplay turned on in the settings for both the Analog Line-In and the TV input. The Analog Line-In can even have the input directed to a different room if desired.

If the Amp is receiving both a TV and an Analog Line-In input at the same time, the TV is designed to "win out" and the Amp won't swap out to Analog Line-In.
Badge
Ryan, I don't see any options in the settings that govern Autoplay for the TV input (ARC in my case). Referring back to my original question, if I've turned the TV off and the AMP is no longer receiving a signal from the TV, shouldn't the Analog Line-In Autoplay kick in when I start my record player? That hasn't been my experience thus far (the Amp stays on TV as the source), which is why I wondered if my settings are off.
Userlevel 7
Badge +25
Yes, if the Amp is not playing the TV input, it should switch to the Line-In when the audio signal is received.

Settings for the TV Autoplay are in Settings > Room Settings > [Room name] > TV and it's a toggle for TV Autoplay. The Line-in Autoplay settings are under Advanced Audio > Line-In.
Badge
Yep, I see the TV Autoplay setting now. If the Line-In Autoplay doesn’t automatically switch over when there is no longer a TV signal, could that mean that the Line-In Source Level is set too low?

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings