Connect Issues

  • 4 February 2021
  • 6 replies
  • 63 views

Hi have a connect gen2 that is very temperamental. Sometimes it works great and other times it just won’t connect anything. Is there a more reliable alternative to link my turntable and CD player to my Sonos system?

 

Thanks!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7

You could get the Sonos Port (which replaced the discontinued Connect Gen 2) or get a Sonos Five (although it only has one line-in port). 

Have you tried unplugging your Connect and rebooting your router to see if it improves the performance of the Connect? You could also try wiring one of your Sonos products to your router or network with an ethernet cable to create a SonosNet mesh network. This usually improves the network performance of all of your speakers.

Thanks for the reply. Unfortunately because of where my router is, I can’t connect anything via an Ethernet cable. I have tried all the things you’ve suggested and they will work for a while and then the connect just drops off again. I’ll have a look at the Port.

A Port would not be a panacea.

If you’re experiencing dropouts from the Line-In then to start with try increasing the Line-In audio delay in the Connect’s settings. If that doesn’t work you may have to resort to using Compression (Settings > System > Audio Compression).

Maybe drop out is the wrong term. Apologies for not being clearer. Here’s the issue. I put an album or cd on and they play fine. I change to a different album or cd and it all quits working. I then have to reboot everything to get it to come back and connect back to the system and it will work fine again. Or, I put an album on and it plays fine. Then I group the connect with a different room to play the album somewhere else and not only will it not play in the new room, when I go back to the original room, it won’t connect. It’s very frustrating.

Is Line-In Autoplay enabled? If so do the problems occur when you start Line-In play from the controller? 

You do know that to play somewhere else you don’t need to group with the Connect? You can simply tell that room to play from the Connect’s Line-In.

(By the way, the advice in my last post still applies so you might want to try the suggestions anyway.)

Hi- line in auto play is enabled and delay is set to max. And yes the problems are that sometimes the line in won’t even show up in the app. That’s when I have to reboot everything. And I’ve already had to resort to compression when I first set it up about 18 months ago. The sound would just cut out and in before I did that. And thanks for the info on just changing the line in location. Hadn’t thought about that instead of grouping! Duh! LOL