Question

Connect:Amp - Delay between wired and wireless speakers?

  • 15 March 2017
  • 6 replies
  • 2621 views

I'm considering getting a Sonos setup, but already have some nice wired speakers I want to keep in one of the rooms. My questions is, can I connect these to the Connect:Amp along with some Play 1 speakers and have them all play together? I'm worried there could be some delay between the wired speakers and the wireless speakers.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

CONNECT:AMP will play in sync. When grouped, Sonos players are in sync at their own outputs. Propagation times on speaker cables are of course infinitesimally small.

Where some have run into issues is with a CONNECT feeding an AV receiver, since the latter often applies digital processing to the sound which delays it fractionally.
Ratty, how noticeable is the fractional delay. I also have a traditional home theater set up, that I'd like to implement into the sonos system, via a CONNECT.
Hi ou812, this is hard to answer because it depends on your Amplifiers and also on the settings. My Onkyo TX is fine. There is no delay hearable, if using the setting pure audio. Bit also with other settings I assume the delay is less than 0.01 seconds. Therefore it works fine for me. You have also take into consideration that the speed of sound is something about 300m/s. Therefore if there are 10m in between the delay that you hear, even if they are 100% synchron is 10m/300 m/s = 0,033 seconds.
Thanx so much for sharing your knowledge and experience with me. I'm running a pioneer elite AV amp. The reason I grew concerned is my house is an open concept design and the home theatre is sort of surrounded by sonos product. So in essence I shouldn't be overly concerned ?
Userlevel 4
Badge +11
I have a room with an old Sony STRBD1070 with a Connect attached. The AV amp is attached to a KEF 5.1 speaker set. When grouped it plays perfectly in sync with the rest of the house, although the amp is only feeding 2.1 then. If I select a surround mode on the amp then the audio goes very slightly behond the rest of the house, but then I only really want surround for films. The amp sees the optical output from the Connect as stereo and the optical output from the bluray as decodeable so sorts itself out anyway. I personally think this is the best way to enjoy Sonos and surround sound - the playbar has too many restrictions for me.
Nick, many thanx, really appreciate the knowledge and experience.