Audio Dropouts using Sonos Connect to send TV audio to Stereo Pair of Play1s

  • 12 January 2019
  • 4 replies
  • 107 views

Audio chain is as follows: LGU75UK6190 TV --> Optical Out --> Optical to analog converter --> Analog IN on Sonos Connect --> Stereo Pair of Play1s

We've been experiencing random audio dropouts on the TV audio which seem to be related to how long we watch (the longer we watch the more dropouts we experience). The Connect is in a cabinet below the TV. We leave the cabinet open when we're watching movies to keep things cool down there, but it doesn't seem to affect the dropouts.

I have checked and recheckd all the physical connections, set static IPs for all our Sonos components, and fiddled with everything I can think to fiddle with. Dropouts continue.

Any ideas here?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

What do the LED's do on the CONNECT when you get these dropouts? That would likely let us know if the device is experiencing a heat related reset.

I've never been a fan of using a CONNECT for a TV, due to the amount of data often included in a TV audio signal, have you attempted to set the line in to "compressed" to see if that helps? Unfortunately (and I don't have this setup to test), that may likely add some additional delay to the audio signal, but it might be at least helpful to identify whether we're talking about a heat issue, or a data saturation issue.

And of course, there's always the possibility of wifi interference, although your statement about the longer you use it, the more likely it seems to happen leads me to believe that it's a small chance. Glad to see you've assigned static IPs, at least we can rule that one out.

Have you tried a simple power cycle on the CONNECT?

I am, of course, making a lot of guesses here. Your best bet for concrete data is to submit a system diagnostic within 10 minutes of replicating this issue, and either post the number here, or contact Sonos to discuss it. There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
Thanks for your input. Setting the audio to Compressed introduced an unbearable lag - it was like watching a badly dubbed Bruce Lee film, so that didn't last long. :D

I've had the LED on the Connect turned off as we find it (and most other status lights on components) irritating while watching. Sadly that means I have no idea what it might do during a dropout. Something to try next time, I suppose.

As for WIFI interference, there's always a chance, though I hard-wire as much as possible. The COnnect is connected via ethernet cable, though the Play1 pair is wireless. I'd have to add a small switch to the tv setup to get everything wired in. Might try it though to see if there's any effect.

We've been running TV audio using the onboard speakers for the last 24 hours as a test. No dropouts there (nor did I expect any). Next experiment will be moving the Connect out of the cabinet to increase air flow while in use. If that doesn't work, I'll be selling the Connect in favour of a soundbar or more likely more Sonos speakers for the house/garage/workshop.
Well, a PLAYBAR, PLAYBASE, or Beam would certainly remove much of the issues that you're experiencing, since they're actually designed for the application, rather than your current system. You could even use the pair of PLAY:1s as surround speakers.

It's unfortunate, but the CONNECT was never designed to be a TV interface. There's just no way to get around the processing/buffering delay on the analog input, and then the saturation of the signal seems to often be an issue, especially in borderline wifi environments.

Best of luck, whichever way you end up going.
Yes, I'm kind of annoyed that the Connect doesn't have an optical input, but as it's one of the first Sonos products to be released I understand why it doesn't. And adding one now could cut into sales of PlayBar/PlayBase/Beam units.... 😛