Answered

Vinyl to Sonos system


I have a playbar, sub and 2 x play 1 speakers which is great for tv, streaming and cd’s. I have a separate analogue system for vinyl but would like to play it through my Sonos system.
I have been given all sorts of advice on how to do it but it all conflicts, the end reult is I have bought a Connect on the advice that I can pay my vinyl on existing Kenwood turntable through existing Kenwood KA-3020SE amp and connecting the tape out to the Connect. This doesn’t work as it seems to me like the tape out isn’t amplified.
My questions are :- in simple terms please!
How do I play my analogue turntable through my Sonos sound system?
Do I need to buy a pre-amp?
Am I wasting my time with the Connect?
Given that it’s possible, what connects to what and do I have to hard wire connect an output from the Connect to my Sonos speakers or will it connect wirelessly?
No jargon please guys I’m not a young guy and I’ve only just moved on from a wind up gramophone :):):)
icon

Best answer by pwt 16 December 2018, 11:26

You should already have everything that you need. I will assume that your Sonos system is working correctly, including having your Connect appear as one of your Sonos 'Rooms'.

The Tape Out should be at line level, which is what's required for the Connect in terms of amplification. Assuming that your turntable is playing fine through the Kenwood amplifier and its attached speakers, this is what you need to check:

1. That you are actually sending the turntable signal to the Tape Out. Check your amplifier manual.
2. That you have connected the Tape Out output to the Connect's Line In input using standard RCA/phono cables. Make sure you're using the Connect input, not the output.
3. That you have selected the Connect's Line In as the source for playback on your selected Sonos speakers (Browse -> Line In on the mobile Sonos app.)

These are the basic checks.

View original

3 replies

Userlevel 6
Badge +16
You should already have everything that you need. I will assume that your Sonos system is working correctly, including having your Connect appear as one of your Sonos 'Rooms'.

The Tape Out should be at line level, which is what's required for the Connect in terms of amplification. Assuming that your turntable is playing fine through the Kenwood amplifier and its attached speakers, this is what you need to check:

1. That you are actually sending the turntable signal to the Tape Out. Check your amplifier manual.
2. That you have connected the Tape Out output to the Connect's Line In input using standard RCA/phono cables. Make sure you're using the Connect input, not the output.
3. That you have selected the Connect's Line In as the source for playback on your selected Sonos speakers (Browse -> Line In on the mobile Sonos app.)

These are the basic checks.
Thanks for your help, I just needed to know what I was trying to do was achievable, it’s all up and working now. I just needed to select the correct source and the correct line.. Thanks again!
Userlevel 6
Badge +16
That's good. Glad you have it working.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings