unable to add the shared folder error 1002

  • 27 December 2018
  • 3 replies
  • 312 views

I have just spent close to £1000 on Sonos kit after reading that the set was a 'breeze'!
I cannot add my itunes library despite trying for the last 4 hours - time i will never get back.
I have checked all the firewall advice, rebooted all devices and router. Turned off devices close to router. I need this resolved or the system is useless and it looks like it is not just me who is affected - the speakers will be going back.
Diagnostic response number is 1167535472.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +20
I have just spent close to £1000 on Sonos kit after reading that the set was a 'breeze'!
I cannot add my itunes library despite trying for the last 4 hours - time i will never get back.
I have checked all the firewall advice, rebooted all devices and router. Turned off devices close to router. I need this resolved or the system is useless and it looks like it is not just me who is affected - the speakers will be going back.
Diagnostic response number is 1167535472.


Hi there,

Welcome to the community and thanks for sending in the report. Your router is reporting an external IP address for your computer when Sonos is trying to connect to the music share. Most of the time rebooting the router, then rebooting the computer clears this up. If not, there's likely a setting on the router which needs to be changed. If rebooting doesn't help, please give us a call and our phone team will help get things up and running for you. Our phone number and hours can be found here.
re-boot didn't work. i managed to get it to load by reducing the name of the mac in sys preferences but it then crashed the whole system. i removed the list on the mac using the minus button and tried to re-install the library but now just get the same error code up. There are no other devices on my network and i live in a rural location. i have never had an issue with the router and i am struggling to believe you market such buggy SW. This was sold as plug and play?!...
Userlevel 7
Badge +20
re-boot didn't work. i managed to get it to load by reducing the name of the mac in sys preferences but it then crashed the whole system. i removed the list on the mac using the minus button and tried to re-install the library but now just get the same error code up. There are no other devices on my network and i live in a rural location. i have never had an issue with the router and i am struggling to believe you market such buggy SW. This was sold as plug and play?!...

Reducing the computer's name to less than 15 can help, but I can't see how that would crash your whole system. It's a good idea to reboot the computer after changing its name. At any rate, it may be best to have our phone team troubleshoot this one live. Please give us a call, our phone number's found here.