Sonos beam with 2 Play 1s Surround Issue

  • 28 January 2020
  • 17 replies
  • 161 views

Badge

I just got a TCL R625 which I am using with a Sonos Beam (Hooked up via Arc HDMI) and two Sonos Play 1s. The Roku software is updated to 9.2.2 build 6106-88. I can get surround from every TV app (Amazon, Disney, Apple TV, Vudu) except for Netflix which appears to be playing back in stereo? The TV is set to autodetect the audio source but I have tried auto passthrough, dolby digital etc and no change. 

What is odd is I have this exact Sonos surround setup on the older TCL R615 and it plays surround in Netflix just fine.

Every device is up to date (Sonos even says Dolby 5.1 signal while the Netflix stream is playing). I have noticed the surround going to my xbox seems to work off and on as well which is odd. It also shows Dolby 5.1 in the sonos app while playing. 


17 replies

Since the Sonos is working everywhere except for one app, I don’t think this could be a Sonos issue.  I would check to be sure that the Netflix app has any audio settings, and make sure they are locked to Dolby Digital, and not Dolby Digital Plus, etc. 

And I’d do the same thing with the xBox. I’m guessing there’s something where it is sending a stereo signal on a Dolby Digital carrier. 

I’ve had this same issue with pre-season football games. My local station is broadcasting a Dolby Digital signal, but the game they’re sending only is in stereo. 

Badge

Since the Sonos is working everywhere except for one app, I don’t think this could be a Sonos issue.  I would check to be sure that the Netflix app has any audio settings, and make sure they are locked to Dolby Digital, and not Dolby Digital Plus, etc. 

And I’d do the same thing with the xBox. I’m guessing there’s something where it is sending a stereo signal on a Dolby Digital carrier. 

I’ve had this same issue with pre-season football games. My local station is broadcasting a Dolby Digital signal, but the game they’re sending only is in stereo. 

Thanks for the reply. Unfortunately the Netflix app doesn't have any settings within the app the force the audio. Strangely, the sonos app even shows Dolby 5.1 signal being received, as it does with the other apps, it simply isnt sending a signal to the rear speakers. I do hear hissing sound coming from the play 1s during Netflix playback.  The Xbox issue may be more of an HDMI handshake issue since it is more sporadic while the Netflix 100% never works. Thanks again for the suggestions. 

Yea, the “hissing” implies to me that there’s the Dolby Digital signal coming through, there’s just not anything being carried on that channel.

Good luck!

Hi i was wondering if you could help me with my sonos one sl speaker i dont know how to turn on bluetooth 

Badge

Hi i was wondering if you could help me with my sonos one sl speaker i dont know how to turn on bluetooth 

I don't believe Sonos is even compatible with Bluetooth. It has to connect to your WiFi system in order to operate (or the SonosNet channel, which I'm not even versed on).

Badge

Yea, the “hissing” implies to me that there’s the Dolby Digital signal coming through, there’s just not anything being carried on that channel.

Good luck!

Yeah it hisses any time the TV is on basically, but when there is supposed to be surround, and the app shows 5.1 it is merely a hiss no surround effects. Switch to Amazon or something and surround effects are fine. So strange and it seems like it could not be "down converting"  the DD+ that Netflix uses to DD? 

The Sonos One series has BLE (Bluetooth Low Energy) in order to assist in setup, but not the ability to use normal Bluetooth to play music. The only speaker Sonos makes that can accept a Bluetooth signal is the Sonos Move, and it can’t be on Wi-Fi connected to any other Sonos speakers at the same time. 

I don’t think either the TV or the Sonos has the ability to down convert. And if they did, wouldn’t it be easier just to play it? I don’t know how down conversion code works, so I’m not sure. I do know that Sonos can’t do it, only stereo or Dolby Digital. 

Badge

I don’t think either the TV or the Sonos has the ability to down convert. And if they did, wouldn’t it be easier just to play it? I don’t know how down conversion code works, so I’m not sure. I do know that Sonos can’t do it, only stereo or Dolby Digital. 

So yeah, then perhaps the TV is not doing it properly I guess. Just odd that the app sees it as 5.1 and not stereo like it would with other sources? Then again, I am just used to it working (in other similar setups I have) maybe that is how it always displays.  

I’ve never known a TV to do any conversion of audio codecs, but that may be something you want to pursue with TCL. I’m not that familiar with the brand, or the apps they’ve built in. 

Badge

I’ve never known a TV to do any conversion of audio codecs, but that may be something you want to pursue with TCL. I’m not that familiar with the brand, or the apps they’ve built in. 

Perhaps you are correct? But I've read several places that Netflix uses DD+ which Sonos will not play. Yet on my other identical Sonos setup it does indeed play the same Netflix Roku app (different TCL model though) so something is doing the downgrade or is communicating that the sonos needs something less than DD+ to play.  Stating all that, I certainly concede my lack of knowledge as to how this all works. Haha

I would appreciate any help in your resolution to this issue. Have exact same problem. Very frustrating. Spoke with Netflix...nothing. Every other app and cable fine with surround. Thx!!!

Badge

I would appreciate any help in your resolution to this issue. Have exact same problem. Very frustrating. Spoke with Netflix...nothing. Every other app and cable fine with surround. Thx!!!

I would gladly provide any help if I myself receive a resolution to this issue which thus far I have not unfortunately. 

Userlevel 4
Badge +4

@Jawbox I have the TCL55 Roku Tv, and I don’t have this issue.  Try going into audio settings, and deselect “Auto”.   Set your audio settings to “Dolby Digital”.  All apps should then send only a Dolby Digital signal.  Autodetect will always send the highest signal possible, which on my TCL with Netflix, will always be Dolby Digital +.

Hope this helps.

Badge

@Jawbox I have the TCL55 Roku Tv, and I don’t have this issue.  Try going into audio settings, and deselect “Auto”.   Set your audio settings to “Dolby Digital”.  All apps should then send only a Dolby Digital signal.  Autodetect will always send the highest signal possible, which on my TCL with Netflix, will always be Dolby Digital +.

Hope this helps.

Thanks for the reply but I have already tried all of the above to no avail (Dolby Digital). And just to be clear, you're talking about the R625 TCL 55 inch right because that is the only model I am referring to. It works fine on an older TCL R615 55 inch TV I have.  Cheers

Userlevel 4
Badge +4

I’m not entirely sure which exact model I have, I’ll check when back home.  I just know that when I used autodetect, my Sonos didn’t work, because Netflix was sending DD+.  When I specifically set the tv’s audio settings to DD, I no longer had Netflix issues.

Badge

I’m not entirely sure which exact model I have, I’ll check when back home.  I just know that when I used autodetect, my Sonos didn’t work, because Netflix was sending DD+.  When I specifically set the tv’s audio settings to DD, I no longer had Netflix issues.

Yeah my older R615 model the autodetect actually works fine with Netflix. So I had that setting on the newer R625 and it did not work (as you've described) so I walked through all the settings including DD and it still only plays stereo for Netflix. Seems like a bug. The Sonos app actually does show Dolby 5.1 as being played, just no sound from rear speakers, only hissing. Pick another app though and the rears work fine. Odd

Reply