Question

Original Play 3 not working suddenly

  • 14 April 2020
  • 3 replies
  • 125 views

I cannot register the Sonos device to  Living Room where we use the system to play music. Is it because this model is now unsupported as it is discontinued? Am completely baffled having tried endlessly to register to the living room via my iPad.

we unplugged and rebooted and had a flashing green light but did not know where to go from there. Sonos is not recognizing the Play 3 which gets us nowhere.

Any suggestions would be greatly appreciated before we give up completely!


3 replies

Hi @Myszka20. Welcome to the Community. I am sorry to hear that you are having trouble with your Play:3. From what I can gather from your opening post. It looks like your Play:3 got reset, which is why it vanished from the application. 

Do you have other Sonos products besides the Play:3? 

What happens when you try to re add the Play:3?

No  we had it from new. It just stopped showing Living Room and only works on my iPad! So strange when things just alter magically. The only thing we did that was different recently was set up Air Play  on the TV which we now disabled during out lengthy search for restoring the set up.

The play:3 is supported, that’s not going to be the issue.  Did you recently buy the unit on a resale market?  If so it’s a good idea to do a factory reset before trying to connect it to your system.  Also, I would try and set it up while wired to a router.  You can disconnect and move it to the living room after setup.

Reply