Question

Not a community issue per se, but if someone from website support could help

  • 16 December 2016
  • 12 replies
  • 417 views

Userlevel 6
Badge +14
No matter what I do, my userid is linked to the UK site. I set my location, I change the URL to en-us, I log in from a known US IP address, when it sees my login or cookie, it swtiches me back to the en-gb URL in the store or accounts pages. I think it started when I logged in from work, which sometimes connects me via a UK IP address, but now even when I use my iPad to connect over LTE or my home network, it *still* puts me in en-gb. Can someone there who runs the website reset whatever record is associated with my cookie?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

My ID does the same thing whenever I go to the store. I just assumed it was a cookie of some sort. I have not found any simple fix.
Userlevel 6
Badge +14
Does anyone from Sonos monitor this folder??
Userlevel 7
Badge +26
Does anyone from Sonos monitor this folder??

We're here, it's just been very busy of late. This is being looked into at the moment. It has to do with the way the header on the community is hard coded. We're working on it.
Userlevel 6
Badge +14
Thanks a bunch, Ryan!
Any progress on this? If I enter the store I still get pushed to the UK site.
Userlevel 7
Badge +21
I get all sorts of languages for the login page - English, French, Dutch

Doesn't matter but just a bit odd
Userlevel 7
Badge +26
Any progress on this? If I enter the store I still get pushed to the UK site.

Just to make sure we have the right details, how are you getting to the store? Are you clicking on the banner at the top of the page? Going to a URL? Something else?
Clicking the banner
Userlevel 7
Badge +26
Clicking the banner

Thanks, the Shop button on the banner should default you to http://www.sonos.com/shop which will load up whichever location cookie was last used on your system. Do you have any links you go to that have http://www.sonos.com/en-gb/ in them? Going to one of those pages directly will change the cookie.
Not aware of any but found a US direct link and was able to flip it back so it seems OK now. Just needed the secret to flipping the cookie.
Userlevel 7
Badge +26
Not aware of any but found a US direct link and was able to flip it back so it seems OK now. Just needed the secret to flipping the cookie.


mmmmmm.... secret cookies. Anything with http://www.sonos.com/en-us/ should do the trick.
Today I find I'm defaulting back to UK sites and have to reset the cookie to US again. Would be nice to know what keeps changing this on me.