major troubles with 10.3 update??

  • 10 July 2019
  • 5 replies
  • 1633 views

I reset my Sonos Beam and tried to reinitialise it. My app errors that an update to the app is available but not in my app store (Google Play Australia?).

Now my Sonos is useless - I can't set it up. Come on guys... You should release the controller update before you release the platform update if it's a requirement!!

EDIT: Manual update fixed this. Suggest the devs look at a better error message or better handling of version updates in-app.

EDIT: please ignore the subject of this post - I was experiencing bigger issues at the time, and have since resolved them (fault found on TV not Sonos) but I can't update subject in edit.

Cheers



5 replies

Update: manual update of App in Google Play got me past that screen... Still a crap user experience
Have you tried again? Having released software in different locations myself, I know that sometimes various regions take longer /shorter time frames to actually appear on the store. I am guessing you got caught in the middle of one of those changes, but suspect if you have waited 5 or 10 minutes, you should be fine.
[deleted]
Airgetlam, yeah I waited. There was some disconnect between the app version I had installed, the app version it wanted me to have, and its ability to check/update from Google Play.

Different wording of the error could have fixed this: "please go to your app store and manually update" or something instead.

Cheers
I’m sure someone from Sonos will read your suggestion. Whether it gets implemented is a guess 😉

Reply