Feature Request - Audio Delay/Sync

  • 12 January 2019
  • 4 replies
  • 297 views

Is it possible that you could include some sort of manual audio delay/sync feature for each speaker/groups of speakers via the app? I have Sonos and regularly use airplay to utilize my home theater setup. The problem I’m experiencing is that even though the Apple TV is technically in-sync with the sonos speaker, my TV/Home audio introduces a delay. The Sonos speakers always end up ahead of my home theater thus creating an echo. I can adjust the audio delay on the TV/Home audio, however that only further lags the TV/Home audio out of sync. I would need to be able to set an audio delay on the sonos speakers in the other rooms to correct the problem.

4 replies

Userlevel 7
Badge +20
Is it possible that you could include some sort of manual audio delay/sync feature for each speaker/groups of speakers via the app? I have Sonos and regularly use airplay to utilize my home theater setup. The problem I’m experiencing is that even though the Apple TV is technically in-sync with the sonos speaker, my TV/Home audio introduces a delay. The Sonos speakers always end up ahead of my home theater thus creating an echo. I can adjust the audio delay on the TV/Home audio, however that only further lags the TV/Home audio out of sync. I would need to be able to set an audio delay on the sonos speakers in the other rooms to correct the problem.

HI compt3ch,

Welcome to the community. While there is a delay setting for home theater audio, it's not currently available for other audio sources. I'll forward a feature request to add an audio delay feature to the app.
Thanks!
I'd like to add support to this request as well. I have a Connect paired with a Connect:Amp for distributed audio through my home with built in speakers connected to the Connect:Amp and a stereo receiver connected to the Connect using the optical cable. Which produced a noticeable delay between the two sources. I tried every setting on the stereo, even direct (bypassing DSP and Dolby) but the delay persisted.

I changed to the banana plugs from the optical cable and the delay disappeared even with the additional receiver processing (neither DSP nor Dolby produced a delay after changing the cables)

It would be nice to take advantage of the digital signal, but since it seems to produce a delay, I cannot until there is a delay functionality similar to the AV set up with my playbar.

Thank you in advance.
The problem goes a little bit further. Sonos players (except playbars) are always buffering. and that causes a delay. I have read somewhere thats it's about 70 milliseconds.Thats makes it difficult to use a play:5 with your television. There should be a option to disable that buffering. My Beam does not buffer. And when you connect a play:5 to a Beam, the play:5 also does not buffer. So that means that it isn't needed.

Reply