Can't turn the mics on on a pair of Play One (Gen 2)

  • 28 September 2019
  • 12 replies
  • 230 views

I can't turn the mic on on a pair of Play One (Gen 2) speakers. The mic light is not on and no amount of poking, swiping or stroking of the mic logo will get it to turn on.
My system has 2 other sets of paired Sonos One (Gen1) units hooked up to it through a Boost plus a Beam paired with two Play 1's. There's a pair of Play-5's on the system too and I'm wondering if there's a conflict??? All the other units fitted with mics work with Alexa ok, just this latest set doesn't.
I've removed the speakers from the system and started over again with connecting them (several times in fact), with no joy. In all other respects the speakers work fine regardless of whether I use the Sonos app or the Alexa app. This pair just won't respond to voice commands.

12 replies

OK, let's start off with identifying which speaker you have.

See Sonos One vs. PLAY:1 reference.

The PLAY:1 does not have any microphones, nor was there a gen 2. The Sonos One does have microphones, and there was a gen 2.

If you've got a mic button, then it's a push that changes the state, and not a swipe. Make sure that you haven't turned off the buttons on your speaker in the settings area for that room. If they're "on", try a simple power cycle of the speaker. Normally speaking, when you push the button, there should be an audible sound on your speaker, and a white LED lights up.
Oops, quite right Bruce. The speakers I've got the problem with are Sonos One's not Play 1's. I've just checked the Sonos App and both the Status light and Touch Controls options are turned on.
I've also recycled the power too (yet again) and darn, still no joy.
Hmmm. I went over to one of my Sonos Ones and checked to make sure that my button was working, which was why I could say something about the LED, since it's not a button I use frequently.

This is odd. That feature technically (and here's where I was wrong before) should not be able to be turned off by the software, since it's hard wired to the mics. So why is it not working for you?

Just to check, you're sure these are Sonos Ones, and not the newer Sonos SL? I've not actually seen an SL, so I don't know if it shows the mic button at all, since it doesn't have mics in it. That's pretty much the only thing I can think of as to why yours wouldn't be working.

Given my complete failure to be of any assistance, I think I'd recommend that you contact Sonos Support directly to discuss it.

I usually suggest the phone folks, they have more tools available because they're on the phone with you, but they are only available Monday through Friday during business hours. Both the Twitter and Facebook support folks are available 24/7.
Just a random thought. These two Sonos Ones aren't bonded to the Beam as surrounds, are they?
Just reread your original post, it's clear they aren't. That's the only thing I can think of....when they're bonded as surrounds to a Sonos speaker that already has voice control, such as the Beam (and currently, only the Beam can have this state), the surround's mic's are turned off, in favor of the mic in the Beam.
One last thing, then I will leave you alone.

Given that you have other Sonos speakers, you could potentially factory reset just those two Sonos Ones, and re-add them to your system. With the knowledge that doing such a reset erases all data, including anything that might potentially help Sonos figure out what might be going on.

I’d check with Sonos first, before taking such a drastic action.

Good luck!
You're a good bloke. Thanks for spending so much time with me on this. I'm going to take up your recommendation of chatting to Sonos Support and won't do a factory reset yet just in case they need whatever is in its memory.
I checked whether they've become surrounds for the Beam but no. I did that by sending a request to these speakers (set up in my guest room) to play something from Spotify and they played them just fine. I did the same to the surrounds in our TV room and again, they did as requested.
Its certainly a head-scratcher... thanks again, Sam
Userlevel 7
Badge +26
Hi @sponga, have you checked in the Sonos app under Settings > Services > Alexa and make sure that voice services are enabled in the room that has those two Sonos Ones?

If the microphone button doesn't turn on the mics, it's usually because there aren't any services enabled in that room.
Ah, awesome. Didn’t realize that, Ryan. Thank you, sir!
Cheers Ryan. Your solution worked. We're up and running. Thank you again too Bruce.
Heh. I just kept you busy until Ryan came in with the answer :)

As usual.
Userlevel 7
Badge +26
The more you know 🙂

Reply