Question

Sonos SYMFONISK Airplay randomly disconnects and can't be reconnected sometimes with my Macbook Pro

  • 28 December 2020
  • 6 replies
  • 65 views

I have tried changing the Airplay audio quality setting to “compressed”, but it didn’t help and when I pause the music or videos for a few minutes, I will have to go back to the MacBook to deselect the speakers and reselect again. 


6 replies

Userlevel 5
Badge +15

Hi @shadowplayer.

Thanks for reaching out and welcome to the community! Let me see what I can do to help you.

Is this only happening on Macbook Pro, have you tried other iOS devices?

Kindly replicate the issue, then submit a diagnostic report through the Sonos app shortly when it happens, and reply with the confirmation number. I'd start by reviewing your system and go from there, it will help in identifying what's possibly causing the issue.

 

If you have any questions,  feel free to reach out.

Thanks, Annazel,

I tried briefly with other devices, and they worked fine, it seems it’s an old issue going on for sometime as I checked online and even in this forum, once you pause the speakers on macOs it will disconnect. I will submit the report mentioned above and let you know later.

Best

Hi Annazel, I have just come across the same issue on my MacBook again, diagnostic report 2061193005 has been submitted.

thanks,

James

Userlevel 5
Badge +15

Hi there @shadowplayer.

Thanks for your response and update.

Upon checking the diagnostic report, it shows sync errors that indicate audio dropouts and symptoms indicative of interference have been detected on one or more Sonos components running on the WiFi. 

Commonly, this issue can come as a result of wireless interference, and following the steps in this article will help you reduce wireless interference around your Sonos products.

 

If the issue still persists, please submit a new diagnostic report and reply with the confirmation number so I can check further and see if there’s anything else causing this issue.

 

Let us know how that goes.

Thanks, Annazel,

it seems I can't follow the instruction as my mesh network is not allowing me to separate the 5G and 2.4G, but I’ve tried some of the tips from the link you provided, let’s see if it cant be improved.

 

Thanks

Userlevel 5
Badge +15

Hi @shadowplayer.

Thanks for your response.

Hopefully, the issue was resolved, but if in case it persists please submit a diagnostic when it happens and reply with the confirmation number, so we can check the system further.

 

Keep us posted.

Reply