Answered

Sonos preventing Mac from going to sleep?

  • 28 August 2020
  • 6 replies
  • 82 views

Hello

I recently installed the Sonos S1 Controller app on my Mac.

During the installation process it asked if I wanted the app to control my machine’s sleep settings, so that it could play music from my Music folder uninterrupted. I clicked Yes. 

But I didn’t realise that even when the Sonos app was no longer running my Mac would no longer go to sleep. Not even my display will go to sleep now, even though the system preferences are set for it to go to sleep after 5 minutes.

I’ve restored the default settings in my Energy Saver system preferences so that “Prevent computer from sleeping automatically...” is now turned off. But it hasn’t fixed it.

I’ve also checked my Activity Monitor to see what apps are preventing sleep and there are none (even the Sonos contoller says it is not). 

I couldn’t see any settings within the Sonos app itself to allow me to change the sleep preferences.

Does anyone know if there are settings anywhere else that I can change that will allow my computer and display to go to sleep again? 

Thankyou for any suggestions

icon

Best answer by John B 28 August 2020, 14:37

I really cannot believe that Sonos would add a script. Have you tried restarting the Mac after changing the setting?

View original

6 replies

This is a one-off change to your computer’s settings.  Sonos retains no control over this.  

I can only speak for a PC not a Mac, but on a PC you would need to change the power profile to allow sleep AND make sure that that profile is the one being used by the computer.  It sounds to me that your Energy Saver profile has been changed but isn’t the one being used?  There may even be a ‘Sonos’ profile in there.

As I say, I don’t know much about Macs, but maybe someone else will drop by….

@John B Yes it does seem that there is something elsewhere that is controlling the Mac’s sleep, but there is no Sonos profile in the System Preferences panel, so either it lives somewhere else or it’s hidden within the system. It may simply be a script that’s been added to the system library somewhere.

I really cannot believe that Sonos would add a script. Have you tried restarting the Mac after changing the setting?

@John B ha, thanks, yes restarting the Mac did the trick. Annoyed with myself that I didn’t try that before.

Regarding scripts, previous versions of the Sonos app didn’t include a feature to change sleep settings, and the only way to stop the Mac from sleeping during playback (and therefore interrupting playback) was to add a script. This still allowed the Mac to sleep when Sonos wasn’t accessing the Music folder. I used it on my old machine but not this new one. 

Anyway, all is well now. I’ll just have to remember to switch sleep settings whenever I want Sonos to play from my folder… although if I have to restart my machine every time to get the changes to take effect then I may not bother anymore.

When I set up my Sonos system and music library in 2011 it asked me if I wanted to stop computer going to sleep. This is not new.

Glad it is (hopefully) now  sorted.

@John B ah interesting. It didn’t work for me at the time, hence the need for the script (which I didn’t write, it was made available to people with the same problem). 

Reply