Songs skip to next song prior to finishing

  • 17 November 2018
  • 7 replies
  • 154 views

I have several SONOS products (PLAY:5, PLAY:3, x5 PLAY:1s) and have recently encountered a problem where songs that are played from any controller will not fully play. It doesn't seem to matter what speaker I play them on. I play them from my itunes library and otherwise don't have problems playing/using itunes.

I've followed the advice to change my router channels to 1, 6 and 11, but haven't had any luck.
Please help! It is incredibly annoying!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

i have same issue. sonos either skips to next song, or stops playing entirely. already tried changing channels and still have this issue. i am playing from music library on my laptop. issue occurs regardless of whether i am using the controller on the laptop, or on my android phone. this has been going on for months. finally submitted diagnostics today, from my laptop 582858766. someone please help - this expensive system is basically useless!
To the OP, what is the source of the music? If it's on an iOS device, I'd recommend looking at the multiple threads where Sonos has indicated that they're looking in to an issue, and have offered several solutions.

lauries444, since you're streaming from a PC, it's possible that you've got another issue, which looks the same. I'd recommend first that you read the wifi interference FAQ, as that contains the most likely reason for your dropouts. If that fails, you may need a simple refresh of your wifi. Unplug all of your Sonos devices, and reboot your router. Once the router comes back up, plug back in the Sonos, one at a time, allowing each to boot up fully before moving to the next. If that is indeed the fix, then I'd highly recommend setting up reserved IP addresses for your speakers (and anything else you have connected) in your router's DHCP table.
Did all those things, and set up my phone to use SonosNet. Tried playing only from the phone tried playing only from the laptop, doesnt matter. Keeps shutting off. Haven't had it skip to other songs now , but maybe because it shuts off before it hss a chance to do that . Very frustrated with this!!
I have had this issue now for a few weeks, I suspect since a sonos update. It’s an entirely new problem for me. Up until now Sonos has worked effortlessly for about 5 years. I stream both Spotify and Deezer from iOS devises and android etc. Makes no difference which I use it still happens. When i play songs from my own “cloud” it works perfectly well and I get the entire song. This is very frustrating! I’ve tried disconnections and reboots but all to no avail so far. Please sort Sonos!
Userlevel 7
Badge +21
I'd suggest reporting the problem to Sonos, these user to user forums do see some Sonos staff activity but not often.

If you submit a diagnostic and contact Sonos with the number they can likely make some progress on your problems. I'd suggest twitter or facebook that are open 24x7 or the phones that vary by location and can have long hold times.
Thank you
I have already submitted a diagnostic but not contacted them about it... so I will. I naively assumed that this was read by Sonos staff more than it perhaps is!
Userlevel 7
Badge +21
The diagnostics go to a computer where they sit and are ignored until someone contacts Sonos support about them.

They don't make that real clear and this is buried about half way down the support page:

Ask the community
Our community is a great place to share and connect with other people that are passionate about the same things you are.