Sky q no surround sound

  • 28 October 2018
  • 16 replies
  • 936 views

Hi all
I have the bar, woofer and 2 sonus 1’s at the rear of the room.
Works great until I put sky q on then the sounds normal ie no bass and the back speakers don’t work.
Any advice would be appreciated !!

16 replies

Have you checked to see what the Sonus (sic) thinks it is getting in terms of a signal?

Open up the controller app, click on the "...more" and then "Settings". Finally, click on "About My Sonos System" Look for the area that has the name "Playbar: (Room Name).

In that area is a line that says "Audio In:" The data after that should be Dolby Digital 5.1.

If it isn't, you need to adjust the settings on either your TV, or the device that is feeding your TV.
Userlevel 7
Badge +20
Hi all
I have the bar, woofer and 2 sonus 1’s at the rear of the room.
Works great until I put sky q on then the sounds normal ie no bass and the back speakers don’t work.
Any advice would be appreciated !!


If you open the Sky Q menu and select Settings>Setup>Audio Visual - you will see two options for Audio output Optical and HDMI. Please ensure that the relevant connection type for your setup (Probably Optical into your Playbar) is set to 'Dolby Digital'
I’m having issues as well. Just had sky q installed and the quality is poor even with bass max? Any ideas how to fix this? I’ve selected Dolby Digital via sky etc and also tried connecting the optical to sky q but the quality is poor compared to how I’m used to?

Nick, did you resolve your issue in the end? Any suggestions?
Hello, all. Same problem here. Beam connected to tv via HDMI ARQ, sky q set to Dolby and surround speakers play music through Sonos great but don’t work for sound through the tv. Any ideas?
Userlevel 7
Badge +20
Hello, all. Same problem here. Beam connected to tv via HDMI ARQ, sky q set to Dolby and surround speakers play music through Sonos great but don’t work for sound through the tv. Any ideas?Sorry for asking but are you watching a programme that has a surround sound signal.:P

Also, can you open the Sonos App>Settings>Room Settings>Advanced Audio>Sorround Settings> and make sure that the Surrounds are set to 'On'
Good question! I tried it with The Mechanic: Resurrection on channel 4 last night, and this morning Ant Man through the Sky store, one of which would would have Dolby.

I’ve also checked as you suggest and surround settings are good.....
Userlevel 7
Badge +20
As a test are you able to connect the Beam directly to the Sky Q box via and Optical cable?
Sorry I think I am being thick.

I’ve tried connecting the beam to the tv with the optical cable (and the sky set to broadcast Dolby on the optical) and it still doesn’t work. I checked the diagnostic in Sonos and it said the beam was only receiving in stereo).

Does the sky have an optical input? (Not at home right now)
Userlevel 7
Badge +20
Hi.

Sorry for not being clear. If you connect the TV to the Sky Q via HDMI and the Sky Q to the Beam via Optical (you'll need to change the Sky Q Audio settings)
No it was me not you.

Will try asap. What functionality will I lose not connecting the beam through the tv?
Userlevel 7
Badge +20
Voice control of the TV but this is just a temporary test.
Thanks. Really appreciate you bearing with me. Will come back to you
Ok, connected to the optical on the sky box and now the surround works.

My Samsung tv is 2 or 3 years old so I don’t think it will do voice control. I can live with it like this BUT my sky remote won’t control the Sonos volume anymore, and changes the tv volume now.

Can I fix this? (Also, is you give me your PayPal account I will send you some cash)
Userlevel 7
Badge +20
This points to the TV not passing the 5.1 signal from the Sky Q box to the Beam. Can you check your TV Audio settings and then revert the cable connections to re-test. Thanks for the offer but no payment required. 😃
It works! There was a sound option on the tv had not seen before that was set to PCM not Dolby.

Can thank you enough!
Userlevel 7
Badge +20
Great news.??

Reply