Question

S2 Controllers See Roam SL but Cannot Adjust Volume Intermittently

  • 19 September 2022
  • 8 replies
  • 49 views

I have three iOS based controllers and they intermittently lose visibility to the Roam or will sometimes see the Roam but you are unable to adjust the volume. There’s no pattern I can discern - one day it’s one controller, some days two but rarely will all three controllers lose visibility to the Rroam. After connecting with the working controller the other one/two controllers will mysteriously regain visibility to the Roam. All of the devices are within a 15 foot radius without any intervening walls. In addition sometimes simply rebooting the Roam resolves the issue, however this is getting annoying. I submitted a diagnostic report #591028388, however right now the controllers at home both see the Roam. Should I wait until the controllers lose visibility to the Roam and submit another report? Is there a diagnostic tool for the controllers to see what state they are in when they can’t see the Roam? Grasping at straws here!


8 replies

That certainly suggests some sort of wifi interference , potentially from outside your own wifi network. It will be interesting, once you call Sonos Support directly to discuss it, to see what they have to say about the data in that diagnostic. 

Just sent in two more diagnostic reports. 

898754026 is my controller after returning home. It cannot see the Roam.

43012737 is my controller after my wife launched her controller and I immediately was able to see the Roam.

I’m curious: what devices are the controllers running on?

5th gen iPad

iphone 13 Pro Max 

iPhone 6s (soon to be a 13 Pro)

What did they say when you called Sonos with those two diagnostic numbers?

Ran out of tech support window yesterday but will be calling in today.

Spent the better part of an hour with Sonos Support and after collecting 4-5 diagnostics we ended up switching the 2.4ghz channel on the router from Automatic to Manual. We initially tried channel 1 however the rep indicated he was seeing some sort of interference and we switched to channel 11. After another diagnostic he felt that the interference was gone and that I should observe the situation for 24-48 hours to see if the phenomenon reoccurs. Will post back later in the week with an update.

There’s no doubt that forcing your Sonos to “chase” the broadcast channel on a router is probably rife with opportunities for issues. Every time your router switches from one channel to the next is likely an interruption in the music stream. 

Reply