Answered

playing Spotify via Sonos results in massive latency/lag

  • 17 October 2020
  • 5 replies
  • 57 views

Hi

I've been Spotify-Sonos user for just over a year, running eero mesh network with  Spotify playing on my sonos devices : MOVE & BEAM WITH  2 x SL’s

 

All has been great...especially with the move outside now i have decent Wi-Fi in the garden.  In the last week whenever I try and play audio from Spotify to one of my Sonos speakers it lags or doesn't play at all.  If i switch to my phones audio its immediate and i can switch tracks with immediately. 

 

So some sort of lag/latency between Spotify and my relaying this to my Sonos speakers.I guess

 

What i cant put my finger on is there has been no changes to the following :

 

no firmware upgrade to mesh eero,

no new devices or electrical devices on the network

no change in the location of the speakers. Move normally sits on dock in kitchen..

eero doesn't allow a change in wifi channel.

 

rebooted all devices / disconnected Spotify app from Sonos / uninstalled / reinstalled / cleared spotify cache

 

Anybody got any ideas why this has just started happening 

 

Thanks

Matt

 



 

 

 

icon

Best answer by Mat_H 17 October 2020, 20:03

So the problem I’ve had for just over a week coincides with an official outage which got fixed  This afternoon/evening 

now I’m back to normal 🙄

View original

5 replies

Userlevel 7
Badge +20

Hi

I've been Spotify-Sonos user for just over a year, running eero mesh network with  Spotify playing on my sonos devices : MOVE & BEAM WITH  2 x SL’s

 

All has been great...especially with the move outside now i have decent Wi-Fi in the garden.  In the last week whenever I try and play audio from Spotify to one of my Sonos speakers it lags or doesn't play at all.  If i switch to my phones audio its immediate and i can switch tracks with immediately. 

 

So some sort of lag/latency between Spotify and my relaying this to my Sonos speakers.I guess

 

What i cant put my finger on is there has been no changes to the following :

 

no firmware upgrade to mesh eero,

no new devices or electrical devices on the network

no change in the location of the speakers. Move normally sits on dock in kitchen..

eero doesn't allow a change in wifi channel.

 

rebooted all devices / disconnected Spotify app from Sonos / uninstalled / reinstalled / cleared spotify cache

 

Anybody got any ideas why this has just started happening 

 

Thanks

Matt

 



 

 

 

Hi

There is a temporary Spotify outage at the moment, please monitor here.

I saw that but don't think that's been going on for over a week :-).  I've had the issue for the last week.

I’ll wait until the issue is resolved with Spotify and then see if I still experience the problem.  thanks.

So the problem I’ve had for just over a week coincides with an official outage which got fixed  This afternoon/evening 

now I’m back to normal 🙄

Userlevel 5
Badge +16

Hi @Mat_H.

Welcome to the Sonos community and thanks for reaching out to us. I understand where you’re coming from and thanks for sharing your updates.

I’m glad that everything is now working and thanks for sharing what was done to get things working again. I do hope you continue to love and enjoy your music and Sonos. Please feel free to visit our status website for any known outages and be up-to-date with the current running status of all music services with Sonos.

Please do not hesitate to reach out or create a topic if you still have further questions or concerns. We are always here to help.

Thanks,

Because basically Sonos is now rubbish. Blame outages, WiFi, upgrades etc. These things happen yes- and did before - which was acceptable - but now all the time with Sonos.

I’ve got fairly up to date components- so don’t use the old - first generation isn’t supported anymore get out of jail card.

all my friends are having issues- I give Sonos six months before they fold! 

Reply