Paired speakers no longer in sync

  • 29 October 2018
  • 7 replies
  • 175 views

My system has ~ ten speakers with two Play:3’s paired in bedroom. After working fine for many years they have recently started playing out of sync. I have tried to unpair and repair them. Situation improves but reverts to out of sync after playing a short while. I submitted a diagnostics report number: 1155317509

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +19
Hi, AlanJC6. Did you previously have a wired Sonos component? Your multiple access points are causing this. Your Sonos components are segregated and distributed amongst your numerous access points. This can cause issues in the information reaching your speakers, as the access points are dishing it out at different times, as it were. Could you clarify? Thanks.
With a system containing that many speakers and with APs involved, Boost mode would seem essential. If the system has always been in Standard setup the mystery would be how it has worked until now, not why it has had problems recently.
Yes, I agree completely with John B. It’s definitely a system for Boost Mode and importantly, when it’s been switched over to that mode, to remember to then also remove the WiFi credentials from Advanced Settings/Wireless Setup in the Sonos App. Set the access points to the same wifi channel as the main router, or better still, switch off their 2.4ghz radio on those AP's, if they are not required and just use their 5ghz radio... and then shift the SonosNet channel well away from the main router channel ... at least 5 channels apart, to help prevent any overlap of signal.
Thanks for the feedback. I used to have a BRIDGE. Sometimes the network would get overloaded and it couldn’t handle all speakers playing at same time. So I switched to a wireless setup and things have been good for a while. This summer I changed my WiFi from a single router to a Google WiFi with several access points. I haven’t seen the data but I’m guessing my speakers may be connecting to different modes? Might that cause the issue? What settings would optimize operation on a multipoint WiFi router?
AlanJC6,

Firstly, I think Google WiFi does not currently allow for the fixing of its 2.4ghz WiFi channel and so the hubs auto-search for their channels and that alone presents a problem for SonosNet. One day the sonos system signal can be fine, but the next day a nearby google hub can auto-change it’s channel and introduce potential wireless overlap and interference. I have seen many complain about the hubs.

If I was in your situation, I would firstly set my ISP provided router to modem mode (or Bridge mode) ... so it just acts as a modem only.

To that (now) modem, I would attach my main Google Hub, which would become the local router, gateway and DHCP server for the network.

Then to that main Google Hub, I would attach, either a switch (if required), or a Sonos Boost/Speaker. If I had opted for a switch, it would definitely be an 'unmanaged' one, rather than managed ...and then I would add the Sonos Boost/Speaker to that switch instead. This would be the start of my local network and my SonosNet network. I would then go onto setup the other Google Hub nodes around my home.

I would let the hubs settle for a day or so, and then use a free WiFi scanner, like wifiinfoview and having setup and monitored the Google Hubs, I would establish the best 'least-used' WiFi channel within my home environment and go onto set SonosNet to that established (free/least-used) channel

I would ensure all my speakers switched themselves over to SonosNet. This can confirmed in the 'About my Sonos System' device list in the Sonos App. Each device entry will (should) have the setting WM: 0 ... this confirms it’s linked via SonosNet.
Note: WM: 1 means it’s still attached to the Google Hub WiFi.

When the SonosNet connection was confirmed to all devices, I would remove the stored WiFi credentials in the Sonos App in 'AdvancedSettings/Wireless Setup'.

That would be the way I would probably go about setting up my system with a Google Hub based mesh network.

Hopefully a firmware update to the Google Hubs will one day allow a user to fix their hub WiFi channels, which will then make them a little more SonosNet friendly.

Please note these are my own personal opinions and ideas and others may choose to do things differently.

Hope the information above, goes some way to help you to resolve your current connection/sync issues. ?
Good advice from Ken. I am going to be picky on one point though. I'll assume your ISP router is still part of the setup. If your ISP router has a 'modem only' mode then as Ken says, all well and good. But if not, then 'Bridge' mode is not the best option because that implies turning off DHCP on the ISP router. I would not do that, but instead:

Leave DHCP on, on the ISP router (so that the Google hub can get an IP address)
The only Ethernet connection from your ISP router should go to the main Google unit. Nothing else connected to ISP router
Turn wifi off on the ISP router
Wire a Sonos component to the main Google unit (preferably not that Bridge as it may have been the problem - wire a Play speaker, even if just to test)

That has worked well for lots of people on here.
Userlevel 7
Badge +21
If things are not working as expected when changing connections to the ISP device try power-cycling it, some are picky about only connecting to the first MAC they see once powered up and won't adjust to you changing the connected equipment without the reboot.