Question

Netgear Nighthawk MK63.

  • 13 November 2020
  • 7 replies
  • 111 views

I have recently purchased a MK63 netgear system with an additional satellite.

SONOS works with the Netgear system using the wifi, however I am unable to use my wired computer for SONOS.

The mesh uses IP settings starting with 10.0 etc, whereas the wired Virginmedia router uses 192. etc.

It does seem obvious that as my working SONOS on the wifi is using IP addresses starting with the 10, and my router with the 192, wired systems will not be able to see the mesh IP addresses as the VM router is the DHCP for the wired configuration whereas the mesh router is the DHCP for wireless devices.

I thought that I would bring this to your attention as there has been a few questions relating to mesh systems. SONOS is not having the problem, it seesm as though it is the network configuration with the IP addressing.

Is there a way around it?


7 replies

Sonos controllers and players need to be on the same IP subnet. Either wire the computer to one of the Netgear nodes or put the primary mesh node into bridge mode.

All sorted now thanks.

SONOS either wired or wifi, all there on a mesh system.

Same issue here.  What’s the solution?

See post #2?

Hi, just installed a Mesh MK63  (1 router 2 satellite) system. Added another satellite.

After a complete set up, SONOS was only available on the wifi netwrk and controllable via phone/tablet/device on the same wifi system. No computer attached to RJ45 could see the SONOS equipment, all sorted now.

This was called a double nat and isn't recommended. It caused the issues I was having. 

https://kb.netgear.com/30186/What-is-Double-NAT

https://kb.netgear.com/30187/How-to-fix-issues-with-Double-NAT

I was presented with three ways to set up.

1. Put the virgin media device in passthrough/modem only mode. This disables its router functions and wifi and leaves the netgear in control of everything. (VM router lost connectivity to the internet).

2. Put the netgear in the virgin media's DMZ.  

3. Put the netgear in access point mode. This disables its own routing functions. You can still use the wifi/ethernet ports but disables some other features. (In this mode, just make sure to put the virgin media's wifi channels on different ones from the netgear so they don't interfere).

Options?

I chose number 3 as the most favourable option (and easiest), I also turned off the VM router’s wifi and am only using the mesh function now (that is why I brought it).

Use Netgear router as access point. Turn off wifi on internet router. Set Netgear system as an access point. The netgear router will use the DHCP from the VM internet modem, making all devices on the LAN and wifi on the same network.

The netgear no longer provides the IP addresses for devices, this is controlled by my VM router, however mesh still works.

Putting the netgear in AP (access point) mode tends to be the easiest. 

Here's the features it disables: https://kb.netgear.com/26765/Disabled-Features-on-the-Router-when-set-to-AP-Mode

You can still use its wireless and ethernet ports.

Has anyone else experienced issues when your mobile device (with the SONOS app) says it doesn’t see the Sonos system while connected to one mesh satellite but not the other?  This just started about 4 days ago.  I have disabled DHCP on the Netgear Nighthawk MR60 and am serving DHCP from my Netgate/PFsense router.  Depending which floor I am on (ground fl. or 2nd fl.) I connect to either the Nighthawk wifi Router (MR60), or the satellite (MS60).  If I connect to the router I can see the SONOS system and control it.  If my mobile connects to the satellite I cannot see it.  This system has been working perfectly for months.  This behaviour has only started in the past week.

Hi, It seems as though the MS60 is not being controlled by the MR60. Albeit it was ok 4 days ago, I would recommend a reset of your complete and Netgear system, It does not sound like it is a SONOS issue sas you are able to control when connected to one device. Post your findings in the Negear Community site to see their advice.

Reply