Answered

my sonos keeps needing to search for wifi

  • 6 July 2019
  • 2 replies
  • 86 views

Aalmost everyday when myself or my wife open up the sonos app on our phones we are greeted by the message that 'Sonos is searching for wireless networks', after about 30 seconds of searching we are told that no networks were found and we should try resetting our router. We do as we we are told and the sonos works for the rest of the day. Apart from the sonos we experience very few issues with our broadband & wifi, I have tried removing the boost, running a cable straight into the back of the play 5, but everything I try is to no avail, itfeels like the bridge loses its internet connection every night and is unable to reset or repair itself. I'm lost now and don't know what else to try so any help is gratefully received
icon

Best answer by Ken_Griffiths 6 July 2019, 14:17

Neil Denise Aris,

Your post mentions both a Bridge and Boost, which are two different Sonos products. If it is the Bridge then I would leave that off, but connect/cable a speaker to the network instead. If it is a Boost however I would leave that cabled to the network instead of a speaker.

Having done either of the things mentioned above, try to establish what WiFi channels your router is using and if you know how, fix those channels so they do not change when the router is restarted. Some routers auto-select a channel at startup but usually you can change it to ‘fixed’ in the router configuration pages.

Next goto Advanced Settings in the Sonos App and set the SonosNet channel so it’s at least 5 channels away from your routers 2.4ghz channel. So if your router is set to channel 6, as an example, then put SonosNet on either channel 1 or 11.

Finally goto the App 'Advanced Settings/Wireless Setup' and reset/remove any stored WiFi credentials, if necessary. This will prevent your speakers switching between the Sonosnet signal and your routers WiFi signal.

Hopefully all then will work fine after doing those few things.
View original

2 replies

Thanks Ken_Griffiths , I will start doing that now
Neil Denise Aris,

Your post mentions both a Bridge and Boost, which are two different Sonos products. If it is the Bridge then I would leave that off, but connect/cable a speaker to the network instead. If it is a Boost however I would leave that cabled to the network instead of a speaker.

Having done either of the things mentioned above, try to establish what WiFi channels your router is using and if you know how, fix those channels so they do not change when the router is restarted. Some routers auto-select a channel at startup but usually you can change it to ‘fixed’ in the router configuration pages.

Next goto Advanced Settings in the Sonos App and set the SonosNet channel so it’s at least 5 channels away from your routers 2.4ghz channel. So if your router is set to channel 6, as an example, then put SonosNet on either channel 1 or 11.

Finally goto the App 'Advanced Settings/Wireless Setup' and reset/remove any stored WiFi credentials, if necessary. This will prevent your speakers switching between the Sonosnet signal and your routers WiFi signal.

Hopefully all then will work fine after doing those few things.

Reply