Question

Music stops


Sonos stops playing my music when my mac goes to sleep. I don't want to untick the box that stops it from sleeping, as I want this to happen automatically when I'm not playing music. How can I get Sonos to keep playing whilst also allowing my mac to sleep when I'm not playing music?

5 replies

If your library is stored on your Mac, it is only logical that Sonos will need your Mac to be awake in order to play music from your library. You only option is to play from an online service, or store your library on an NAS drive.
Of course. But when I play on itunes, the computer remains awake until I switch the music off. I want Sonos to do the same thing.
It can't. It has no way of controlling your computer. Your only solution is what I posted.
Not true at all. I'm suddenly experiencing this same issue after moving to a new apartment yesterday and getting my system back up and running. And no, it was not an issue prior to the move. Sonos had zero issues playing music when my computer was in sleep mode — whether manually triggered or by energy saver mode.

And I've been running the most current version of OSX along with the most current version of Sonos.
It's not the computer's sleep mode that matters, it's the hard drive's. Depending on your settings, the computer can be "asleep" while the hard drive can be running. This can be set in the System Preferences > Energy Saver > Power adaptor tab. Make sure that "put hard drives to sleep when possible" is unchecked. Make sure "wake for network access" is checked. If you run on battery as well, go to that tab and make the same changes.

But at the end of the day, jgatie's suggestion is the best route. Avoids all sorts of potential issues with the Mac.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)