MacBook Pro screen mirror with Apple tv 4k no sound

  • 10 October 2021
  • 7 replies
  • 48 views

Hello,

When I use MacBook pro to screen mirror w/ Apple tv 4k, I only get picture but no sound. ( remember it does work for one time only)

If I use iPhone to screen mirror, both video and audio working.

Hope can get answer to solve the issue,thanks!


7 replies

Userlevel 7

Try rebooting your MacBook and Apple TV and trying again.

Thanks for reply, just tried and still no luck.

Userlevel 7

Turn off AirPlay mirroring and go to System Preferences > Sound and change the Output to Apple TV.

Thanks again,

When use MacBookpro to screen mirror

Sound output to Apple tv: have video, no audio

Sound output to sonos: no video, have audio

 

When use iPad or iPhone to screen mirror

Have both video and audio with no issue

Userlevel 7
  1. What Model of MBP are you using?
  2. What is the MacOS version?
  3. How much storage is available on the MBP hard drive?
  4. All the above can be found by clicking on the Apple iCon in the upper left corner of your display > About this Mac
  5. Are you playing AppleTV 4K movie that is downloaded to your MBP?

 

Thanks for your input.

I am at workplace now so that not able to check mbp info. But I know its a pretty old one, probably 5-6 years old model. My wife upgraded to the latest model so leave it in living room, mainly for screen mirroring use.

But I have no issue with mirroring before I got sonos system, I was able to get picture and audio through tv that time.

I hope above info can rule out some cause if possible.

 

Thank you again!

Userlevel 7

Thanks for your input.

I am at workplace now so that not able to check mbp info. But I know its a pretty old one, probably 5-6 years old model. My wife upgraded to the latest model so leave it in living room, mainly for screen mirroring use.

But I have no issue with mirroring before I got sonos system, I was able to get picture and audio through tv that time.

I hope above info can rule out some cause if possible.

 

Thank you again!

Also make sure:

1.Sonos app is up to date. 
2.All the devices (TV and Sonos) are connecting to same network and no extenders are involved

Reply