Answered

Google wifi added to our broadband and Sonos wont connect....any ideas?


We have added google wifi to our broadband and the Sonos just wont connect. Keeps saying its now created its own wifi 'SONOS' and to find it but its not visible. Also tried connecting it via the Sonos hub but that is missing too. Been trying for 3 weeks and everything I try isn't working. We have a hub and two play:3's and never had any problems. Has anyone else had this?
icon

Best answer by Ken_Griffiths 2 March 2019, 15:12

Google Hubs are an issue with Sonos for a number of reasons, not least they auto switch their WiFi channels and may also split your local network into two with your original ISP provided router, if not setup correctly.

I would switch off your ISP provided routers WiFi, if you have not done that already... basically treat your router as a modem as far as practicable.

Then I would run a scan at your locality and see what channels are in use by your hubs and your neighbours WiFi. Use an app like wifiinfoview, or similar, to get that information.

Next I would cable a single Sonos device to your main google hub only... this will begin the start of SonosNet/'wired' mode. Power off your Sonos devices and bring them back online, one at a time.

Next, ensure your Sonos mobile controller is connected to your Google Hub WiFi signal and open the App, you should hopefully see all speakers. Now do these two things...

1. Set your SonosNet channel in Advanced Settings of the Sonos App to the 'least-used' channel in your locality.
2. Goto Advanced Settings/Wireless Setup and remove/reset you WiFi credentials, as these are not needed when running your devices in SonosNet/'wired' mode.

Hopefully everything will then be okay, at least until the Google hubs decide to auto-change their channels, but if that happens and causes any problems in the future then just try changing your SonosNet channel to fix things.

Hope that helps to get you up and running.?
View original

15 replies

Google Hubs are an issue with Sonos for a number of reasons, not least they auto switch their WiFi channels and may also split your local network into two with your original ISP provided router, if not setup correctly.

I would switch off your ISP provided routers WiFi, if you have not done that already... basically treat your router as a modem as far as practicable.

Then I would run a scan at your locality and see what channels are in use by your hubs and your neighbours WiFi. Use an app like wifiinfoview, or similar, to get that information.

Next I would cable a single Sonos device to your main google hub only... this will begin the start of SonosNet/'wired' mode. Power off your Sonos devices and bring them back online, one at a time.

Next, ensure your Sonos mobile controller is connected to your Google Hub WiFi signal and open the App, you should hopefully see all speakers. Now do these two things...

1. Set your SonosNet channel in Advanced Settings of the Sonos App to the 'least-used' channel in your locality.
2. Goto Advanced Settings/Wireless Setup and remove/reset you WiFi credentials, as these are not needed when running your devices in SonosNet/'wired' mode.

Hopefully everything will then be okay, at least until the Google hubs decide to auto-change their channels, but if that happens and causes any problems in the future then just try changing your SonosNet channel to fix things.

Hope that helps to get you up and running.?
Thankyou so much for your reply. I shall give it a go 🙂
Badge
just curious. I am having problems with my sonos system, which has been in place for 4 years or so. around 15 speakers and boost. but have been having a lot of problems not just with sonosnet but also my wifi connection all around the house. I have a mesh network of 3 asus routers. but the question is have you ever experienced where there is a need for 2 boosts for a very large house? 7500 sf, brick?
Badge
by the way my question was for ken and my system was working great for 3 years, didnt change anything but all of a sudden having all kinds of issues, with dropped speakers, freezing controller, music interruptions etc.
If you will excuse my butting in, an additional Boost is extremely unlikely to make any difference in such a situation. This is probably caused by interference or IP address issues. I think it would be best if you submitted a system diagnostic in Advanced Settings, and posted the number back on this thread.
just curious. I am having problems with my sonos system, which has been in place for 4 years or so. around 15 speakers and boost. but have been having a lot of problems not just with sonosnet but also my wifi connection all around the house. I have a mesh network of 3 asus routers. but the question is have you ever experienced where there is a need for 2 boosts for a very large house? 7500 sf, brick?I can perhaps try to briefly outline the Sonos setup in two ways...

1. If running a Sonos System on a 3rd-party home mesh wireless network system, the Sonos devices will run at their best when all the mesh-network hubs are set to the same 2.4ghz WiFi channel. Some mesh systems, like Google WiFi, will auto select their own (sometimes different) individual WiFi channels and apparently there is no way to fix the WiFi channel for each Google hub. In that case it’s perhaps best to use option 2 below and switchover to SonosNet.

2. For a Sonos System setup, things can (and often do) run much better on a SonosNet signal, which is basically an 'exclusive' wireless mesh network system in its own right, with each Sonos speaker acting as a wireless hub for the radio signal that’s built into each Sonos device.

All Sonos speakers/hubs run on the same user-selected (non-overlapping) 2.4ghz wireless channel (either channel 1, 6 or 11), which is set in the Advanced Settings of the Sonos App.

When running this type of setup alongside a 3rd party home mesh WiFi System, it’s best to ensure that the user-selected SonosNet wireless channel is unlikely to interfere with the WiFi channels in use by the 3rd-Party mesh hubs.

Adding in standalone devices like Boosts etc. across a SonosNet network are useful where there is perhaps a long distance between two Sonos speakers and a 'man in the middle' will help the SonosNet signal to hop between them. However I would not bother if a speakers nearest neighbour is close-by, say within 25-30 feet or so... but of course thick brick walls can be a factor, I guess.

In your case though, because things were once working okay with your Sonos Speakers in the past, at some point, I would forget the Boost option and look more to the WiFi interference issues that may have arisen between your SonosNet signal and your ASUS wireless device signals ..and make sure their channels are not overlapping and interfering with your chosen SonosNet channel.

Check what channel(s) are in use by the ASUS devices and perhaps fix them all to a chosen channel, like Channel 6, for example and then set your SonosNet channel at least 5 channels away at either Channel 1 or 11 and hopefully that will help to resolve the wireless interference issues.
Badge
my thoughts as well, I am running the sonosnet on channel 11 and my mesh is set to channel 1. have changed them around and still all kinds of craZy stuff happens with both my mesh and sonos. and this is a new mesh, i got fed up with my old one and thought a new mesh would be better so did that, still the same issues. mesh wifi is spotty and drops devices and sonos acts up all the time too. and everything was beautiful for years. cant figure it ou
Badge
do you think the fact that i have the boost plugged into a switch and not the actual router could have something to do with it? just thought of it. I also have sonos amp plugged into the boost. HMMM
my thoughts as well, I am running the sonosnet on channel 11 and my mesh is set to channel 1. have changed them around and still all kinds of craZy stuff happens with both my mesh and sonos. and this is a new mesh, i got fed up with my old one and thought a new mesh would be better so did that, still the same issues. mesh wifi is spotty and drops devices and sonos acts up all the time too. and everything was beautiful for years. cant figure it outMicrowaves, Baby Monitors and WiFi Printers are renowned for causing wireless interference, but that aside, I would perhaps install WiFi scanner software on a portable device, such as the freeware 'wifiinfoview' installed on a Windows laptop and scan and check exactly what WiFi channels are in use in and around the rooms of your home and try to find the two least-used non-overlapping 2.4ghz wifi channels and then go with those for your asus router (and hubs) and use the other channel for SonosNet.

I would try to shift all your 'other' non-Sonos network devices over to the 5ghz Band, where practicable, to reduce the load on the 2.4ghz band.

Make sure you have removed/reset your WiFi credentials in 'Advanced Settings/Wireless Setup' of the Sonos App... they’re not needed when running your system on SonosNet.

I would also try to make sure that your speakers are at least 3 feet away from any other wireless broadcasting device, if possible ...and for added network stability, I would consider adding all the Sonos devices IP addresses to the local DHCP Server Reservation Table.

It’s perhaps a case of doing all you can to eliminate the potential interference issues and then as a very last resort, look at cabling any speaker that may still be causing you issues perhaps due to thick stone walls, floors, or beams etc.
do you think the fact that i have the boost plugged into a switch and not the actual router could have something to do with it? just thought of it. I also have sonos amp plugged into the boost. HMMMI would not think that the switch would be a problem, I am assuming that it’s an unmanaged switch rather than managed, but try to keep the Boost a good four feet (or more) away from both your Amp and router WiFi.
Besides your new ASUS router and satellites, do you have an ISP provided router too? If so, is that ISP Router operating in 'modem' or 'bridge' mode?
Badge
1474332651 is the dx no
Badge
Hi I don't work for Sonos but was having the exact same issue as you.I also have google wifi access points which were constantly giving me fits. So, my tech guy suggested to buy a boost and install it into my google wifi and not my main router which is only a modem, Since then, all has been good.
Badge
No isp router, just a radio/modem. Im on a microwave link.
Hi I don't work for Sonos but was having the exact same issue as you.I also have google wifi access points which were constantly giving me fits. So, my tech guy suggested to buy a boost and install it into my google wifi and not my main router which is only a modem, Since then, all has been good.Yes that’s exactly what needs to be done, I personally think, with some mesh systems. Simply run things on SonosNet by cabling a device to the main mesh hub (and not the original ISP's router).

It need not be a Boost either in every case, as any Sonos Speaker will do the same thing, but if you don’t/can’t wire a speaker then go with a Sonos Boost.

Then it’s usually the case, like I mention in point 2 of my earlier post, of trying to ensure the SonosNet channel is different to the 3rd party mesh WiFi channels. Usually that gets rid of most of the interference surrounding a Sonos system and things then often will work fine.

I think fixing all WiFi channels around the home is a good thing once you’ve discovered the least-used channels, rather than letting them auto-select themselves, but then keep an eye on the nearby neighbours WiFi channels, as they can sometimes change and so you may have to alter your own wireless channels accordingly. I tend to scan the local airwaves every few months or so, just to see if anything has changed.

Reply