Connectivity issues with my Sonos Play:3

  • 21 October 2018
  • 5 replies
  • 151 views

Userlevel 1
Badge
Hi,

Have a couple of issues i need help with.

Firstly, have recently setup my Sonos Play:3 and having connectivity issues. The music stops and jumps and the app is very unresponsive and seems at times, to have a mind of its own.

And secondly, when connecting with Spotify the shuffle of my playlist which has around 1300 songs is completely broken which doesn't happen when not connected to Sonos. For instance if i play a song by an artist beginning with C it will only play songs by the surrounding artists - so those also beginning with C as well as B and D so doesn't reach very much of my playlist. This is very repetitive and infuriating.

Any suggestions?

Thanks

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +19
Hi, Ethan. This is likely due to WiFi interference. This is often the cause of audio playback issues. If those links don't work, not to worry, we can certainly get to the bottom of this for you. Following any occurrence of this issue, please submit a diagnostic and respond with the confirmation number. This way we can identify the cause. Many thanks in advance.
Userlevel 1
Badge
Hi Edward,

Have tried those links and it doesn't seem to have made any difference. Diagnostic is: 830487253

Thanks
Userlevel 7
Badge +19
No worries. Please take a look at this. It shows all activity on wireless channel 1. The frequency on which your router is operating.



RSSI: is the strength of the signal; the higher the number, the better the signal. As you can see, the RSSI is 37 for your router. Anything else occupying the same channel (signified by "chan" in the picture - again, 1 in your router's case) has the potential to cause issues- if whatever it is on the same channel has superior or only slightly less strength. Note that both are applicable for your network. Also, notice where I have placed the red arrow. That's a wireless printer with a WiFi antennae. That's the problem. If that is your printer, I would suggest disconnecting it as a test. In the long run, you could cable it and switch off the WiFi antennae inside it. If you were to change your router's channel (which would be the normal advice), the printer would sit on the same channel unfortunately; they work by mirroring your router's channel.

All this being said and done, you may want to try running your router on a few different channels anyway. This way you can find the one that has the least interference from neighbours on it. This will improve your WiFi speed, Sonos aside. The link I provided in my previous post goes into the issue of WiFi interference in relation to Sonos comprehensively.

I hope this was clear.
Userlevel 1
Badge
Hi Edward,

So after a week or so my Sonos is working perfectly through the Sonos App its only when I switch to the Spotify App where it begins to slow down and stop etc. (I prefer the Spotify interface on their own app as it's very lacking within Sonos). Do you know why this would be?

Thanks.
Userlevel 7
Badge +19
Hi, Ethan. Well, this depends somewhat on whether you've followed the advice from my previous post (don't mean to sound snide, just to get an idea of what may have changed etc.). If the Spotify application is the only thing not working properly, following the advice from before, then I would like another diagnostic please. Not to worry, I'm sure we'll find the solution.