Question

changing which speaker is ethernet wired

  • 16 August 2019
  • 16 replies
  • 247 views

I recently read that the Sub should not serve as the "wired" component for the network so have decided to change to a Play 5 in another room. I unplugged both the Sub and the Play 5 from power, then removed the ethernet connection from the Sub and connected the Play 5. I then powered them both up. However, when I check "About my system" the Sub still says WM:2 and the Play 5 is still WM:1. Am I doing something wrong?

16 replies

Hi. The really puzzling thing here is that those WM values indicate that you do not have a wired (SonosNet) setup at all. And if those values are as before then you never have had.

The first thing I would try would be to use a different Ethernet cable.
Userlevel 7
Badge +26
The Sub is bonded with the Play:5 over 5GHz, so I believe the WM:2 is accurate. However, you should see that the Play:5 is wired to the network. Do you have link lights on the back indicating a connection? A new Ethernet cable is a great first step.

Also, you have to wait for a few minutes for things to switch over.
Hi. The really puzzling thing here is that those WM values indicate that you do not have a wired (SonosNet) setup at all. And if those values are as before then you never have had.

The first thing I would try would be to use a different Ethernet cable.

Hm. Tried a different cable. Same result. I wonder what's going on.
The Sub is bonded with the Play:5 over 5GHz,
Outside of a home theatre setup a Sub would bond over 2.4GHz surely.

I inferred that the OP's Sub and P:5 were actually in different rooms.
Tried a different cable. Same result. I wonder what's going on.
Could be a bad or disabled port on the router/switch.
Try a different port in router? Is there anything in router settings that could prevent a wired connection? If you go into your router can you see if it thinks the Play:5 is wired?

You could experimentally remove (reset) your WiFi credentials in Sonos and see if it will connect at all. Settings, Advanced Settings, Wireless Setup.
A fancier switch could block the port on detecting STP traffic.

The Sub is bonded with the Play:5 over 5GHz,Outside of a home theatre setup a Sub would bond over 2.4GHz surely.

I inferred that the OP's Sub and P:5 were actually in different rooms.


In a standard wireless setup the SUB always shows WM:2 as far as I am aware; that indicates that it is always bonded over 5 GHz to another unit.


The Sub is bonded with the Play:5 over 5GHz,Outside of a home theatre setup a Sub would bond over 2.4GHz surely.

I inferred that the OP's Sub and P:5 were actually in different rooms.
In a standard wireless setup the SUB always shows WM:2 as far as I am aware; that indicates that it is always bonded over 5 GHz to another unit.

The last time I had a P:5/gen2 pair + Sub bonded on WiFi, as I recall they were all WM:1. Besides, the P:5/gen2 has only has a single (dual-band) radio. And Sub couldn't bond with P:5/gen1 or Connect:Amp if it had to use 5GHz.
My understanding (although I wouldn't put my life savings on it), is that WM:2 means 'bonded within a HT, connecting over 5GHz, in a wireless Sonos setup'.
My understanding (although I wouldn't put my life savings on it), is that WM:2 means 'bonded within a HT, connecting over 5GHz, in a wireless Sonos setup'.
I believe that’s the case too @John B ... I have this in my own notes:

In SonosNet mode speakers and any surrounds are set to WM:0
In WiFi mode normal speakers (not surrounds) are set to WM:1
In WiFi mode surrounds are set to WM:2
(It pays to not solely wire a sub or surround).

That said though, the OP's issue is the wired Play 5 in the 'other' room showing WM:1, when it should be showing WM:0 .. it’s like the network connection to that speaker is not working correctly.

My thoughts are to reboot the router, but I’m assuming that there are no managed switches in between and that the Ethernet cable(s) to the speaker are not faulty.
My understanding (although I wouldn't put my life savings on it), is that WM:2 means 'bonded within a HT, connecting over 5GHz, in a wireless Sonos setup'.
Yep.
https://support.sonos.com/s/article/3237
I’m saying this with a little reluctance, but might it also be useful for the OP to check they have not switched off the wireless radio on their Sonos devices here?.... and then go onto remove their WiFi credentials from “Advanced Settings/Wireless Setup” to 'force' SonosNet mode.
You can't force SonosNet mode via Advanced Settings/Wireless Setup. It simply won't let you reset the WiFi credentials unless all devices are WM:0.
You can't force SonosNet mode via Advanced Settings/Wireless Setup. It simply won't let you reset the WiFi credentials unless all devices are WM:0.
Ah okay.
Userlevel 7
Badge +26
Some clarification...

Play:5 gen2 will bond with a Sub over 2.4GHz. The 5Ghz SonosNet is only created by home theater main devices, which would be the Amp, Beam, Playbar, and Playbase.

As that article posted above says:
“WM=0” means your system is in a wired setup
“WM=1” means your system is in a wireless setup
"WM=2" means the device is bonded as a surround speaker or Sub to a Playbar, Playbase, or Beam in wireless setup

I'm passing it up to the team that they should probably remove the “a Playbar, Playbase, or Beam" section, as I believe that it will show WM=2 now for any device bonded as surround or Sub with a player unless it's wired wired into the network. This is not specific to if it's 2.4 GHz or 5 GHz. I'm reaching out to the software guys too, just in case there's a change here that I'm not aware of.

Reply