Answered

Cant use spotify connect - new router


I have had some Spotify-connect issues since I replaced my old router last week. I’ve never experienced any issues previously. I can easliy use Spotify via the Sonos app however i’m not able to use Spotify directly (using my Sonos system obviously, working just fine on iPhone). 
What I’ve done so far:

  • Router restart/reboot serveral times
  • Deleting both Sonos & Spotify app
  • Removed Spotify via the Sonos app
  • Deleted and adding my entire Sonos system to the Sonos app

When I plug out the powercable on my router I’m lucky to find my Sonos devices. The next day it’s all gone again  What to do?? 
 

Do I really need to buy the Sonos Boost? 

Regards

 

 

icon

Best answer by Airgetlam 11 January 2022, 18:47

View original

12 replies

Userlevel 7
Badge +22

What router? Sounds iffy, a Boost would be a good solution.

The key thing I don’t see in your list of things you’ve tried is a reboot of the router while the Sonos devices are unplugged. 
 

If that doesn’t properly refresh the network information and resolve your issue, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

What router? Sounds iffy, a Boost would be a good solution.

Icotera - i4850-00. I cant believe I need to have one more device in order to work around this issue. Old router is from 2012 - never had a problem ….

The key thing I don’t see in your list of things you’ve tried is a reboot of the router while the Sonos devices are unplugged. 
 

If that doesn’t properly refresh the network information and resolve your issue, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

You’re right … Sonos devices has been “online” while rebooting the router. 

In general, when replacing a router, you should refresh the whole network, by powering down all devices and then rebooting the new router. This forces everything to get ‘new’ addresses from the new network, rather than having them hold on to addresses that were given to them by the old router. 

In general, when replacing a router, you should refresh the whole network, by powering down all devices and then rebooting the new router. This forces everything to get ‘new’ addresses from the new network, rather than having them hold on to addresses that were given to them by the old router. 

Noted with Thanks. Just tried the above and all Sonos devices appears through Spotify. Question is, will they tomorrow without rebooting again. 

They should, yes. But you’ll need to tell us if they don’t. 

While there’s only science to networking, to many of us it’s a black art :)

They should, yes. But you’ll need to tell us if they don’t. 

While there’s only science to networking, to many of us it’s a black art :)

The devices does not seem to be visible this morning through Spotify ..

I don’t have any knowledge about how the Spotify Direct connect works. Are they visible in the Sonos controller? That’s where the expertise of most folks in this forum is. 

Ok, yep via Sonos no problem. Spotify is the problem. I’ll try to change some settings in the router. 2.4GHz / 5GHz, maybe that will solve it

 

Yea, sorry, once the speakers are ‘seeable’ in Sonos, it means they’re properly set up, and the issue is somewhere in the Spotify software, something I just have no knowledge about. Sorry I can’t help further.

Userlevel 4

I have had some Spotify-connect issues since I replaced my old router last week. I’ve never experienced any issues previously. I can easliy use Spotify via the Sonos app however i’m not able to use Spotify directly (using my Sonos system obviously, working just fine on iPhone). 
 

Is it on your iPhone that you cannot see the Spotify connect devices? Have you tried a reboot of your iPhone?

Also, on your iPhone, check iPhone Settings > Spotify > Local Network (make sure this option is still enabled)

Reply