Beam setup


Badge +1
Hi. I'm trying to set-up my Sonos Beam with my LG OLED55C8. I have connected the beam to the HDMI 2 (ARC) socket on the TV and turned on the HDMI ARC in the settings. The Sonos app say's that the Bam is connected to the tv but I still can't get any sound through the Beam. Any help would be appreciated.

22 replies

Userlevel 7
Badge +20
DaveJ1356 wrote:

Hi. I'm trying to set-up my Sonos Beam with my LG OLED55C8. I have connected the beam to the HDMI 2 (ARC) socket on the TV and turned on the HDMI ARC in the settings. The Sonos app say's that the Bam is connected to the tv but I still can't get any sound through the Beam. Any help would be appreciated.



Can you check what the Audio output settings are on the TV and try changing them?
Badge +1
HDMI ARC is selected and Digital sound outs is set on Auto
Userlevel 7
Badge +20
Hi

Thanks for that. What is the source for your TV? Some sources cable etc can output an Audio format that the Beam doesn't support.

This article may help: https://support.sonos.com/s/article/3339?language=en_US
Badge +1
I'm sorry I don't know what you mean by all that.
Userlevel 7
Badge +20
Sorry. Where is the signal that your TV is displaying coming from? e.g. Terastierial TV, Sky, Cable etc

Some of these sources output Dolby Digital Plus, which the Beam can't decode - hence no audio being heard.
Badge +1
Thanks. TV supplied by SKY
Userlevel 7
Badge +20
Can you open the Sky>Settings>Audio>HDMI setting and confirm what it is currently set to?
Badge +1
Have been right through the settings and I don't have that option!
Badge +1
This is crazy. Why is there no one to talk to. I'm really fed up with this damn piece of rubbish now and considering getting shot of it!!!!
Badge +1
Sorry, Found it, it was set to "normal". I've tried it on dolby Digital too and it makes no difference.
Userlevel 7
Badge +20
Last chance as I normally stop helping when someone stops appreciating my time. Sonos don't monitor the forums on weekends but they are available via Twitter and Facebook.

Was your Sky box connected to your device that output sound previously? There is a setting that turns on/off Audio via an optical connection and another via HDMI. With the Beam, you need to make sure that the HDMI setting is set correctly.

As another test, can you output any music via the Sonos App?
Userlevel 7
Badge +22
You want it on dolby digital
Userlevel 7
Badge +20
DaveJ1356 wrote:

HDMI ARC is selected and Digital sound outs is set on Auto



Also, can you take this off Auto and select dolby digital. Also, can you try any other HDMI port on your TV?
Badge +1
Your time is appreciated. I'm sorry that I write very slow on here. I find it frustrating and a lot easier to talk to someone as I don't fully under stand the technicalities.
The sky box works ok with the tv and the Beam plays music from my phone
The audio on the sky box is set to Dolby Digital
The sound on the tv is set to HDMI ARC and Digital sound out can only be set to PCM or AUTO neither of which make any difference.
I don't know what other information I can give you, I have followed the set ups to the letter!
Thanks
Dave
Badge +1
PS. Just popping out to buy another HDMI lead.
Dave
Userlevel 7
Badge +22
I don't think its the cable - aren't you using the one that came with Beam.

With sky box set to Dolby Digital I would move on to seeing if the TV is the problem. Hook the beam direct to the sky box via the HDMI cable with the optical adapter. Then see if your getting at least Dolby Digital direct from the box. Once we know that we can move on to figuring out the TV.
I don’t think it’s the cable either... the TV is both DTS and DD compatible ... I think there has to be a setting in the TV settings to ensure DD is being transcoded correctly.

I know that LG TV's usually require 'simplink' to be enabled and also within the simplink settings, there is usually a further option called 'Auto Power Sync' and that needs to be switched on too.

What I can’t find is a way to ensure the TV outputs a DD signal over the HDMI-ARC port, but I’m guessing it’s a TV setting here that needs to be changed.

Turning the TV off (not the same as standby) and removing/reconnecting the HDMI cable though is always worth a try.
There is a setting under Sound > Sound Out > Optical / HDMI ARC > Digital Sound Out to force the TV to Dolby Digital. That should be set also.
Badge +1
Hi Guys. I've just been up to Asda and bought a new HDMI cable. Its a BlackWeb 4K Gold plated 1.2m HDMI cable £14.99. Lo and behold its now working. The one I was using was a "high speed" cable from Amazon that has been working with all my other devices. A big thank you for all your help today and sorry if I have upset anyone with my frustrations.Thanks again
Dave.
Userlevel 7
Badge +22
Great news!
Userlevel 7
Badge +20
Great news, now you can enjoy. Please do come back if you have any further questions or issues.
I always thought the Beam came complete with a cable and an optical adapter? Oh well, at least it’s sorted, that’s the main thing.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings