Sonos Now Playing with Alexa Groups

  • 17 December 2018
  • 252 replies
  • 34755 views


Show first post

252 replies

The original post here says that "You can also adjust the volume without having to name a room, so long as you're speaking to the microphone enabled device set up in that Alexa Group. "Alexa, turn it down/up," is all you'll need to say to adjust the volume on the Preferred Speaker."

Is the use of the singular "Preferred Speaker" deliberate here (i.e., because this only works with a group containing one Sonos speaker), or it should it work with groups containing multiple Preferred Speakers?

If it's meant to be the latter, it isn't working for me: when I say "turn it up everywhere" the volume will change only on one of the Sonos Preferred Speakers in the Alexa "everywhere" group.

Is it working for other people?
The original post here says that "You can also adjust the volume without having to name a room, so long as you're speaking to the microphone enabled device set up in that Alexa Group. "Alexa, turn it down/up," is all you'll need to say to adjust the volume on the Preferred Speaker."

Is the use of the singular "Preferred Speaker" deliberate here (i.e., because this only works with a group containing one Sonos speaker), or it should it work with groups containing multiple Preferred Speakers?

If it's meant to be the latter, it isn't working for me: when I say "turn it up everywhere" the volume will change only on one of the Sonos Preferred Speakers in the Alexa "everywhere" group.

Is it working for other people?
The Alexa control of volume, at the moment, only applies to the one Sonos room (or main controlling room in a group situation). The main room is always the one shown at the top of the group in the Rooms Tab of the Sonos App, as I discovered recently.

There is no 'group volume control' anywhere, other than the Sonos App itself, at the moment. My guess is lots of people would like to see that change though at some point in the future.
The Alexa control of volume, at the moment, only applies to the one Sonos room (or main controlling room in a group situation). The main room is always the one shown at the top of the group in the Rooms Tab of the Sonos App, as I discovered recently.

There is no 'group volume control' anywhere, other than the Sonos App itself, at the moment. My guess is lots of people would like to see that change though at some point in the future.


Thanks - it's good to know I wasn't missing something obvious. The initial post led me to hope this new Alexa groups facility was going to bring voice control of grouped volume. It's certainly something I'd like to have (to be able to control the level across multiple speakers in an open-plan living area, without needing to get my phone out every time). I'll keep waiting...
Thanks - it's good to know I wasn't missing something obvious. The initial post led me to hope this new Alexa groups facility was going to bring voice control of grouped volume. It's certainly something I'd like to have (to be able to control the level across multiple speakers in an open-plan living area, without needing to get my phone out every time). I'll keep waiting...Yes indeed, me too.?
The original post here says that "You can also adjust the volume without having to name a room, so long as you're speaking to the microphone enabled device set up in that Alexa Group. "Alexa, turn it down/up," is all you'll need to say to adjust the volume on the Preferred Speaker."

Is the use of the singular "Preferred Speaker" deliberate here (i.e., because this only works with a group containing one Sonos speaker), or it should it work with groups containing multiple Preferred Speakers?

If it's meant to be the latter, it isn't working for me: when I say "turn it up everywhere" the volume will change only on one of the Sonos Preferred Speakers in the Alexa "everywhere" group.

Is it working for other people?
The Alexa control of volume, at the moment, only applies to the one Sonos room (or main controlling room in a group situation). The main room is always the one shown at the top of the group in the Rooms Tab of the Sonos App, as I discovered recently.

There is no 'group volume control' anywhere, other than the Sonos App itself, at the moment. My guess is lots of people would like to see that change though at some point in the future.


I was literally typing a new comment when I glanced up two posts and saw this... I've also discovered that attempting to control volume for the Alexa Group (which includes two rooms- a paired L&R Play 1 "Living Room" and a single Play 1 "Kitchen") only impacts the "Living Room" speakers. The other Sonos in the Alexa Group ("Kitchen") is not impacted by volume instructions placed through the Echo Dot associated with the Alexa Group.

Is this an oversight by Sonos or somehow a limitation inherent in the Alexa environment? I wouldn't think the latter?
The Alexa control of volume, at the moment, only applies to the one Sonos room (or main controlling room in a group situation). The main room is always the one shown at the top of the group in the Rooms Tab of the Sonos App, as I discovered recently. .

Interestingly I just discovered the opposite. For me, the main controlling room is the one listed second (bottom) in the Group within the Rooms Tab. I found this out as I also experienced the lack of being able to control the volume for both rooms within the Alexa Group and read the recent posts concerning this issue.
H22,

Did you perhaps have the rooms manually grouped together already? Try ungrouping them manually in the Sonos App 'Rooms tab' and then giving the Alexa instructions. What happens then with the volume instruction and which room is at the top of the list?
H22,

Did you perhaps have the rooms manually grouped together already? Try ungrouping them manually in the Sonos App 'Rooms tab' and then giving the Alexa instructions. What happens then with the volume instruction and which room is at the top of the list?


Thanks for the reply. I did, indeed, have them manually grouped together already. I ungrouped them manually, gave Alexa instructions, and the music played on all the speakers (both rooms) as the new Alexa Group feature is designed to allow. However, the volume control through Alexa is still limited to one room.

Interestingly, for me, that volume control is still associated with the room listed second (bottom). I was actually able to reverse the position of the rooms within the Sonos app/Rooms as I ungrouped and regrouped and the Alexa volume control switched to the other room now listed as second.
H22,

Did you perhaps have the rooms manually grouped together already? Try ungrouping them manually in the Sonos App 'Rooms tab' and then giving the Alexa instructions. What happens then with the volume instruction and which room is at the top of the list?


Thanks for the reply. I did, indeed, have them manually grouped together already. I ungrouped them manually, gave Alexa instructions, and the music played on all the speakers (both rooms) as the new Alexa Group feature is designed to allow. However, the volume control through Alexa is still limited to one room.

Interestingly, for me, that volume control is still associated with the room listed second (bottom). I was actually able to reverse the position of the rooms within the Sonos app/Rooms as I ungrouped and regrouped and the Alexa volume control switched to the other room now listed as second.
Ah might be one or two minor issues then with the new grouping features. I’m sure Sonos will sort them over time.

I think these new grouping/ducking features though are great and are working really well. They auto-grouping and ducking features are probably my favourite update since Sonos integrated the Amazon Alexa voice service into their system. I’m looking forward to the next few updates.
Userlevel 3
Badge +5
After a couple months of this feature being released, it’s still not available to me I’m Canada. I keep hoping it will magically appear one day, but so far nothing.
Userlevel 7
Badge +25
After a couple months of this feature being released, it’s still not available to me I’m Canada. I keep hoping it will magically appear one day, but so far nothing.
I'll check it out to be sure, but as far as I know, Alexa Groups should be available everywhere Sonos and Alexa are available. Are you able to make Alexa Groups with other devices and your Sonos players don't show up?
Userlevel 3
Badge +5
After a couple months of this feature being released, it’s still not available to me I’m Canada. I keep hoping it will magically appear one day, but so far nothing.
I'll check it out to be sure, but as far as I know, Alexa Groups should be available everywhere Sonos and Alexa are available. Are you able to make Alexa Groups with other devices and your Sonos players don't show up?


Yes, exactly. I can create groups with Hue lights, smart switches, but under “Alexa-enabled devices”, there is nothing listed but a prompt to “Add Alexa-enables devices for simpler control of your smart home devices.”

Interestingly, if I go to my device list under “Echo & Alexa”, all my Sonos Alexa devices are shown and apprear to be set up correctly.
Userlevel 7
Badge +25
Thanks for the details. If you haven't yet, can you disable and re-enable your Sonos Skill?
Userlevel 3
Badge +5
Thanks for the details. If you haven't yet, can you disable and re-enable your Sonos Skill?

I’ve done a full reset of Alexa (removed all devices in Alexa and Sonos, started from scratch) to no avail. Just tried what you suggested and it didn’t work.

Probably unrelated, but this an interesting slash screen after setting up the Sonos skill in Alexa app. Seems like those two statements contradict themselves, no?
Thanks for the details. If you haven't yet, can you disable and re-enable your Sonos Skill?

I’ve done a full reset of Alexa (removed all devices in Alexa and Sonos, started from scratch) to no avail. Just tried what you suggested and it didn’t work.

Probably unrelated, but this an interesting slash screen after setting up the Sonos skill in Alexa app. Seems like those two statements contradict themselves, no?
Just as a thought, do you have a few Sonos devices with built in Alexa? I’m just thinking if you perhaps have just one, or even a couple of them, they may already be 'enabling' (controlling) other groups in the Alexa App. You can only use them once only for each group... they then 'grey out' and become inactive in the first section of the group... you can of course set them as 'preferred' in the last section in more than one group.

I would just check any other groups you may have in the Alexa App, just in case they have been used elsewhere already.
Userlevel 3
Badge +5
Thanks for the details. If you haven't yet, can you disable and re-enable your Sonos Skill?

I’ve done a full reset of Alexa (removed all devices in Alexa and Sonos, started from scratch) to no avail. Just tried what you suggested and it didn’t work.

Probably unrelated, but this an interesting slash screen after setting up the Sonos skill in Alexa app. Seems like those two statements contradict themselves, no?
Just as a thought, do you have a few Sonos devices with built in Alexa? I’m just thinking if you perhaps have just one, or even a couple of them, they may already be 'enabling' (controlling) other groups in the Alexa App. You can only use them once only for each group... they then 'grey out' and become inactive in the first section of the group... you can of course set them as 'preferred' in the last section in more than one group.

I would just check any other groups you may have in the Alexa App, just in case they have been used elsewhere already.


Hi Ken - thanks for the suggestion. I have four Alexa-enabled Sonos and five Alexa groups, none of which have an Alexa device controlling them. The list doesn’t have any greyed our devices—it doesn’t list anything there. Just a text sentence. Screenshot attached.
Userlevel 7
Badge +25
The Sonos devices should be listed in that Devices section, like "Bedroom" looks like it could be a Sonos speaker. They're just listed by the room name they have in the Sonos app.
Userlevel 3
Badge +5
The Sonos devices should be listed in that Devices section, like "Bedroom" looks like it could be a Sonos speaker. They're just listed by the room name they have in the Sonos app.

Exactly. And yes “Bedroom” is a Sonos One. So it’s seeing the speaker, it’s seeing my Alexa-enabled devices under the device list, but it’s not showing them as available to be assigned to a group. SO confusing.
Corrode,

Thanks for clearing that up quickly with your screenshot, it’s odd that Canada accounts had this issue early on. My only other thought, would be to log out the account in the Alexa App itself by going to the bottom of the Settings area and choosing 'sign out'. Then close the App fully and reopen it and sign in again. That’s what some users did when the update rolled out initially. It maybe worth a try.
Userlevel 3
Badge +5
Corrode,

Thanks for clearing that up quickly with your screenshot, it’s odd that Canada accounts had this issue early on. My only other thought, would be to log out the account in the Alexa App itself by going to the bottom of the Settings area and choosing 'sign out'. Then close the App fully and reopen it and sign in again. That’s what some users did when the update rolled out initially. It maybe worth a try.


Thanks for the suggestion. No dice.
Corrode,

Thanks for clearing that up quickly with your screenshot, it’s odd that Canada accounts had this issue early on. My only other thought, would be to log out the account in the Alexa App itself by going to the bottom of the Settings area and choosing 'sign out'. Then close the App fully and reopen it and sign in again. That’s what some users did when the update rolled out initially. It maybe worth a try.


Thanks for the suggestion. No dice.

I take it you are able to set the Sonos speakers as 'preferred', but just can’t see or use them to 'enable' the group, is that correct?
Userlevel 3
Badge +5
Corrode,

Thanks for clearing that up quickly with your screenshot, it’s odd that Canada accounts had this issue early on. My only other thought, would be to log out the account in the Alexa App itself by going to the bottom of the Settings area and choosing 'sign out'. Then close the App fully and reopen it and sign in again. That’s what some users did when the update rolled out initially. It maybe worth a try.


Thanks for the suggestion. No dice.

I take it you are able to set the Sonos speakers as 'preferred', but just can’t see or use them to 'enable' the group, is that correct?


That’s correct. I can set my Sonos One as a preferred speaker but can’t set that same device as an Alexa-enabled device for that same room.
Just need to perhaps establish if anyone here in the community with an Amazon Alexa Account registered in Canada, may have this working with their Sonos One/Beam speakers, otherwise it maybe a case that Amazon are still to roll this feature out.

I know that it was a 'teething' issue a while back, but not heard anyone complain about it since, so I thought the matter was sorted for everyone, too.
Userlevel 3
Badge +5
Just need to perhaps establish if anyone here in the community with an Amazon Alexa Account registered in Canada, may have this working with their Sonos One/Beam speakers, otherwise it maybe a case that Amazon are still to roll this feature out.

I know that it was a 'teething' issue a while back, but not heard anyone complain about it since, so I thought the matter was sorted for everyone, too.


Yeah, I have yet to confirm if anyone else in Canada is having the same issue. Perhaps I need to make a friend who also uses Sonos. I’ll try to reach out to someone.
Userlevel 7
Badge +25
If it helps, I've gotten confirmation that Alexa Groups is live in Canada. If you remove the Sonos One from any Alexa Groups it's currently in, can you select it as an Alexa input in one group?

Reply