Sonos Now Playing with Alexa Groups



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

257 replies


I have three Ones and Beam. Not sure why they’re not listed as options under that section.

That’s fine, it’s just that they weren’t listed, as mentioned.

Yes, in normal circumstances I would expect you to see those in section one of the Alexa Groups, but Sonos have said it’s a gradual rollout process, so perhaps Canada have not received the update at the moment. I guess you could ask Sonos through their 24/7 Twitter link. See below:

Contact Sonos Customer Care/Twitter (24/7) etc.

By the way, expect a delay in any response time 'perhaps' as it is holiday season.

Hope that helps. ?
Userlevel 2
Badge

I'm not sure I agree that "this is how it should be". Sonos lets you take two speakers and create a stereo pair, that is virtually a single speaker. When you have that configuration and you add that (virtual) single speaker into a room, it breaks everything.


Sonos refers to a stereo pair, a single speaker not bonded to anything else, a 5.1 setup...as a 'room'. This is what you'll see when you view these entities in the Sonos app. However, you're correct that that 'room' is now called a 'speaker' in the Alexa app. It does make communication rather strained.

As far as a stereo pairing breaking everything, that's not true. I'm able to use stereo pairs and 5.1 setups in Alexa groups without issue. The Alexa group really doesn't know that the 'speaker' is really a pair or something else. No reason it should be treated differently. I would say what you're seeing is more of a coincidence that a cause.

From what I've seen, these voice commands will have different outcomes based on current conditions. By condition, I mean, is the Sonos room currently grouped with other rooms? Is it currently playing music? Is there music in the que? Is it playing TV audio? How long has it been since something was played on that group (there seems to be some sort of timeout). Did you just setup the group, and more time is needed for things to be configured in the cloud correctly?

So I would suspect that the conditions that were in play while you had your stereo pair setup was the issue. The act of separating the speakers into two different rooms had the effect of changing the conditions. For example, nothing was currently playing, nothing in the que, no timeouts in effect. Therefore your command worked, as the conditions were right

Unfortunately, I couldn't tell you what conditions matter, or what the if/than logic around these conditions is, or even if they will change tomorrow as bugs are fixed and functionality improved. I've tried a couple different groups and they've worked beautifully. Others not so much. I've somewhat decided that I'll use some of the more basic things that work consistently, and hold off on the more complicated things that don't seem to work as well.
[/quote]
I can definitively say that none of these conditions applied: there wasn't music being played, there weren't different pieces of equipment grouped in other rooms, no queues/timeouts, etc. Everything worked with the exception of the room where I had a Sonos stereo pair. The minute I unpaired the speakers, everything worked. The error from Alexas ("sorry, downstairs is offline.") was 100% worthless and provided no clues about how to fix this.
Userlevel 2
Badge

I'm not sure I agree that "this is how it should be". Sonos lets you take two speakers and create a stereo pair, that is virtually a single speaker. When you have that configuration and you add that (virtual) single speaker into a room, it breaks everything.

In my case, the inclusion of that (virtual) single speaker in the room resulted in the unhelpful error from Alexa, "Sorry, Downstairs is offline", referring to the Alexa Room I had set up called "Downstairs". That error makes zero sense, and the minute I removed the (virtual) single speaker from the room, everything worked as intended.

In the Sonos app, I then unpaired the stereo pair (creating two physical speakers), added the second speaker back to Sonos because it drops one of the two from the system, renamed them "Living Room 1" and "Living Room 2" and then added both of them back to the Alexa Downstairs room. Then everything worked.

For everything to work "as it should", there should be some mention that Alexa rooms are 100% incompatible with Sonos stereo pairing. This doesn't seem to be mentioned anywhere. Also, the error messages, if you mistakenly try to use them together, should be a little more informative than telling you that your Alexa room is "offline".
it depends on which section of the Alexa Groups you are referring to here...

In the first section of a Group (Alexa Enablement) area... A stereo pair of Sonos Ones, for example, will show twice, because each speaker has an Alexa component that can be used to enable a group, for light control etc.

In the second section, where you actually add your Sonos speakers to the group, you will just see the Room Name of the Sonos One stereo pair once only. It you were seeing it twice here (with one device offline) that was an error on your system where by mistake the Sonos Room has been added to your Amazon Alexa device list twice. I (and some others) have occasionally seen this happen where a user disables and quickly re-enables the Sonos Skill and the old device (Room), for whatever reason, has failed to delete and so two devices incorrectly show in the Alexa device list. Obviously it’s then appropriate to delete the old Room, which often shows as being 'offline'.

In the third section of the Alexa Groups .. where we choose to set our Sonos Speakers as 'Preferred' .. you should again just see the Sonos 'Room Name' once only for the Sonos One 'Pair' .. again if it’s showing twice, then it is an incorrect offline 'duplicate' as mentioned above and should be removed from the devices section of the Alexa App.

I hope that explanation now helps you to make a little more sense of why you were possibly seeing your devices duplicated.


I think you're onto something here. Given that it's currently working, I'm less inclined to try re-pairing the Sonos stereo pair but I think Alexa was viewing the pair as two independent devices rather than a single Sonos entity. I don't know why.
Userlevel 1
Badge +3
therefore some Alexa skills, like the BBC skill, are not currently supported

I don't mind the BBC skill not being supported, in fact I'd prefer not to use that skill at all and to fall back on TuneIn. If I say "Alexa play Radio 2 in the kitchen" she answers "BBC Radio 2 from Simon's TuneIn playing on Kitchen" and everything works fine. No BBC skill needed or involved as the stream is being played from TuneIn. However, if I drop the ".. in the kitchen" then Alexa seems to only know what to do via the BBC skill, and this isn't compatible with the group's default speaker, hence it comes out of the Echo Dot. Why doesn't she use TuneIn when the BBC skill is not activated?

If I say "Alexa play Radio 2 from TuneIn" then it plays via the group's default speaker (Sonos). So it works fine by saying either "Alexa play Radio 2 from TuneIn" or "Alexa play Radio 2 in the Kitchen" but not the more concise "Alexa play Radio 2" which is a shame.
Yes this is my experience too. I think the BBC Skill somehow takes precedence over TuneIn ... I think this though is an Amazon issue rather than a Sonos issue... I’ve removed the BBC Skill too and that makes no difference to me either. It seems Stuart_W's experiencd is different to mine here and I cannot explain why that is either.

At the moment I have to add the words '..from TuneIn' to the end of my Alexa instruction to get BBC Radio 1 etc. to play on my preferred Sonos devices.


Everything works so well, but I find it frustrating that I cannot permanently disable Alexa skills, in this case the BBC skill, although Kiss skills exhibit the same behaviour. Because Amazon has decided to automatically enable skills, I cannot get rid of the BBC skill and solely rely on TuneIn. Hopefully some kind of toggle will be implemented (by Amazon) that means skills can be switched off for good if not needed.
Userlevel 3
Badge +3
Does this only work with Amazon Echo devices? I have Ecobee Switch+ light switches that have Alexa built-in. I do not use Echos anymore. I created a group with my two Play:!s as the default audio device, along with a Switch+, but asking Alexa to play music resulted in music playing on the Switch+. I did note that the Switch+ does not show up in the Groups section of the Alexa app as an "Alexa enabled device", even though it is such a device. Is that my problem? They do show up as Alexa/Echo devices in the Devices section of the app but not in the Groups section.

I have to say, these smart home integrations are difficult and cumbersome to navigate with so many moving parts.
Does this only work with Amazon Echo devices? I have Ecobee Switch+ light switches that have Alexa built-in. I do not use Echos anymore. I created a group with my two Play:!s as the default audio device, along with a Switch+, but asking Alexa to play music resulted in music playing on the Switch+. I did note that the Switch+ does not show up in the Groups section of the Alexa app as an "Alexa enabled device", even though it is such a device. Is that my problem?

Yes, that's exactly why. I don't seem my ecobee thermostat as an Alexa-enabled device with groups either.

I have to say, these smart home integrations are difficult and cumbersome to navigate with so many moving parts.


Absolutely agree with this. Unfortunately, it's kind of the way these things naturally evolve. In hindsight, I'm sure the developers (from all the various companies involved) would have built a different framework to support all the functionality we all want and expect today. Something that better fits than what we have. Unfortunately though, they couldn't really know what functionality would be wanted when it was first designed, so the framework was based on what they know.

Hopefully there will be a sort of reset that will allow for a more easy to use framework in the future...one that won't cost too much to adopt.
Userlevel 3
Badge +3

Yes, that's exactly why. I don't see my ecobee thermostat as an Alexa-enabled device with groups either.



That's disappointing. Clearly Amazon or Ecobee need to get their act together to fix this. Although, I see our Sonos One also does not appear as an Alexa enabled device, so I suspect it's an Amazon thing.

Yes, that's exactly why. I don't see my ecobee thermostat as an Alexa-enabled device with groups either.



That's disappointing. Clearly Amazon or Ecobee need to get their act together to fix this. Although, I see our Sonos One also does not appear as an Alexa enabled device, so I suspect it's an Amazon thing.


It should. You may want to log.out of Alexa and log back in. It definitely should be available after that.
Userlevel 3
Badge +3

It should. You may want to log.out of Alexa and log back in. It definitely should be available after that.


Didn't work. The One is in the bathroom and not part of any group though, so I am not concerned about this.
jnak,

Looking back through this thread and at your profile, I see you are from Canada, the same as the user 'Corrode' above and they could not get their Sonos devices to work as 'Alexa Enabled' controllers for the Amazon groups either, so I'm guessing the feature has not yet rolled out to Canada at the moment.

Hopefully Amazon will go onto sort the matter soon for that region. ?
Hello, I'm still unable to include a Sonos One speaker in Alexa groups. I have two Amazon Echo devices and one Sonos One. I want to include all three devices in a multi room group. I'm based in the UK. Does anyone's know if the multi room update has been launched in the UK?
Hello, I'm still unable to include a Sonos One speaker in Alexa groups. I have two Amazon Echo devices and one Sonos One. I want to include all three devices in a multi room group. I'm based in the UK. Does anyone's know if the multi room update has been launched in the UK?warburtonp,

Amazon's own multi-room speaker groups are for Amazon branded Echo Devices only... Sonos Speakers however can be used with normal Amazon 'Alexa Enabled' Groups .. those are the groups used for smart-home devices and have the section called 'Preferred Speakers' ... this feature has been rolled out to UK users. I think you may 'possibly' be looking at the wrong type of grouping (perhaps?).

The 'Alexa Enabled' groups can be created by going to the icon bottom right hand corner from the main opening screen of the Alexa App... then go to the (+) icon (top right hand corner) and choose the 2nd option that says 'Add Group' ... do not select the 3rd option which is entitled 'Add Multi-Room Speakers'. Please see attached screenshot.

Hope that now helps clarify the type of Alexa Group required by your Sonos devices.
Dear Ken, thank you for your prompt reply. If I choose the "Add Group" option (as per your note), all of the "Alexa-Enabled Devices" are greyed out. The "Devices" list lower down shows only the Amazon Echo devices. Can you provide any further guidance?
Dear Ken, thank you for your prompt reply. If I choose the "Add Group" option (as per your note), all of the "Alexa-Enabled Devices" are greyed out. The "Devices" list lower down shows only the Amazon Echo devices. Can you provide any further guidance?
Can you provide a screenshot (or two) of what you are seeing on your device.

Maybe also try logging out the Amazon Alexa App and logging back in again to refresh your Alexa settings. It will take a minute or two to refresh your devices.
Dear Ken, see attached. The Sonos One speaker is the Kitchen. When I initially set up each device (2 Echos and 1 Sonos One) they were each placed in a group named by the selected room. This may or may not be relevant but I’ve included this for completeness.
warburtonp,

I think perhaps your Alexa devices are 'greyed out' and not selectable because you have possibly defined them as a controller inside a group(s) already. Can you screenshot your groups page, or maybe check what groups you have created.

Please note, each Alexa device can only be used once as a 'controller' across all your groups, though any group itself can have multiple 'Alexa Enabled' controlling devices.

You need to maybe check what devices you have used already.
It seems that may be the problem. I have three groups, Dining Room, Kitchen, Lounge, each containing one device. I can’t see why groups are needed in this case but that’s how the app configured the devices on initial set up. I haven’t defined the devices as the “preferred speaker” in the groups though I expect this may be done by default for a single device in a group. I’ve attached some screenshots showing the groups and the details of each.
warburtonp,

Here’s an example screenshot (using iPad) of what the groups look like when they are created by a user in the Alexa App ... perhaps check each of your existing groups to see what devices you have 'Alexa Enabled' already as group 'controlling' devices. The devices are shown in the first section of the group itself.
I’ve deleted the single device groups, which seemed unnecessary. The devices and Echo multi room group still work. I can now create a new group containing the Sonos (Kitchen) and one Echo. I cannot however get music to play from both devices simultaneously. I’ve assigned the Sonos as the preferred speaker then the Echo, then neither. None of the options enable simultaneous play. Can you provide any further advice? See attached screenshots.
warburtonp,

I have sent you a PM to help get you started with your Alexa Groups ... hope you find it useful.
Just received it. I’ll have a look. Many thanks.
Userlevel 4
Badge +5
I’m a couple days into to troubleshooting with Sonos support and still not seeing any option for my Sonos devices under Alexa-enabled devices in groups. Anyone have any other suggestions I could try?

Edit: I just realized I missed a whole page of replies. I see Ken has noted that another Canadian user is having the same issue I am. I’ve just asked Sonos support if my being in Canada is causing this issue. I’ll reply back if they provide something conclusive. Thanks all & Ken especially.
Userlevel 2
Badge
I have have setup groups within the alexa app and have sonos speakers as the preferred speaker in each room that has a sonos speaker. Commands to play music work as advertised with automatic grouping and ungrouping of the sonos speakers. I am not getting any ducking (lowering of audio volume) when issuing "alexa" commands to the echo in each room.
I’m a couple days into to troubleshooting with Sonos support and still not seeing any option for my Sonos devices under Alexa-enabled devices in groups. Anyone have any other suggestions I could try?

Edit: I just realized I missed a whole page of replies. I see Ken has noted that another Canadian user is having the same issue I am. I’ve just asked Sonos support if my being in Canada is causing this issue. I’ll reply back if they provide something conclusive. Thanks all & Ken especially.
Corrode,

My guess is that Canada is still to get the Amazon update, but it would be helpful Corrode, if you can perhaps keep trying things (now and again) by logging OUT/IN the Amazon Alexa App, as that should eventually force the update to you, that’s once Canada gets the rollout and then maybe post back here to let everyone know it’s in place.

Sonos did say it would roll out over-a period-of-time, but it was not clear from Amazon, when and where that would be.

Anyhow hope you get it soon.?
I have have setup groups within the alexa app and have sonos speakers as the preferred speaker in each room that has a sonos speaker. Commands to play music work as advertised with automatic grouping and ungrouping of the sonos speakers. I am not getting any ducking (lowering of audio volume) when issuing "alexa" commands to the echo in each room.I have sent you a PM demonstrating an example Alexa group.Hope it may help you to get things working. It explains the three different working sections of an Alexa Enabled Group.