Software News

Sonos 10.4 Now Available: Updated Settings Menu

  • 10 September 2019
  • 47 replies
  • 9594 views

Userlevel 7
Badge +26
  • Community Manager
  • 11527 replies
Sonos version 10.4 is now available, bringing an updated look and feel to our settings menus, along with the software for running our recently announced Sonos One SL, Sonos Port, and Sonos Move.

New Settings

The Sonos app, has had an update and reorganization to the settings. In the app, the bottom bar now shows Settings instead of More. Within the Settings you’ll see some new headings, settings have been reconfigured to be more accessible. Room Settings and most system based actions are under System and then the Room name, or lower below your rooms listing. You’ll find Alarms there now located under Settings > System.

Connected Services Management
You can now see all services connected to your Sonos system to provide control through our API. In the Sonos app, under Settings > Services > Connected Services you can now disconnect services that you’ve connected in the past. For more details, see here for ‘connected services management’.

Trueplay for iOS 13

Sonos 10.4 also adds support for Trueplay for iOS devices running iOS 13.

Update now

To update, go to More > Settings > Software Updates, or click the Update Now button if it appears on your controller. You can also set up automatic software updates to install as they become available, so your system is up to date when you go to use it any time.

If you see a message that the update is not yet available, you may need to wait a little bit before updating that specific controller.

You can also find our most recently release notes on our article ‘Release Notes for Sonos Software’.

Please note that after updating, if you have any trouble with your local music library, please go to Settings and update the music library.

47 replies

Userlevel 5
Badge +10
I was hoping this release would also be updated for Android 10, but it looks like that is not the case.

In Android 10 dark mode, the Sonos notification has a black background like other notifications, but any black text like a song title or a TuneIn station name disappears because it is also black. Album art is transformed into a color negative. Would be nice to have that fixed.

Also, Android 10 brings support for a progress bar in the notification. I could understand if this is not possible because the controller app is not actually playing media, but it would be a nice touch.

Further to the comment about correctly implementing dark mode for the notification, there may be a lot of users who would appreciate the app to completely go into dark mode, getting rid of all of the white backgrounds when dark mode is on.

Just some things to think about for 10.5 :)
The new design for the settings menu looks good though!
Userlevel 7
Badge +26
Glad you're liking the new layout. I'll pass along that interest in dark mode for Android for you.
Userlevel 4
Badge +8
I really like the new layout. Much easier and clearer to navigate. Look forward to using it with my new Move 🙂
Userlevel 7
Badge +20
Looks like there could be a bug in the 10.4 iOS controller.

I have a Play:5 pair + Sub, with a CD player connected to the LH Play:5 and a turntable connected to the RH Play:5. I'm only seeing Line-In settings for the CD player. There's no sign of the second (turntable) Line-In. It was there last time I checked with the previous version of the controller.

I can select the turntable Line-In for playback, and autoplay works, I just can't access any settings.

Same for iPhone and iPad.
Userlevel 7
Badge +26
Thanks for reporting that pwt, I'll check it out. Have you tried disconnecting the Line-In cables on both units to see if it comes back?
Userlevel 7
Badge +20
Have you tried disconnecting the Line-In cables on both units to see if it comes back?

No, sorry, it's a bit of a fiddle to get behind the speakers. Since the Line-In sources are playing fine, I doubt this would make any difference.

I'd guess it's just a bug in the new settings panel implementation in the controller app. -- assuming there's only one Line-In for a stereo pair. Happy to be proved wrong, however.

Edit: I just popped a cable into the RH speaker of my other Play:5 pair. Exactly the same problem.
Userlevel 7
Badge +26

Have you tried disconnecting the Line-In cables on both units to see if it comes back?No, sorry, it's a bit of a fiddle to get behind the speakers. Since the Line-In sources are playing fine, I doubt this would make any difference.

I'd guess it's just a bug in the new settings panel implementation in the controller app. -- assuming there's only one Line-In for a stereo pair. Happy to be proved wrong, however.

I tested it out and re-created it. I'll get the team to take a look.
Userlevel 7
Badge +20
I tested it out and re-created it. I'll get the team to take a look.

Thank you, Ryan.
Userlevel 7
Badge +19
Yes it's been reported, I found it a week or so ago. What's odd is that it shows as disconnected in settings but shows in the line in section on music sources. I tried swapping line in, in plugging etc but nothing changed. Still the line in works fine, and whilst I don't need to change any settings it's not a biggy.
Userlevel 7
Badge +19
Also to add I really like the update. Getting to eq settings is better, and it remembers that you've been there the next time you go to settings.
Userlevel 7
Badge +26
Yes it's been reported, I found it a week or so ago. What's odd is that it shows as disconnected in settings but shows in the line in section on music sources. I tried swapping line in, in plugging etc but nothing changed. Still the line in works fine, and whilst I don't need to change any settings it's not a biggy.
The issue looks to be that the Room Settings for Line-In only show the status on the Left speaker of the pair. So if your Line-In is only on the right, it'll show disconnected, and if you have one plugged in to each side, again, only the Left shows up.
Userlevel 4
Badge +3
Thanks Ryan. Is there anyway we could get a shortcut to alarms? My schedule is different everyday so I have to adjust my alarm everyday. I have a lot of Sonos speakers, which means that the Alarms page is really buried now: Settings - System - scroll, scroll, scroll - Alarms.

Sure wish it could be easier to get to. Probably dreaming, but I'd love to be able to customize the bottom navigation bar and put a shortcut to Alarms right there, or something along those lines.
It's worth pointing out that the new Settings tab now preserves state.

In other words you can visit other tabs, or expand the Now Playing screen, and when you return to the Settings tab it's still showing whatever submenu was there before.

This could be useful for, say, tinkering with EQ or perhaps keeping Alarms closer to hand.

Obviously if the controller app is removed from the background/overview and restarted then the Settings tab resets to the top.
Userlevel 7
Badge +20
Yes it's been reported, I found it a week or so ago. What's odd is that it shows as disconnected in settings but shows in the line in section on music sources. I tried swapping line in, in plugging etc but nothing changed. Still the line in works fine, and whilst I don't need to change any settings it's not a biggy.

Thanks. Hard to see how this got through testing, especially if it was reported as part of the beta program. I'd be asking searching questions of the QE team.
Looks like there could be a bug in the 10.4 iOS controller.

I have a Play:5 pair + Sub, with a CD player connected to the LH Play:5 and a turntable connected to the RH Play:5. I'm only seeing Line-In settings for the CD player. There's no sign of the second (turntable) Line-In. It was there last time I checked with the previous version of the controller.

I can select the turntable Line-In for playback, and autoplay works, I just can't access any settings.

Same for iPhone and iPad.
code:
I experience the same
Userlevel 7
Badge +26
The line-in settings issues is currently being worked on. I'll let you know when it's been resolved, but it'll be in a software update in the future.
Userlevel 2
The new layout is ok, but it's really annoying that the Alarms function is now buried relatively deep within settings (iOS app)
I'd say it's pretty obvious that the beta community didn't contain as many members that changed their alarms as frequently as the posts here suggest the larger community does.

I'd be wiling to bet that it's being looked in to for an upcoming release, based on the number of posts already.
Userlevel 2
Thanks Ryan. Is there anyway we could get a shortcut to alarms? My schedule is different everyday so I have to adjust my alarm everyday. I have a lot of Sonos speakers, which means that the Alarms page is really buried now: Settings - System - scroll, scroll, scroll - Alarms.

Sure wish it could be easier to get to. Probably dreaming, but I'd love to be able to customize the bottom navigation bar and put a shortcut to Alarms right there, or something along those lines.


Good idea. If you use alarms, like I do virtually every day, also on different schedules, this is something that you would want to access often and so burying it inside multiple levels and scrolls is not very user friendly. I would suggest that Alarms should not be a "system menu" function - they are for ordinary people doing ordinary everyday, simple things, and this makes their use rather unnecessarily difficult.
Userlevel 1
The update is nice however you've made finding alarms a nightmare, I literally use my sonos as a glorified alarm and rarely use it for anything else, I have issues waking up so the fact it's so loud helps me massively on a day to day basis! Really need you to update the app as soon as possible as I change them on a daily/weekly basis so need quick and easy access like I'm sure many do! Great products so good that it the alarm on 100% wakes up myself and everyone in the house which is brilliant!
Userlevel 2
Badge
Ryan,

Any idea why the ability to “Start a Station” from a song in Apple Music was recently removed? I’ve tried to report this to support and they keep saying they will add it as a feature request? It was already a feature....that I and others have been using for years. I even sent them a screen shot from the Sonos forum that someone posted previously to teach someone else how to use the feature. It clearly showed the Start Station function.
Userlevel 7
Badge +26
Good question, Calabogie. I'll have the team look into it. Most service fields are created by the services themselves, added to Sonos using the Sonos API that we develop. I don't know if that's the case here.
Userlevel 4
Badge +3
Ryan, you seem to be responding to every single post in this thread (very much appreciated btw), unless the word Alarms is mentioned, in which case you ignore it completely. Is that intentional? The fact that Alarms are in the very first paragraph of the announcement (and bolded as well) seems to indicate that Sonos knew this was going to be a big problem. So why is Sonos hiding from it now?
Userlevel 7
Badge +26
Hi Kirk, sorry if it seemed that way, I've responded to a few other threads asking about the Alarms. I've made sure to pass along the feedback from the community to the team for people asking for easier access to the Alarms. Thanks for reaching out!
Userlevel 4
Badge +5
[repeating my first post which had wrong name (Recently Played not Recently Added)]
also had opened a topic for this but then saw this upgrade announcement and realized that this is a bug with the updated software

RECENTLY PLAYED does not work anymore since the update.

it worked fine before.
I deleted the app and reinstalled
still not working

in MY SONOS > Recently Played
sits with a blank box and the word LOADING
even leaving it open for 10-15 mins nothing happens

use this daily Please fix
Thanks

Reply