Answered

Resolved: Problems with Sonos Alarms for 12/31/16 - Updates Inside


Userlevel 4
Badge +3
  • Sonos Staff
  • 5617 replies
As of this morning, there is currently an issue with Sonos alarms unable to be turned off. We're working on getting this resolved, but for now, any alarm scheduled to include Saturday the 31st will start playing immediately and cannot be stopped unless disabled again.

We’re sorry for the trouble and our teams are hard at work to resolve this. We'll post updates here as soon they become available.

In the meantime, if you have an alarm set for tomorrow that is going off and can't be stopped, you'll want to go into your Sonos controller and select Alarms. Then, disable any alarms scheduled daily or including Saturday. If disabling the alarms doesn't do it, deleting the alarm will.

Once that's done, you can stop your music as normal.
icon

Best answer by John M 31 December 2016, 02:20

Earlier today we discovered a bug in how some Sonos players interpret leap year dates, resulting in unexpected behavior for alarms set through your Sonos speakers. We're sorry for any inconvenience this has caused.

Until the end of the day on January 1st, 2017, alarms set on Sonos may trigger on the wrong days or times, not trigger at the time you set, or repeatedly loop / not turn off.

For the rest of this weekend, we recommend you disable any existing alarms. If your alarm is going off and can’t be silenced, disable the alarm and then stop the music. You’ll find instructions for alarms here.

After the 1st of January, we expect all alarms will resume their normal behavior. You have our commitment that we will fix this bug in a future update.

View original

181 replies

The alarms are not stopping even if you remove the alarms, remove the radio station and even remove the app. Currently the only way of shutting it up is to let it run but turn the sound down. as soon as you try to make any changes it returns to the play-time alarm settings. :@
Userlevel 4
Badge +3
Hi theocritos, that's odd. We'd like more information about your Sonos system. Can you please send us a diagnostic and reply with the confirmation number? Here's an article explaining how: How to Submit Diagnostic.
Max - Check out the rest of the Community. I have 40+ brothers and sisters experiencing the same. The system finally turns off if you delete - not disable - all of the alarms. Await response from you tec people. You have a bug.
theocritos wrote:

The alarms are not stopping even if you remove the alarms, remove the radio station and even remove the app. Currently the only way of shutting it up is to let it run but turn the sound down. as soon as you try to make any changes it returns to the play-time alarm settings. :@


You may need to reboot all the players to get them to see sense. BTW the one which keeps springing to life is not necessarily the one which fires off the alarm command, hence the need to reboot all of them.
Thanks Ratty. I've deleted the alarms and it has shut up. Seems like it could be a nasty bug as the community is rife with problems today.
Userlevel 1
theocritos wrote:

Max - Check out the rest of the Community. I have 40+ brothers and sisters experiencing the same. The system finally turns off if you delete - not disable - all of the alarms. Await response from you tec people. You have a bug.



Seems that Sonus starts Saturday's (31/12) alarm instead of Friday's (30/12) at least for me. So instead of deleting all alarms try to delete alarm for Saturday (for me just disabling it worked fine). Looks like it confuses dates and kicks off alarm 24 hrs earlier then it should and can't turn it off. Also other people played around with changing dates.
Qwertz wrote:

theocritos wrote:

Max - Check out the rest of the Community. I have 40+ brothers and sisters experiencing the same. The system finally turns off if you delete - not disable - all of the alarms. Await response from you tec people. You have a bug.



Seems that Sonus starts Saturday's (31/12) alarm instead of Friday's (30/12) at least for me. So instead of deleting all alarms try to delete alarm for Saturday (for me just disabling it worked fine). Looks like it confuses dates and kicks off alarm 24 hrs earlier then it should and can't turn it off. Also other people played around with changing dates.



This was exactly the situation for me too - I have different radio alarms on weekend which were being activated - disabling rather than deletion has fixed for me.
A Friday alarm gave me a problem. Other posts have suggested that Sonos has a problem recognising the existence of 31 December which may point to a Leap Year origin.
Perhaps some or all 30 December alarms reference the 31 December date somewhere and that is where it falls over? Just speculation but setting Sonos system date to 23 December seems to have worked for me..
I have 4 Play 1's all with alarms, only one, has been affected, constantly playing TalkSport, deleting (all) the alarms appears to have worked, the other speakers are working without fault.
Just stumbled in here....confirming deleting alarms finally stopped speakers as well.
My Friday alarm came on as usual at 06:45 (stopped immediately as I wasn't working today). The Saturday alarm (apparently) came on at 08:30 as scheduled, and since then was unable to make the Sonos stop until I deleted the alarms.
OMG - Thank G o d for this community post. Sonos woke us up and would not shut off. Tried everything except the Alarm. Mine is not scheduled to turn on, on Thursday-Friday and here we are. Removed Saturday and saved and then I was able shut it off. Did a test, Tried putting Saturday back on schedule and turned back on automatically and couldn't shut it off again. I hope SONOS gets this fixed fast. So weird this is a system wide issue! :?
Mine also stopped when I deleted the Saturday alarm.
I think it was the Saturday alarm that went haywire for me. Or more accurately the 31 December alarm. My money is on a leap year origin.
Badge
I can confirmed I suffered the issue, came across this thread before I was to contact support, did what it said and deleted alarms and now peace and quiet! ahhhhhh. I thought it was going crazy and I was going loopy, literally tried everything before I turned to support, which I looked sooner.

Does the problem go away if I recreate the alarms from new? Alarms are really important on my sonos and can't really do without if possible.

I suppose I could use the feature on my phone but really dont want to if I can help it. love waking up to my random playlist!
Same here - Despite restarting everything and 'factory resetting' the speaker with the issue, nothing worked until the community pointed me in the direction of the Alarms. Having 'disabled' them, it now pauses and does not come straight back on. I have tried deleting the alarms and recreating them, but the issue remains. Thanks everyone, I await a fix. The dog will just have to go hungry tomorrow morning, or will become the alarm call!
Disabling my weekend alarm did the trick. As soon as an alarm contains Sat&Sun the player keeps playing the selected stream source - no matter which player. Unplug /reboot with no effect. Tested with a couple of play 3 and a playbar. I bet a new year thing (Europe/Germany)
Set the Sonos system date to 23 December and you can reset alarms. Another post has suggested setting it forward a week, but i think Sonos will fix this fairly quickly
@BigThinTiger: I'm afraid no. I did not work for me. I deleted all my alarms, rebooted every player and recreated an alarm. If the weekend days are involved, the player starts turn mad. HTH
I unplugged my Play1 system and switched it on after 5 minutes and got the same thing. I've now deleted my alarms and that worked but does this mean I can't use the alarms, as it's my security system for the house.
We’re sorry if this has affected you. Our teams are looking into it as we speak and we'll post updates here as soon as we have more to share.

In the meantime, we recommend deleting any alarms that you have set from your Sonos app.[/quote]
Having similar issues here. I now have been successful in getting alarms to stop in one of my zones (TV soundbar) even without deleting or turning off the alarm.

However I am still unable to stop the alarm in my bedroom zone (Play1). In fact, it automatically keeps stopping and restarting the radio station when the alarm is turned on. It does stop when i disable the alarm.

Max - I submitted diagnostics. Conf# 6939928.
At 6:50-something AM local time my living room alarm went off ... but with the radio show alarm that I have set to go at 10pm every day. Also last night the radio show did not turn on, so when my bedroom sleep music was still playing all night long and waking me up finally at 5am (supposed to last 2 hours starting at 9:45) I assumed the alarms were problematic. Hoping for a resolution soon, as our day has various radio programs and Amazon music playlists go off at various times throughout the day.

Deleting the bedroom sleep playlist alarm resolved the issue. Recreating it with the same time (9:45pm) caused it to start again, but recreating at a different hour (I tried 11am and 10pm) caused it to not play again. However, it is now 7:13 and the 7am playlist has not yet started. Submitted diagnostics 6940032
Hi there. I have three speakers but only one is loaded with alarms and like everyone else woke up to unexpected radio which I cannot alter, change or even group, it keeps returning to same station. Interesting and thankfully the other speakers can play what I want and are not effected, are others experiencing this? Either way I hope those SONOS guys can resolve the problem soon.
Userlevel 1
Badge
I thought I was going mad!

Sonos fired off my regular Saturday alarm a day early and hitting stop only stops it for a few seconds before it comes back on again after @5 sec pause.

Normally if I stop an alarm when it is playing it stays off but this time if I leave it playing sometimes it will run for differing amounts of time before switching off and then immediately start again. Other times it just continues to play.

Weird...
I didn't need to delete the alarms, only to switch them off. I had no weekend alarms.

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings