Plex Now Available in Beta on Sonos



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

84 replies

Badge +1
Where do I start? I added it to Sonos, and after creating an account .. Sonos indexed everything just fine. Sonos sees the Artists and song titles etc ... just won't connect to Plex to playback the darn stuff. I got into the guts of the Web version .. everything looks great .. nothing needed to be done to my router .. everything really looks fine and dandy, yet ... still no-play. ... and it's still in Beta in Sonos Labs (which is fine). I hope that when it's properly released for Sonos, I won't still be having these issues. Fingers-crossed.
I got it working shortly after it was announced, running the Plex server on a Synology NAS.

AFAICS, it's very much beta software. The version on the Sonos controller was slow, clunky and had very limited categories - it may have improved since.

The web version was much slicker and fuller featured - if that had been available from the Sonos controller I'd have been much happier, and may well have used it to get round the '65k' problem. Maybe it will be better when the proper version is available.

[Edit] Just tried it again - a bit quicker than when I first tried it, but still useless in terms of categories etc.
Userlevel 7
Badge +21
Plex developers have pretty much abandoned the Sonos forum on their own website. There doesn't seem to be any progress on this, and there has been no response from them as far as anything Sonos related goes for a couple of months now.

Kenners, there are a few possible solutions... some have found that manually adding a port forward for Plex to your router, rather than using UPnP to automatically add it, has helped allow Sonos and Plex to communicate. Some people with more advanced router/firewall setups (like pfSense, Sonicwall, and others) have found there are advanced NAT options that need to be enabled for it to work properly. And then there are just some routers that don't handle the trick Plex is currently using to make it work (which will require Plex to change things on their end somehow).
Badge +1
Thanks, Mike. That's a real shame on Plexs' part .. this could be such a good addition to Sonos.

I have a simpleton question for you .. if Plex shows that there's full-pathway to outside the router .. doesn't that negate the need to go the port forward route?
Userlevel 7
Badge +21
I have a simpleton question for you .. if Plex shows that there's full-pathway to outside the router .. doesn't that negate the need to go the port forward route?

The simple answer: No. The details, however, are not simple. 🙂 I've tried to make it easy to understand here, but networking is frequently complex.

So... port forwards can be set up two different ways. The hard way is setting up a manual port forward. This process can vary from router to router, and some routers have advanced options available that others don't, or that others might set automatically. And it's something that you need to do yourself (fortunately, there are a few different websites out there that go into the steps needed to do this for many different routers).

The easy way uses a great Microsoft technology called Universal Plug and Play (UPnP). The idea behind it is that devices on your network communicate with a process running on your router that automatically creates port forwards to allow hosts outside of your network to communicate with hosts inside your network. It's very often used for multi-player gaming, where the game software can pick a random port, set up the forward, then tell the game server where to make the connection. The thinking as to why this may not be sufficient enough for Plex/Sonos to work is because the automated software on the router is not able to set the advanced setting needed to allow the Sonos to Plex connection to work.

What Plex is currently doing to work with Sonos is a little unconventional, but it needs to be because of a security measure present in most routers. When you go to play a song from your Plex server, Plex is telling your Sonos speaker to connect to your router's WAN address. This is unusual because both devices are usually connected to the same network, so direct communication between the two devices is possible. The problem is that as a security measure, many routers have what is called DNS Rebinding protection. This prevents a malicious website from having its own hostname set up to point to a private network IP address on your network, then referencing their known hostname to access a device within your network. So Plex can't have a hostname for your server that resolves to, for example, 192.168.1.101, because the router would block that DNS result.

Since it can't use a private network address, Plex uses a DNS entry that returns your router's WAN address, and now your router needs to do something unique: It needs to receive a request from a device on your LAN that references your WAN address and port forward, and then return that traffic to the host on the LAN that the port forward points to. The advanced router/firewall systems refer to this as NAT reflection or Hairpin NAT (the data is being reflected back to the LAN, or making a hairpin turn and going back in the same direction it came from). And for some of the consumer routers, manually creating a port forward will might enable this in those routers that don't explicitly offer the advanced setting.
Badge +1
Thanks for your detailed reply, Mike. Very much appreciate you taking the time.

I've been into the guts of my router, and unfortunately I see nothing connected with any NAT Reflection or Hairpin NAT.

I guess if I really want Plex to work with my Sonos, I'm going to have to upgrade the router.
I've been into the guts of my router, and unfortunately I see nothing connected with any NAT Reflection or Hairpin NAT.

I guess if I really want Plex to work with my Sonos, I'm going to have to upgrade the router.


As far as I recall, though, the only thing that I had to do t make it work was to switch on UPnP, which was disabled in my router by default. I don't recall having to do anything more complex than that. It was under the NAT section of the router setup - do you have anything similar?
Badge +1
Thanks, amun. I double-checked my router and UPnP was already switched on.
Badge +1
It seems Plex just does not want to work with my set-up. Saving myself from further pain, I've gone with Amazon Music .. it works flawlessly for me. Bye, Bye; Plex. Thanks everyone for trying to help.