Known Issues with Sonos App and iOS 9

  • 16 September 2015
  • 33 replies
  • 14810 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

33 replies

Anyone from Sonos care to chime in here and acknowledge the problem so we can get working on a fix? Ive got a few hundred emails now complaining that my system is no longer functioning when in actuality its the Sonos app. I can confirm buzz's post completely, he describes the situation perfectly.
I have also updated my iPad to the fresh ios9. Now my Sonos App does not recognize my two Play:1 sets, but only my Connect device. The sonos app on my iphone, not yet upgraded, as well as the sonos controllers on my local MACbook and Windows PCs have no trouble seeing all three devices.
So I guess it is an ios9 issue ?
thanks in advance.
Userlevel 7
Badge +22
Have you tried rebooting your router and the sonos units effective.

No it would not think it is an ios9 issue.
Userlevel 2
Badge
In how many homes do you have equipment? For a Player like Sonos I think the level of "not working" items are somewhere between strange and weird. For how long time have you had time to test everything on IOS 9 - and as simple as setting an alarm does not Work. Did you guys test it at all? I am not impressed. This is not the path of a leader - this looks more like the path of "Oh yes - right - some one is talking about a new IOS - should we maybe look into this - now it is our only remote control for a great many people?"
In case it helps to report more occurrences -- this mostly works, but I'm also having problems with the songs:// url scheme, as reported by AVMaster and buzz. I use iRule on an iTouch for this... and have a four other url scheme buttons that are working just fine (yes, you had to grant permission the first time, but after that it works). Only the sonos:// url scheme is broken, and crashes after the splash screen (and with a residual black-screen "blank app" as buzz mentioned.

Looking forward to an update!
Badge +3
Anyone from Sonos care to chime in here and acknowledge the problem so we can get working on a fix? Ive got a few hundred emails now complaining that my system is no longer functioning when in actuality its the Sonos app. I can confirm buzz's post completely, he describes the situation perfectly.

Hi AVMaster, we have a fix for this on the way and it should be out within the next few weeks. I'll let everyone here know when an update is available.
Did you guys test it at all? I am not impressed.

Based on my experiences with previous major iOS updates and other 3rd party Apps, testing with iOS betas is not always effective. Apple can make some last minute changes that cause issues for 3rd parties. After an issue is discovered, a 3rd party developer must identify and fix the issue, run the new update through its own beta testers, then submit the updated App for approval. The approval process alone can require a week or more before an updated 3rd party App is available to users. In many cases there is simply not enough elapsed time to respond to a late change before the iOS version is released. If history repeats, there will soon be an update to iOS 9 that could start the "fix it" cycle again.

Unless you need to be on the leading edge for some reason, it is always best to hold off on installing major updates and allow things to stabilize.