Question

Unable to get Alexa on Sonos Beam to find local radio stations (Australia)


[repost as last question was flagged answered when it wasn't resolved - plus added new info and corrected details]

Hi guys. I'm tearing my hair out here, hope you can help.

How can I get Alexa to use Australian radio stations not US radio stations?

I have a Sonos Beam with Alexa running (with 2 x Play:1's for 5.0 surround sound).

I have iHeartRadio enabled (and linked to my account on both Sonon and Alexa) and TuneIn enabled in Alexa but it doesn't seem I can configure it and it doesn't show in Sonos. I have tried setting my default radio app to iHeartRadio. I have set my address, and changed my default country in Amazon account to Australia.

The stations play fine when I load them from the app manually, but Alexa cannot work out that I'm not in the United States. It also doesn't detect that the stations I'm asking for are actually in my favourites on the apps and the Sonos. Instead it plays a US station that matches (e.g. WSFM, KISS) or tells me that it can't find the station for those there's no similar US radio station name (e.g. Triple J). I am able to get some but not many Australian radio stations by being very specific - e.g. "Alexa play Triple M Sydney" or "Alexa play Triple J on TuneIn" (whereas "Alexa play Triple J on iHeartRadio" returns "cannot find station" alert). The main problem for me is the "WSFM" one.

I have tried using IFTTT and have had some success using "trigger" [thanks John B], but it's a messy solution IMO.

How can I just get Alexa to default to Australian radio stations not US radio stations?

Thanks
Dan

0 replies

Be the first to reply!

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings