Answered

Sonos will not skip songs with alexa



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

81 replies

Userlevel 3
Badge +3

Sonos Alexa won’t skip, or plays one song and stops, Alexa for Sonos can’t resume and is totally unreliable.

 

here we are, April 2020 and Sonos and Alexa is a complete fail. If I hear one more suggestion to install and uninstall the skill I’ll chuck my speaker out the window.

 

Is it the skill devs? Is it the Sonos team? Is it Amazon? Who knows? Because there is zero public communication.

 

Sonos and Alexa is a DISASTER and no one seems to be taking any ownership. 

Userlevel 2
Badge +1

Bamra74, 
 

the leaving one device is just to make the setup easier.   if you have no Sonos devices then the setting menu is greyed out because there is no Sonos devices.  You would have to take a extra step to add devices.   However you could factory reset all of them at the same time.  
 

 

You do not have to add anything to amazon.   It’s automatic once you enable the skill and run discovery.  
 

 

did you follow the steps in my last post? 
 

 

 

I will be doing that tmrw now. So I have a playbar, sub and two plays 1s in the front room. Do I first just add the Sonos 1s, sub after its set up then add the play bar? 
 

I have a beam also for the bedroom .

 

Thank you for your help 

Badge

So they had me disable the skill and remove the devices from amazon.   then do a factory reset of all Sonos devices.   After that I just needed to add the Sonos devices back to my account and then add the Alexa skill.  

maybe a bad Sonos update caused the bug.  The reset did a clean install? 

 

I’ll post an update if it stops working  again

Userlevel 3
Badge +3

When you say you deleted them from Amazon, Do you mean from within the Alexa app you deleted all your Sonos devices? 

Userlevel 1

Logged into your amazon account, under settings there is a My Account" option. There should be some options/dropdowns to review.your devices. You can select the device and register it/them.

I did this for amazon music. Not sure if this will work for apple music. I would try to deregister them and then link them back to the apple music service. 

Userlevel 4
Badge +5

Yes, factory reset fixed the issue.  

I have 6 speakers to do so I have to do a factory reset on all devices then head back to the amazon website to re register all the devices, then onto the the Alex app and do the same after I have found the devices on the Sonos app?

Sonos should send a update to rectify this situation as if the last update messed things up they should sending the new fix.

Thanks


you are adding steps that are not needed.  
 

step 1: in the Sonos amp remove amazon music.

step 2: disable Sonos skill in the Alexa app.  

step 3: either using the amazon app or the webpage go to device and contents section and deregister each Sonos device found

 

those three steps takes about 1 min. 
 

step 4: factory reset all devices all but one.  (This will make added devices back quicker) 
 

step 5: in Sonos app go to settings>system>add device

add all speakers.  Then Factory reset the last speaker and add it back  

 

(for me this took about 4 mins for three devices)  

 

step 6: add amazon music back in Sonos app

 

Step 7: add Sonos skill back in the Alexa app

 

step 8: run discover if the Alexa app didn’t do it.  You can do so by voice command or via Alexa app.  
 

You should be able to test the system now.  
 

This error is possibly an issues between Sonos systems and amazon servers.   The factory reset forces a new connection between Sonos and amazon servers.   I’m not sure if a software update can do it alone.   This could be sonos’s fault but could also be Amazon’s fault.  

 

This actually did work. The steps do not work without the factory reset. It seems you also need to reset ALL speakers before adding the skill again, otherwise it doesn’t work.

 

Unfortunately it took me 45 minutes to get all speakers back:

2x Play:5, 2x One SL, 2x One

Make sure to note the following before you start:

  • Stereo Pairs
  • Volume Limits for your speakers
  • TruePlay is lost and has to be redone

 

Badge

Disable the skill in the amazon alexa app. Then go to amazon.com and then your devices and click “register”. 

Userlevel 2
Badge +1

Got that page found my Sonos speakers so I will not have to re register on the amazon website but on the amazon Alexa app? Your system still working? If this works you should be the technical wizard for Sonos. Thank you

Userlevel 4
Badge +5

This is what i did without success:

- remove all sonos devices in the Alexa app with the recycle bin

- disable the sonos skill

- remove all Alexa integrations from the Ones in the sonos app

- remove all sonos devices on the amazon website under devices

This did not help. Has anyone additionally reset the Sonos devices to factory setting to get it working? 

 

 

 

Userlevel 4
Badge +5

Oh look, in the german community Sonos said they are aware of the issue and they are working on a fix. So just wait.

 

https://de.community.sonos.com/amazon-alexa-und-sonos-223393/alexa-kann-nicht-zum-naechsten-song-springen-wenn-sie-selber-eine-wiedergabe-gestartet-hat-6749258

Userlevel 2
Badge +1

Hello fellow Sonos owners, hope you are all well?

Just wanted to know if anyone has had a breakthrough with this current situation? I have tried all ways but no luck. Any more idea would be great. Thanks

Did the factory reset of the device in combination of the removal of the Alexa skills and registration not work?  
 

if not call tech support.  They will send it to the engineers for further assistance. 

Is your Sonos speakers now doing the skip and play continuous songs now? 
 

Sonos are aware of the problem and it’s getting worse.

Badge

Yes, factory reset fixed the issue.  

Userlevel 2
Badge +1

Thank you Sonos for contacting me to let me know the issue is fixed. Roberto Di Sisto has been keeping me up to date and thank you again.

Userlevel 4
Badge +5

Yes, factory reset fixed the issue.  


How much work would that be? And do you think it will work if i try it on one of my speakers first?

Firewater,

 

Thanks for the info, the factory reset was the key to resolving my issue as well.

Userlevel 2
Badge +1

Yes, factory reset fixed the issue.  

I have 6 speakers to do so I have to do a factory reset on all devices then head back to the amazon website to re register all the devices, then onto the the Alex app and do the same after I have found the devices on the Sonos app?

Sonos should send a update to rectify this situation as if the last update messed things up they should sending the new fix.

Thanks

*!!!Thanks Firewater,*** your process help me solve the issue with took me the whole day to figure out.

“ step 1: in the Sonos amp remove amazon music.

step 2: disable Sonos skill in the Alexa app and remove all sonos speakears froms your groups

step 3: either using the amazon app or the webpage go to device and contents section and deregister each Sonos device found those three steps takes about 1 min.

step 4: factory reset all devices all but one. (This will make added devices back quicker)

step 5: in Sonos app go to settings>system>add device add all speakers. Then Factory reset the last speaker and add it back (for me this took about 4 mins for three devices)

step 6: add amazon music back in Sonos app

Step 7: add Sonos skill back in the Alexa app

step 8: run discover if the Alexa app didn’t do it. You can do so by voice command or via Alexa app.

You should be able to test the system now. This error is possibly an issues between Sonos systems and amazon servers. The factory reset forces a new connection between Sonos and amazon servers. I’m not sure if a software update can do it alone. This could be sonos’s fault but could also be Amazon’s fault. “

:grinning:

Userlevel 3
Badge +3

I’ve enabled and disabled the skill until my fingers hurt. I’ve restarted, rebooted and nothing works. Alexa replies “I can’t skip”.

 

google Alexa Sonos can’t skip songs / Alexa Sonos won’t skip tracks and you end up here in one of the many unanswered unsolved forum threads.

Userlevel 7
Badge +20

I’ve enabled and disabled the skill until my fingers hurt. I’ve restarted, rebooted and nothing works. Alexa replies “I can’t skip”.

 

google Alexa Sonos can’t skip songs / Alexa Sonos won’t skip tracks and you end up here in one of the many unanswered unsolved forum threads.

 

I have just tested this on my set-up again whilst listening to a playlist in my queue.  Using the commands ‘Alexa, Next’ and ‘Alexa, Previous’, both commands worked correctly.

I wonder if this is a geographical issue?  

My details are:

Country: UK

Device: Sonos One

Voice: Amazon Alexa

Can you confirm the command that you are using? And that your voice assistant has heard you correctly in the relevant App History?

Userlevel 3
Badge +3

I’m in Australia.

 

Saying “play next song” or “next” or “skip this song” or “skip” results in Alexa replying “I can’t skip”.

 

Today I’ve also noticed if I start from my Sonos Move or Sonos One or from the Echo Dot with “Alexa play Downtempo” she starts the right Apple Music station (Downtempo Radio) and she will play just a single song. Then stop. This is a new behaviour and I can’t replicate it consistently but it’s pretty annoying and it’s new.

 

But saying any combination of skip or next has Alexa reply “I’m sorry I can’t skip to the next song”.

 

I've tried from my Sonos One, my Sonos Move and from my Echo Dot. No skips, and now a “single song played” then stop.

 

EDIT: Alexa has definitely heard me right.

Userlevel 7
Badge +20

It’s not possible to skip Radio.  Are you able to select a Playlist and try again.  My test is ‘Alexa, Play Soft Jazz Playlist’.  Alexa, Next and Previous work fine.

Userlevel 3
Badge +3

Yes, It is possible to skip one song at a time in Apple Music ‘radio’ stations. It’s possible in the Music App and the Sonos app. Only one song at a time though.

 

These are not like a TuneIn station. 


Apple Music users will confirm this. Try any of their curated content stations like Downtempo or Funk or Pure Jazz or Smooth Jazz...any of them - especially my personal favourite “Hair Metal”.

:)

 

Skip is part of the Apple Radio experience. Sonos does it in the app just fine like it does for curated Amazon Music stations. Just that Sonos and Alexa can’t. Seems well documented on many threads here. Alexa on Sonos can’t skip or go to next song.

Userlevel 3
Badge +3

Firewater,

 

Thanks for the info, the factory reset was the key to resolving my issue as well.

Can you confirm that a station or streaming radio function like an Amazon Music station like Lounge & Bar or an Apple Music station like Downtempo (or any apple station as they all allow skipping one song) now allows skip and resume? I’m so reticent to hard reset 5 speakers and retune them without at least some confirmation from Sonos that this works.

I’ve only had the Sonos One for a couple of days. Problems with no skip on Amazon Music and Tunein dropout radio stations, but nobody seems to be able to fix or take any serious interest in fixing these issues as these threads are months and months old. Great sound on the speaker, but if they don’t fix these issues soon, It’ll be RMA for sure.

 

Rather than complaining in multiple threads it’ll be great you’d provide some useful information about your network configuration, and we might be able to assist.

 

If it’s a specific radio station that drops out, there is nothing Sonos can do about it because it’s the station’s infrastructure that causes the dropouts. There are other radio station aggregators than TuneIn that you can try out, search for them under “Add Music Sources”.

Alexa is a cloud-based service, it’s not in any way hardware-related to Sonos. Thus a factory reset won’t help, at least not for long. It’s trying your patience but Amazon and Sonos are already working on it, as far as I’m aware.