Sonos One mic not working at all

  • 18 November 2017
  • 20 replies
  • 16706 views

Hello, I just setup my Sonos One today. I've been using an Echo Dot for some time and it continues to work fine. However, during the setup of my One, and currently even if I put my mouth 2 inches from the One and say "Alexa", nothing happens. I can do the same with my Dot, no issue. It just seems like the Mic isn't working or is disabled. Diag number 8102699

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

20 replies

I will add that I can' find any way to mute the mic. Is it just defective? I'm assuming, since I can't find any instructions to do so, just hitting the mic button *should* turn on the LED to show the mic is muted. Nothing happens with that either.
The LED is hardwired to the mic and is on when the mic is on, not when it is muted. That is a security feature so those who are a little leary of devices listening in always can tell when the mic is on.
So how do I mute it if I want? I don't really want to, but I want to see if I can try, because as it stands it acts like it is on mute.
The mic is turned off by physically pushing the mic button on the top of the device. There is no software on/off because of the privacy concerns.
Yeah, that's why I think I have a defective unit. That doesn't seem to do anything.
Userlevel 7
Badge +21
Have you properly set up the Alexa Voice Service in the Sonos controller app? The mic may not be enabled if you haven't done this.

This is separate from the Sonos skill in the Alexa app, which just allows directing Alexa to play music over Sonos speakers.
I just set up two Sonos Play:1 speakers to be used with Alexa. The setup and discovery all seemed to work fine. However, the microphone does not appear to be working in either unit (suggesting user error). Where should the microphone light appear on the unit and what does it look like? The only light appearing on my unit is the on/off light on the top of the unit.
I had the same issue and solved it by going through the Sonos app on my phone >Settings >Room Settings>Choose room and under Voice Services I was able to add Alexa. It was a bit strange as we did not need to go through this step with our other Sonos 1 and were close to returning the unit.
Thanks CVH i had the same issue, and it seems to be when you add a second Sonos 1
Try swiping your finger across the microphone button (right to left). This enables the microphone. The light should come on and stay on.
Try swiping your finger across the microphone button (right to left). This enables the microphone. The light should come on and stay on.

This one worked for me. Thanks.
Try swiping your finger across the microphone button (right to left). This enables the microphone. The light should come on and stay on. Been struggling to get Alexa to respond for two days - countless google searches and you’ve fixed my problem with a simple swipe of the finger - thankyou!!
I will add that I can' find any way to mute the mic. Is it just defective? I'm assuming, since I can't find any instructions to do so, just hitting the mic button *should* turn on the LED to show the mic is muted. Nothing happens with that either. I have the same problem...
In addition to installing the Sonos Skill in the Amazon Alexa App, check the speaker device “room settings” in the Sonos App and ensure the “Amazon Alexa Service” is installed in the section entitled “Voice Services” and that “touch controls” are set to enabled...then power off/on the mic on the speaker itself. A tiny LED will light-up when the mic is active.

I've tried going into app and turning on off touch controls. Powering off unit but still no love on one of my Sonos one microphones. All updated. Have been only using left side for a while and just tried turning on the right speaker and it's not working. Sent diagnostics and receipt is: 1499772525. Thanks in advance

I've tried going into app and turning on off touch controls. Powering off unit but still no love on one of my Sonos one microphones. All updated. Have been only using left side for a while and just tried turning on the right speaker and it's not working. Sent diagnostics and receipt is: 1499772525. Thanks in advance

I presume the Sonos One is stereo paired. If you are using the Google voice service, it only installs to the one (left) speaker, the other speaker mic is disabled. Just not sure if that’s what may have happened here in your case.

Thanks . I'll unpair tomorrow and check it out

I have been having the same issue, I have tried to turn the mic on the speaker with no luck (using the recommended methods above). The other problem with mine is that I don’t have the voice opinion under the services menu in the app on either my iPhone or Ipad? Not sure why as I used to have it there and wasn’t needed as Alexa wasn’t available but now that it is I’m trying to add it and it is not there, the only opinions there are the music services.

My Sonos One (Gen 2) is unpaired 

If anyone could help me that would be great.  

Userlevel 7
Badge +20

Hi

 

Can you confirm that you have Enabled the Sonos Skill within the Aleca App?

Have you properly set up the Alexa Voice Service in the Sonos controller app? The mic may not be enabled if you haven't done this.

This is separate from the Sonos skill in the Alexa app, which just allows directing Alexa to play music over Sonos speakers.

This worked for me