Question

Sonos One - Alexa Voice Control With Spotify


I am in the UK and I'm trying to get my Sonos one to play Spotify via Alexa Voice commands - my spotify account is premium and it is linked to both Sonos and Alexa I have tried relinking them both multiple times with no success. No matter what I try Alexa tells me that "you need to link your Spotify premium account to play Spotify".

I can only assume the problem is with Sonos because I've never had this issue with any echo devices.

If someone has any suggestions it would be appreciated this is super annoying trying to get this working there is no reason it shouldn't work.

Diagnostic ID - 1535996763

11 replies

Userlevel 6
Badge +20
Hi

Can you open your profile in www.sonos.com and check that your location/address is correct. Also, please open the Alexa App>Settings>Devices>[Your Sonos One] and check that the device location is set correctly.
Just checked and they are both set to UK and to my home address, still no dice though.
Userlevel 6
Badge +20
Okay, can you please open the Alexa App>Settings>Music>Spotify>Go to Spotify App and check it is linked to the correct account?

Edit: Can you also check your location in your Spotify Account?
Ok checked all that it's linked to my account and the location on my spotify account is also set to UK.
Userlevel 6
Badge +20
Sorry for the long post but these are my normal troubleshooting steps:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Ok perfect thank you very much!

I think it was actually disabling and re-enabling the Sonos skill on the Alexa app that got it working that was the only thing I hadn't tried yet.

Anyway it's fixed now :) thanks again!

Just incase would you have any suggestions why Alexa won't play my playlists on spotify like I have a playlist named Everyday she understands that I'm saying Alexa play my everyday playlist but she doesn't actually play it she just plays everyday music not my actual playlist. The same applies to all my other playlists - they are all playlists with the music stored offline if that makes any difference
Userlevel 6
Badge +20
That's great news :) You need to save and follow Spotify playlists in the Spotify App to be able to use them with Alexa.
My playlists are all different names and set as offline so it downloads the music when I add songs to it. Unless there is something else I need to do?

EDIT - Yeah just tried again and no matter how I phrase it she just plays random playlists that I'm not even following I said "Alexa, play my play list chill songs" and she plays a playlist named "Chilled pop" which I'm not even following, and when I look the app she heard exactly what I said she just didn't do it lol.
Userlevel 6
Badge +20
BradR91 wrote:

My playlists are all different names and set as offline so it downloads the music when I add songs to it. Unless there is something else I need to do?

EDIT - Yeah just tried again and no matter how I phrase it she just plays random playlists that I'm not even following I said "Alexa, play my play list chill songs" and she plays a playlist named "Chilled pop" which I'm not even following, and when I look the app she heard exactly what I said she just didn't do it lol.



Is the playlist within Sonos or Spotify? (Edit: Sorry, you've already said that it's in Spotify. If you open the Spotify App, you should have the option to follow your playlist)

EDIT: Can you try 'Alexa, Play Piano Chill Playlist' as a test?
Strange piano chill worked fine but none of mine do :/, I don't see an option to follow my own play lists though when I click them
Userlevel 6
Badge +20
I wonder if they are treated as 'local' as they are off-line playlists. Alexa can't initiate locel music.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings