Question

Sonos One Alexa is half baked - Smart Home doesn't work?

  • 23 October 2017
  • 36 replies
  • 3616 views

I didn't see this advertised anywhere but after setting up my Sonos One with Alexa it seems that any smart home devices do not work. All works perfectly with my echo dot but the Sonos Alexa is kind of a half baked approach.

Is that just me? Sonos admins please let me know if I'm doing something wrong.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

36 replies

I'm having no luck getting SonosOnew/Alexa and a recently purchased Echo Dot to discover smart home devices. I use Insteon devices via software/hardware provided by Indigo.com. Indigo has a plugin called Hue Bridge which is supposed to emulate this device but several attempts yield nothing.
New Strategy: I will purchase an Insteon Hub 2245-222 which is supposed to directly communicate with Alexa (there is an Insteon skill that can be enabled). Hopefully that will cure my woes and I'll be happily controlling my lights and scenes. I'll report back.
Userlevel 7
Badge +20
The only thing I can think off then is to follow the steps I've listed in this post to rest the Amazon Alexa authorisation:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-alexa-issues-6796539/index1.html#post16180399

Merry Christmas 🙂
Badge
Already tried this multiple time, same with the Hue skill. Disable and re-enabled, on the app and on the Alexa-Website.
Userlevel 7
Badge +20
You could try disabling the Harmony skill and then re-Enabling.
Badge
Yes Music control works fine. Maybe I need to wait some time and hope for a newer firmware.
Userlevel 7
Badge +20
So I have a Harmony Hub and can control from my Sonos One fine. The same voice syntax works from my Echo devices and Sonos One. And you can control music via the Sonos One?
Badge
Ok, connected by Ethernet cable, reseted to be sure there is no connect to WiFi and via https://alexa.amazon.com/spa/index.html#appliances all devices forgotten. But still the same - what I need to say, when I discover it finds again all devices (19x Hue lights / 1x Harmony Hub / 1x Sonos Room) - but I can't control those from Sonos One.
Userlevel 7
Badge +20
The problem normally comes from your Amazon account or Spotify location but these would cause issues with your Echo devices as well, so we can assume that isn't the problem.

Can you try removing the Wi-Fi credentials under settings and connect the Sonos One directly to your Router via an Ethernet cable. Then using the PC version of the Alexa App (https://alexa.amazon.com) select Smart Home>Devices>Forget All followed by 'Discover. WARNING: If you have set-up Routines, this will remove all actions from all routines!

Retest
Badge
Yes that's true. But also Alexa is in general not supported in Switzerland and I use it since near 2 years. It's just not possible to add the location in Switzerland.

My Sonos One works in general, I can also use Alexa - only the Smart Home things are not working - wich are working well on my Echo devices.

I want wo Switch to Sonos One from my Echo devices because of the better Sound quality of Sonos, the possibility to control via app on the phone.
Userlevel 7
Badge +20
I just noticed you are from Switzerland, is this your current location? The Sonos One skill is currently only supported in the UK,US and Germany.
Badge
I see Sacha's Echo (Online) / Sacha's Echo Dot (Online) / Sacha's Sonos One (Offline) / Family Room (no status)

thank you very much to try to help me.

I have the feeling that I'm now troubleshooting since 3 to 5 hours ... disable/enable skill, reset of my Sonos One and reconfigure. Remove and reinstall the app on the phone. I also tried with a brand new Amazon Alexa Account with no other devices - my Sonos is online for some seconds and then it goes offline again. Firmware on the Speaker is 8.2.3 on the App 8.2.2
Userlevel 7
Badge +20
Within Alexa App>Settings>Devices there should two devices listed, one that matches the name within the Sonos app and another for the Alexa Component which if registered to you will be named Sacha's Amazon Alexa Enabled Play:1.
Badge
No the Device is names "Sacha''s Sonos One"
Userlevel 7
Badge +20
unfortunately i don't see this option :-(Can you confirm that you selected the device 'name' Amazon Alexa Enabled Play:1?
Badge
unfortunately i don't see this option 😞
Userlevel 7
Badge +20
Please select Alexa App>Settings>Devices>'Your Sonos One' you should see an option to turn 'On Line'.
Badge
thanks i tried that, but no success, I strugle on the last step:

Select 'Discover' at the bottom of the screen. Ensure that your Sonos 1's are displayed correctly and not shown as 'Off Line'. Also ensure that there are no devices with the same name (To ensure my Sonos devices are not duplicated, I've added Sonos to the end of each of my players within the Sonos App. Remember, if you want to do this, rename before selecting 'Discover';


My Sonos One is shown as 'Off Line' 😞
Userlevel 7
Badge +20
Reset of the Sonos One. (Unplug from AC; press and hold button on rear of unit; plug into AC and wait for flashing amber LED). I tried that, but no success 😞 But thanks anyway!

If you are having problems please follow the steps I've listed in the Answer to this post:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-not-responding-to-alexa-comands-6793239
Badge
Reset of the Sonos One. (Unplug from AC; press and hold button on rear of unit; plug into AC and wait for flashing amber LED). I tried that, but no success 😞 But thanks anyway!
Userlevel 5
Badge +6
I also had the Sonos One showing as "offline" in the Alexa app. I fixed this by going into my Amazon account on my laptop and deleting the Sonos One from my Amazon devices. I then rebooted the speaker. Finally, I added it back into the Alexa app. Everything now works. Hope this helps.
Userlevel 2
Badge
Reset of the Sonos One. (Unplug from AC; press and hold button on rear of unit; plug into AC and wait for flashing amber LED).
Badge
Factory reset of what? I already disabled/enabled the harmony and hue skills. Removed and re-added the voice service. With my Echo and my Echo dot all works perect, not with the Sonos One. Also One doesent seems do recognize IFTTT triggers.
Userlevel 2
Badge
My Lutron Caseta works perfectly with my echo dots and Sonos One. What you mat want to do is a factory reset, remove all from the Alexa app or Amazon login and start again.
Badge
Same here, Hue doesent work, Harmony Hub doesent work.
Userlevel 1
Badge
JDW712 Have you try removing your skill from from echo dot and add it again it worked for me I have no more issues controlling my light lock my front door open my garage door list goes on for me it worked since I did it


Michel