Question

sonos one alexa

  • 25 January 2020
  • 9 replies
  • 97 views

Userlevel 2

When I ask Alexa on my Sonos one to play rotary radio I get the following message.  It’s the only radio station that does it.  If I select the same station from my radio stations in the Sonos app it works fine. 

 


9 replies

Userlevel 5
Badge +13

Hi @Sponge, just so I can check to see if I’m understanding the issue correctly; you can start playback on other Tune-In stations through Amazon Alexa and you can start playback on this station manually through the Sonos app but you cannot start playback on this station using Alexa. Have you tried adjusting the command syntax to be more specific to the Rotary UK station? If you ask for  “Alexa, Play Rotary UK Radio from Tune-In...” vs. “Alexa, Play Rotary Radio United Kingdom” is there any difference in playback behavior? Is there a specific Alexa skill for this station in your app that may need to be enabled or disabled?             

Userlevel 2

Hi Jean, you are correct in your understanding. There is a Rotary Radio skill and when I say Alexa play rotary radio on my Sonos One I get the response “enjoy” but nothing plays. When I then go to the Sonos app I get the above message. I will add that my echo dot plays Rotary Radio when asked. 
 

Userlevel 5
Badge +13

Thank you for the additional information @Sponge. Can you try disabling the Rotary Radio skill in Alexa and then test the voice command  on your Sonos One?

Sometimes Alexa skills trip-up radio stations available though Tune-In. If turning off this skill works, we’ll have to test it to see if it negatively impacts the echo speaker’s ability to playback the same.    

Userlevel 2

Thanks for your response.  I’ve done as you suggest and with the skill disabled neither of my devices will play Rotary Radio. Below is screenshot using Alexa, below that is a screenshot of the station play from my stored stations within the Sonos app  

 

Userlevel 5
Badge +13

Hi, @Sponge, thank you for the screen shots!

Is the MyTuner skill added to Alexa or is it added as a service to Alexa?  

With the service added to both Sonos and Alexa, try asking for “Rotary Radio UK on MyTuner” and see if playback works.   

A diagnostic report from your system might help me see if there is anything else behind the scenes that could be derailing this.

Please follow these steps: 

Settings > Help&Tips > Submit Diagnostic

and the post back with the confirmation number so i can take a look.

Userlevel 2

the my tuner skill is added to Alexa, I’m not sure what you mean by adding the service to both?

diagnostic report 45455

 

thanks for your help.

Ray

Userlevel 5
Badge +13

Hi there @Sponge I’m sorry for the delay on responding to your post.

What I meant was that you want to make sure that “MyTuner” skill/service is added to Alexa and that My Tuner is also added to Sonos but that the specific skill for the Rotary Radio isn’t enabled on Alexa.

On your diagnostic I can see that MyTuner is now added to Sonos, is the general “MyTuner” skill enabled on Alexa?   

It also looks like one of your surround speakers is wired to your network and creating Sonosnet.

Is it possible to either wire your Playbar or wire your Sonos One to the network instead to see if this changes anything in the voice service response.

 

 

Userlevel 2

I’ll give it a go and let you know. Screenshot below showing the skill enabled on Alexa

 

Userlevel 5
Badge +13

Hi @Sponge I’ll need you to disable the “Rotary Radio UK” specific skill but make sure that the My Tuner skill only is enabled:

 

Reply