Question

Sonos no longer responding to Alexa commands: Spotify and audible

  • 6 January 2019
  • 10 replies
  • 914 views

Over the last few days my sonos one and beam will no longer play Spotify based on Alexa requests. I can direct music to them via the app and voice commands to my Echo dot will play spotify. They will play tuneIn stations via Alexa. I can adjust Spotify volume by voice but I can’t start music or pause or stop it. I have the same issue playing audible.
I’ve de-authorized and re authorized and tried all the steps in answers provided in other threads by ukmedia (including powering all sonos off and starting a new set up). Diagnostic 850972675. Not sure what else I can do?

10 replies

Badge


Hi there. I have occasionally experienced a similar problem as the original poster.
Occasionally I will ask Alexa "Play Rap Caviar" and it will say "Playing Rap Caviar Spotify" but nothing happens. It will respond correctly to commands regarding Pandora, SiriusXM, etc but not spotify. In addition, if I start a spotify playlist from the app Alexa will occasionally say "cannot skip to the next song at this time."

I was wondering if this could have anything to do with duplicate devices on my Alexa account?

I recently had to exchange a Beam after several factory resets did not resolve an issue. I also remember having to perform a factory reset during my initial setup 7 months ago.

When I log into Alexa and look at the devices section there are more devices there then I have active in Sonos. I included a screenshot. Is it normal for Alexa to create a separate device designation like Luis's 5th Sonos one when I have named it Yoga Room in Sonos?

Should I do some deregistering?

Here is my set up.
Cat5 cable to modem with wifi disabled -> ethernet cable to Linksys Velop Mesh system
Karla's Kitchen = sonos one
Love Shack = sonos one
TV Room = playbase, sub, two sonos ones
Yoga Room = sonos one

Thanks a million!

Thank you for you’re quick response. I final got
it to work. I seem to have had connected the device twice. But under two different names if this makes sense. Thank you again!
Userlevel 7
Badge +20

I had this problem and found that I had made the Sonos the default music speaker in the Alexa App for 2 groups. Removed it from one group and then it works fine.i have the same issue. Can you kindly explain how to remove it step by step?

I'm newbie and couldn’t figure it out. Thanks! :)

Hi

Please open the Alexa App>Devices>Groups. Now select the Group that you want to change and then select Edit in the top Right corner. Just toggle the devices under the Preferred Speaker setting.
I had this problem and found that I had made the Sonos the default music speaker in the Alexa App for 2 groups. Removed it from one group and then it works fine.

i have the same issue. Can you kindly explain how to remove it step by step?

I'm newbie and couldn’t figure it out. Thanks! 🙂
I had this problem and found that I had made the Sonos the default music speaker in the Alexa App for 2 groups. Removed it from one group and then it works fine.
Userlevel 7
Badge +20
Hi

There's no impact on any other devices or any risk by assigning fixed IP addresses to Sonos - at worst things will remain the same. :)

Edit: Can you make sure that you aren't logged into Spotify on any other app on your device and retest?

It's good things are working via the app, here are my standard Alexa troubleshooting steps:

Sorry for the long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Thanks for all your tips. I tried the latest, but no success.
I did look and all my sonos are assigned dynamic addresses, and they are all on the low end (13-16). I didn’t want to change anything as I’m concerned about making things worse - at least I can use my sonos now via the app! I wasn’t sure what would happen if I just started reassigning address’s - I’m not network savvy. I do have a ticket open with sonos and I’ll try and speak to them directly tomorrow.
I’m just perplexed as Alexa will tell me the weather but not play Spotify (or audible). So it’s not like Alexa isn’t linked.
Anyway I do appreciate the time you’ve taken to help me.
Userlevel 7
Badge +20
Hi

With regard to commands:

1/ If you have set the default music service then there is no need to include Spotify in the command;
2/ There is no need to include the 'Room Name' when the command is given to the Sonos One.

I wonder if we are looking at this from the wrong perspective for this particular problem. This may be down to duplicate IP Addresses, commonly caused by booting a device or your router. Can you please power down the following devices for 5 secs, allowing each to complete its boot cycle before proceeding to the next device:

- Router
- Any Network wired switch
- Any wired Sonos devices
- All other Sonos devices
- All other attached network devices

If this fixes the problem, I suggest you open the Settings page on your Router and reserve IP addresses for your Sonos devices - I personally use the range 192.168.0.240 and above for my Sonos devices.
Hi @ukmedia. Thanks for the tips. Checked all of the above and the only thing that was a bit off was when I checked Alexa history to see what was heard. Alexa logged my request. When I clicked the details what was written was ‘shuffling songs by artist from Spotify.’ But what Alexa said ‘was sorry something went wrong’ and no music played. I’ve tried to phrase my request a lot of ways - play artist, play artist on Spotify, play artist on kitchen, play artist on Spotify on kitchen. Where artist is an artist I know is on Spotify. The first, play artist was working up to a few days ago. Appreciate the help!
Userlevel 7
Badge +20
Hi

A few things to check:

1/ Can you confirm what command you are using?
2/ Have you checked that Alexa is hearing you correctly in 'Alexa App>Settings>History'?
3/ Open the Alexa App and select 'Music, video & Books>Spotify'' - Click Go to Spotify App and check it goes to the correct Spotify Account.
4/ Open the Alexa App and select 'Settings>Alexa Preferences>Music & Media>Choose default music service' is Spotify selected as the default music library?
5/ Open the Alexa App and select 'Settings>Alexa Preferences>Music & Media>Spotify' and select 'Unlink account from Alexa'

Reply