Answered

Sonos Beam wont transfer to TV via Alexa anymore

  • 16 January 2020
  • 11 replies
  • 265 views

Hi All,

I purchased a Sonos Beam ~45 days ago.  I set it up with 65” TCL425.  Everything worked great until about a week ago.  I can’t get the Alexa to switch the sound to the TV unless I power cycle the TV.  The voice command I was using was “Alexa, transfer to TV” and it use work.  When I try to do it now it says “hmm  I can’t transfer to that input, for a list of supported inputs please visit the list of supported devices”
 

I completely reset the Sonos Beam & TCL.  Still doesn’t work.  Any ideas?

icon

Best answer by Ken_Griffiths 19 January 2020, 10:17

A couple of other Alexa instructions  for  Sonos HT devices you may find useful are..,

“Alexa, Switch to Night Mode on Lounge" to turn on night mode.

“Alexa, Switch to Speech Enhancement mode on Lounge" to turn on speech enhancement via voice.

Hope that assists. 👍

 

View original

11 replies

I’m also a new Beam owner - bought mine a couple of weeks ago. This was working for me previously but I haven’t had to do it for a while. I just tried it and get a "I'm not quite sure what went wrong" message.

Workaround is to go into the Sonos app and select TV from the Browse menu.

See if this perhaps will work for you…

“Alexa, set mode to TV on Lounge” ...where Lounge is the “room name” of your Sonos HT device.

A couple of other Alexa instructions  for  Sonos HT devices you may find useful are..,

“Alexa, Switch to Night Mode on Lounge" to turn on night mode.

“Alexa, Switch to Speech Enhancement mode on Lounge" to turn on speech enhancement via voice.

Hope that assists. 👍

 

See if this perhaps will work for you…

“Alexa, set mode to TV on Lounge” ...where Lounge is the “room name” of your Sonos HT device.

Thanks, this alternative command worked for me.

Although it’s not as natural as just saying “Alexa switch to TV” so hopefully that command starts working again soon.

Just had the same problem. Got it working by saying “Alexa switch sonos to TV”

Just had the same problem. Got it working by saying “Alexa switch sonos to TV”

This one doesn’t work for me. Alexa just tells me it couldn’t find any video skills that could do that.

Userlevel 7
Badge +20

Have you tried Disabling and then Enabling the Sonos Skill in the Alexa App?

My new Sonos Beam is connected to my TCL TV with a HDMI Arc. I've then installed Amazon Alexa on my beam talktowendys.

I've had my Sonos beam since November and am also facing the same issue when switching back to TV volume. Worked every time until around about the start of January and now it says that the command is no longer supported.

Very annoying to have to switch the TV back on and off and sort of takes away the magic of having a voice assistant in the first place.

 Perhaps someone can confirm if thiis is definitely an issue from Amazon's point of view? 

 

 

 

I've had my Sonos beam since November and am also facing the same issue when switching back to TV volume. Worked every time until around about the start of January and now it says that the command is no longer supported.

Very annoying to have to switch the TV back on and off and sort of takes away the magic of having a voice assistant in the first place.

 Perhaps someone can confirm if thiis is definitely an issue from Amazon's point of view? 

So did you try ..“Alexa, set mode to TV on [Sonos Room Name]” ??

Thank you for your reply. 

Just tried it and worked on the second attempt. 

Reply