Question

Sonos Beam with Alexa Won't Stay Connected

  • 3 November 2019
  • 4 replies
  • 71 views

Never had any issues with Sonos Beam until recently. Will not stay connected and Alexa won’t work. Did something change with all the recent updates? Help. Tried rebooting numerous times, no duplicate IP’s.


4 replies

Userlevel 7

Hi rfenner

Please Clarify….

Do you mean the Beam won’t stay connected to your network meaning you can’t see it in the Sonos App or Do you mean it won;t stay connected  to your TV?  Thanks!

 

It disappears in the app and Alexa will say “I’m having some issues at the moment… “

 

The TV is hardwired w/ an HDMI so that seems to work.

 

I’ve rebooted and re-added the system numerous times and it keeps happening. Rebooted the router, checked for duplicate IP’s - nothing seems to work.

Userlevel 7

Hi rfenner

If you have not changed your router or added range extenders try this (some may seem redundant). 

Note: If you have made changes to your network STOP. Let us know what changes were made as there may be other things to consider.

  1. Unplug all Sonos
  2. Unplug any other wireless or wired components to your router
  3. Check your routers admin page for updates and install if availble
  4. Reboot your router
  5. Sign out of Alexa in the Sonos App
  6. Delete the Sonos Skill in the Alexa app
  7. Sign out of the Alexa app
  8. Power cycle your Android/iOS device
  9. Make your your iOS/Android device is up-to -date
  10. Make sure the Sonos app is up-to-date
  11. Plug-in your Sonos 1x1...let each come back before moving to the next
  12. Sign into the Alexa app
  13. Enable the Sonos skill
  14. Sign into Alexa in the Sonos app
  15. Plug-in your other wireless and wired products 1x1...let each come back before moving to next.
  16. Test your Sonos and Alexa

If the problem continues submit a diagnostic within 10 minutes of the occurence, post the reference ID in this forum, contact Sonos tech support by phone, Twitter or face book. The latter two are 24/7.

Let us know how things sort out.  Cheers!

Not sure if you solved this problem but try changing channel on your router I had same problem changed channel from 1 to channel 11 and this fixed the problem

Reply