Answered

Sonos Beam : Return to TV

  • 27 July 2018
  • 7 replies
  • 18861 views

  • Contributor I
  • 0 replies
Ryan S or anyone who works at Sonos, its inconvenient to have to say “switch to tv” every time we want the Beam to play tv sound.

Since the soundbar is first and foremost for Tv, can you default the Beam to automatically switch itself back to Tv mode after playing music? That would create a more seamless experience
icon

Best answer by jgatie 27 July 2018, 16:13

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 3
Badge +2
Hi Sean, the easiest way to get the Beam to switch is simply to ask. If you have Alexa enabled, just say "Alexa, switch to TV." This command will have the Beam drop out of the group, and swap over to the TV input.

Alternative commands are:

"Alexa, switch to TV on [room name]"
"Alexa, switch the [room name] to TV"


If you don't have voice control enabled, you can also turn off the TV (or mute it) for 10 - 15 seconds or so, then turn it back on. The Sonos setting "TV Autoplay", if enabled, will have the Beam switch to the TV input when it detects a new signal on the HDMI, and you can set the grouping behavior of if it stays in group or drops out in the Room Settings.


The comment that worked for me previously since getting the beam was "Alexa switch living room to TV". However, since the last update (or possibly unrelated to the update since I didn't try for a few weeks prior) the command doesn't work. Neither does "Alexa switch to TV".

Any ideas?
Userlevel 7
Badge +26
Hi Sean, the easiest way to get the Beam to switch is simply to ask. If you have Alexa enabled, just say "Alexa, switch to TV." This command will have the Beam drop out of the group, and swap over to the TV input.

Alternative commands are:

"Alexa, switch to TV on [room name]"
"Alexa, switch the [room name] to TV"


If you don't have voice control enabled, you can also turn off the TV (or mute it) for 10 - 15 seconds or so, then turn it back on. The Sonos setting "TV Autoplay", if enabled, will have the Beam switch to the TV input when it detects a new signal on the HDMI, and you can set the grouping behavior of if it stays in group or drops out in the Room Settings.
I'm not sure if the actual question has been answered - Here is the scenario:

1 - turn on TV, bean connects, playing TV sound without issue.
2 - I turn on music on another SONOS speaker and then group it with the BEAM.

-- At this point - both the BEAM and the other Sonos speaker are playing music(not TV Audio).

3 - Now I want to return the BEAM to playing TV sound.

-- Do i need to restart the TV?
-- Isn't there a way to return AUDIO out from the TV to the beam?
Userlevel 1
Badge +2
And I did have that checked. OK. Thanks for that!
Perhaps you have the 'ungroup on autoplay' option ticked?
Userlevel 1
Badge +2
I don't want to hijack the thread, but my question was similar, but reversed. The TV AUTOPLAY seems to work well with my BEAM. TV audio seems to override any music. Lovely. Works great.

My question is the reverse. What seems to happen is that after I turn the TV off and pull out the SONOS app to play music, we've lost the BEAM from the grouped rooms. So, I have to in and re-add it.
Is that how it's working for everyone else?
If so, seems a bit like a bug?

Would love to have the behavior be:
Is TV audio ON? If YES then MUTE MUSIC but don't ungroup BEAM.
You can set it to Autoplay when the TV is turned on by going to Settings->Room Settings->(Beam room name) and setting 'TV Autoplay' to 'On'.