Sonos Beam can't control smart devices in Alexa

  • 28 January 2022
  • 19 replies
  • 128 views

Badge

Hi,

I have a strange issue with my Sonos Beam and Alexa. Alexa is linked correctly in my Beam and responds to all my commands except for the ones to control smart devices.

Things that are working fine with my Beam when I ask Alexa:

  • Play music in spotify
  • Weather forecast
  • Open Skills
  • Execute my Routines
  • Play radio

The only thing that is NOT working is the control of smart devices such as switches or lights. If I ask Alexa to turn on my bedroom, it answers “I cannot find any device or group called bedroom”. But the same command on other Amazon echo devices that i have at home work fine. And this happens with any device… It’s really strange because the routines execute just fine, even the routines that turn on some lights…

This initially worked fine for about 1 year, but then stopped working in the last couple of months. So i don’t know what happened in between.

I contacted Sonos support and we unlinked the Beam from Alexa completely and added again from scratch with the same result. We also tried switching to wifi (I have it connected through ethernet cable) and the problem still persists.

I also contacted Alexa team and they say they don’t offer support of other manufacturers devices and cannot log in to this system.

So i don’t know what else can I do… My beam should still be under warranty until July 2022.

 

 


19 replies

Have you tried disabling the Sonos skill for Alexa, then re-enable?

And, of course, rebooting the Beam…

I would be surprised if this sort of issue was caused by a fault on your Beam.

Userlevel 7
Badge +20

This sounds like a naming issue to me.  Do you have a device called Bedroom listed in your Alexa App?

Please see my article: Tips and Tricks - Resolve Most Alexa Issues | Sonos Community

Badge

This sounds like a naming issue to me.  Do you have a device called Bedroom listed in your Alexa App?

Please see my article: Tips and Tricks - Resolve Most Alexa Issues | Sonos Community


It’s not really called Bedroom. It’s called Dormitorio in spanish. I have Alexa in spanish. And bedroom was an example… all the lights at home have the same behaviour.

Userlevel 7
Badge +20

This sounds like a naming issue to me.  Do you have a device called Bedroom listed in your Alexa App?

Please see my article: Tips and Tricks - Resolve Most Alexa Issues | Sonos Community


It’s not really called Bedroom. It’s called Dormitorio in spanish. I have Alexa in spanish. And bedroom was an example… all the lights at home have the same behaviour.

Have you checked for any duplicate names across devices and groups?

Badge

This sounds like a naming issue to me.  Do you have a device called Bedroom listed in your Alexa App?

Please see my article: Tips and Tricks - Resolve Most Alexa Issues | Sonos Community


It’s not really called Bedroom. It’s called Dormitorio in spanish. I have Alexa in spanish. And bedroom was an example… all the lights at home have the same behaviour.

Have you checked for any duplicate names across devices and groups?

Yes. no duplicates.

Userlevel 7
Badge +20

What make are the lights?

Badge

I have a bunch of tasmota switches all connected through Home Assistant.

Badge

I have tested more and it’s not all smart devices, I have found a couple that work.

It works with:

  • Smart devices through SmartLife skill (I have a bedside lamp and a power plug only).

It doesn’t work with (device or group not found):

  • My own Home Assistant skill (I imported haaska in developer mode, region EU - Ireland).
  • Philips Hue Bridge V1
  • Nuki skill
  • Aigosmart skill
  • LG ThinQ skill
  • Govee Home skill

It doesn’t work but it says “I can’t connect to the device”:

  • AC Cloud Control skill

All of them work fine with all the other Echos at home, this behaviour is only with the Sonos Beam.

 

I don’t know why SmarLife skill is working and all of the rest don’t work…

 

Any help would be appreciated.

Badge

Another thing that does NOT work is the news or news brief. When I ask alexa for the news she answers that I must define the news sources in the app, but I have already done that, and the other echos answer with the news...

Have you tried disabling and reenabling the Sonos skill for Alexa yet? Then 'discover devices'.

Badge

Have you tried disabling and reenabling the Sonos skill for Alexa yet? Then 'discover devices'.

Yes. And also removing alexa from the sonos app, removing sonos beam from alexa devices in amazon web, and staring from the scratch.

I was a bit puzzled by the references to Home Assistant.  Is that Google Home and if so how does that relate to Alexa?

Badge

Home Assistant is a free software to control smart devices from all kind of brands locally. To acces to your home assistant instance from alexa you have to create a developer skill (there’s one template files called haaska that you just import) and link it to your alexa account. Then you can control all your devices in your home assistant instance from alexa.

I think that the same can be achieved to google home but I haven’t tested because I don’t use google home.

If the integration woth home assistant was the only one failing I could think of doing something wrong from my side, but there are more skills not working and also the news… so I don’t know…

You said at one point '..the other Echos answer me...'

That implies that you think of Sonos voice enabled speakers as Echo devices. But they certainly aren't that and don't claim to be. Perhaps that is not relevant here, or maybe there is some relevant feature that is implemented differently.

Badge

Well, I mean the official amazon echos. The Sonos Beam is certified by Alexa, so almost all the features should be the same. Also it worked in the past, but not anymore…

Userlevel 7
Badge +20

Did you fix this issue?  I only use Home Assistant to link in to Hubitat, which then exposes devices to Alexa.  These devices can all be controlled by Sonos and Amazon devices, I’m wondering if this is a Home Assistant issue?

Badge

No, I still have the issue. I don’t think it is a Home Assistant issue as the problem is also with other smart home skills and also with the news.

Userlevel 7
Badge +20

Pergaps this is a duplicate IP issue, rather than an Alexa one. Can you check my post here: Tips & Tricks - Resolving random issues impacting Sonos devices.. | Sonos Community

Badge

I don’t think so. I have a reserved IP address in my DHCP server for the beam...

Reply