Answered

Problem with Alexa routine using Sonos One

  • 16 June 2022
  • 4 replies
  • 75 views

Userlevel 1
Badge +1
  • Trending Lyricist I
  • 29 replies

Guys I have the following routine running with my Sonos One pair(I have two Sonos One namely Sonos One Left, Sonos One Right)

When I say the voice command the routine does the following:

 

  1. Set volume to 1: Works Perfect
  2. Says a phrase: Works Perfect
  3. Turns Off the Master Bedroom Light - Works Perfect
  4. Starts playing music for 15 min on Spotify - Works Perfect
  5. Issue the Alexa Stop Music command to stop playing the music - Works Randomly. When it is not working, the music keeps playing after the 15 minutes until the playlist is finished. 

This has been driving me crazy for a while now. I have changed step 5 in stopping the music but again it worked randomly. It is like for a reason step 5 is missed or not executed at all.

 

icon

Best answer by Corry P 21 June 2022, 17:33

View original

4 replies

I can’t tell you why the ‘stop music’ command it’s working, but it looks like you can set a timer when you request to play music via a routine.  Did that option not work?

Userlevel 1
Badge +1

@melvimbe

If you are referring to this

 

 

 

I do not know.  But what you are saying, which makes perfectly good sense, is that the timer for a reason might be skipped.  The timer won't stopped the music after it elapses. It just runs the next step in the routine. 

Userlevel 7
Badge +18

Hi @03397 

Thanks for your post!

If you’re still having this problem, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

Userlevel 2
Badge

@03397

I had the same issue as you and tried both the 

 

“Alexa Stop Music” Command 

 

and the 

 

“Timer” tick box within the “Music and Podcasts” Routine settings as per @melvimbe suggestion above and neither option would work for me and music would never stop at the desired time fence

 

However I managed to get it working perfectly by applying the setting below

 

No “Alexa Stop Music” Command and no “Timer” tick box in the Alexa Routine

 

I simply added the desired play duration at the end of my music selection as per image below

 

So in your example above the desired text string would be

 

“Play Relax Music Shuffle on Spotify for 15 Minutes”

 

I tested this with the commands “Seconds”, “Hours” and “Minutes” and it all seems to work when paired with a numerical value.

 

It shouldn’t be this hard (or this badly designed) but this has worked fine since I tried this tweak but it should be noted that I tested with a Radio Station (In my test LBC London) as opposed to a playlist but think the duration setting would work whatever the music source is.

 

 

Reply